Connection and speed

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Connection and speed
Connection and speed
2020-12-23 07:03:05
Model: Archer C50  
Hardware Version: V4
Firmware Version: 190125

I bought this router a week ago it already showing problems. Internet speed slows down in between and router range is also decresing inbetween. 

0
0
#1
Options
6 Reply
Re:Connection and speed
2020-12-24 07:10:12

@atharwa 

 

Hello, does it mean the current internet speed is not good enough and the Wi-Fi will disconnect?


When did you purchase this Archer C50? Was it working fine before? Please ensure you are running the latest firmware, you may try to reset it to factory defaults and reconfigure it from scratch, then confirm the speed again.


BTW, what is the network bandwidth you got from your ISP? What is the speed you can get when you connected to the ISP modem directly? Please leave all the settings by default on the C50 when doing the reconfiguration, monitor the speed first.

 

As for the Wi-Fi connect issue, please confirm if you are connecting to the 5G network or to the 2.4G? You may try to modify the wireless settings on the C50, such as changing the 2.4GHz wireless channel to 1/6/11, channel width to 20MHz; changing the 5GHz channel to a clear one as well, such as 44/48, channel width to 40MHz, then reboot the router and reconnect to the network to confirm.

0
0
#2
Options
Re:Connection and speed
2020-12-24 13:37:41
I bought it a week ago and it was working fine for 10 days but after that it started giving me problems like slowing speed in between and ping goes very high and i tried what you said i made those change it is still slowing speed of internet and giving high ping
0
0
#3
Options
Re:Connection and speed
2020-12-25 03:50:02

@atharwa 

 

Hi, can we have more details about the slow speed and high ping issue, what is the network bandwidth you got from your ISP? What is the speed you can get when you connected to the ISP modem directly? Please leave all the settings by default on the C50 when doing the reconfiguration, monitor the speed first.

 

How do you monitor the ping? Any screenshot?

0
0
#4
Options
Re:Connection and speed
2020-12-25 09:23:19

@Kevin_Z    My broadband speed is 5mbps and it is good enough for me and it was giving me same exact speed before as well from  my previous router and this router as well but after 10 or 12 days it started giving me high ping, slow internet speed inbetween problems like this. And i am checking my ping on commant prompt  and before it had never given me this problems

0
0
#5
Options
Re:Connection and speed
2020-12-25 11:24:15

@atharwa 

 

Hi, thanks for the screenshot. Try to upgrade the firmware to the latest, then reset it to factory defaults by holding the reset button on it until all the LEDs flash, then reconfigure it from scratch to confirm:

https://www.tp-link.com/support/download/archer-c50/v4/#Firmware

 

BTW, you can also try to change the DNS server on the C50 WAN to 8.8.8.8 or 1.1.1.1, reboot it and reconnect to the network to confirm.

0
0
#6
Options
Re:Connection and speed
2020-12-29 08:06:08

@Kevin_Z I tried that but it didn't work 

0
0
#7
Options