Connecting Deco S4 to ISP Modem

Connecting Deco S4 to ISP Modem
Connecting Deco S4 to ISP Modem
2020-12-24 00:43:19 - last edited 2020-12-28 03:18:20
Model: Deco S4
Hardware Version:
Firmware Version:

Hi,

 

I am trying very hard to connect my S4 to my ISP modem. It is a pure modem and NOT a modem router.

 

I have also watched the video https://fb.watch/2zCmMDb2VE/ and my ISP is Singtel.

 

I have used the following settings.

 

 

 

I can create the WiFi. However once it try to test the Internet connection, the light on the S4 will turn red and the following error show.

 

 

My Internet is working fine. I have contacted TP Link helpdesk and Live Support. TP Link help desk wanted me to unplug all the network and power cables from the S4 and my ISP modem for 30mins. I have done so but it didn't work.

 

TP Link live support Carlo tried to help (a big shout out to him) but failed too. He has suggested do a reset on all Deco units which I have done. However the call is drop off due to some technical reasons.

 

I do not need any username or password from Singtel to connect to the Internet.

 

Now I am currently connecting my Deco S4 to my Archer C9 and then my Archer C9 connecting to my ISP modem. This work. However this is not what I want.

 

I want to connect my S4 directly to my ISP modem, removing the C9 from the setup.

 

Any suggestions?

 

Thanks.

0
0
#1
Options
1 Accepted Solution
Re:Connecting Deco S4 to ISP Modem-Solution
2020-12-25 07:48:03 - last edited 2020-12-25 07:58:23

@mousehunt 

Good day,

Sorry for the delay.

Based on our experience, I think you might need to enable IPTV/VLAN and choose SG-SingTel when choosing the internet connection type.

Or go to more>advanced>IPTV/VLAN and enable internet VLAN and choose Singapore-Singtel.

Thank you very much and wait for your reply.

Recommended Solution
0
0
#2
Options
2 Replies
Re:Connecting Deco S4 to ISP Modem-Solution
2020-12-25 07:48:03 - last edited 2020-12-25 07:58:23

@mousehunt 

Good day,

Sorry for the delay.

Based on our experience, I think you might need to enable IPTV/VLAN and choose SG-SingTel when choosing the internet connection type.

Or go to more>advanced>IPTV/VLAN and enable internet VLAN and choose Singapore-Singtel.

Thank you very much and wait for your reply.

Recommended Solution
0
0
#2
Options
Re:Connecting Deco S4 to ISP Modem
2020-12-25 12:42:19

@TP-Link 

 

It works! Thanks! 

2
2
#3
Options