Archer C80 AC1900 - unable to disable 5G

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.

Archer C80 AC1900 - unable to disable 5G

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Archer C80 AC1900 - unable to disable 5G
Archer C80 AC1900 - unable to disable 5G
2020-12-28 13:20:34 - last edited 2021-01-01 10:04:31
Model: Archer C80  
Hardware Version: V1
Firmware Version: 1.5.0 Build 201022 Rel.53112n(4555)

Hello, I have this issue with Archer C80 AC1900 brand new router:

 

when I disable (and save config) the 5G WIFI, after a few minutes , the 5G wifi network keeps enabling back.

 

Is there any way I can solve this issue ?

 

 

after a few minutes later , the 5G appear enabled on network list and in the router setings:

 

Any help is appreciated. Thank you.
Jujo S

 

  0      
  0      
#1
Options
8 Reply
Re:Archer C80 AC1900 - unable to disable 5G
2020-12-28 13:26:58 - last edited 2021-01-01 10:04:31

Try to hard reset (Method 1) the device and reconfigure from scratch.

If this was helpful click on an arrow pointing upward. If this solves your issue, click the star to mark it as a "Recommended Solution".
  0  
  0  
#2
Options
Re:Archer C80 AC1900 - unable to disable 5G
2020-12-28 14:45:59

@Ivaylo problem solved (so far) with hard reset (Method 1).

 

Thank you !

  0  
  0  
#3
Options
Re:Archer C80 AC1900 - unable to disable 5G
2020-12-30 13:15:12

@Jujosan 

the same thing happened to me.

Try this: do all the settings from the web but turn off the 5Ghz radio from the app, it worked for me.

  0  
  0  
#5
Options
Re:Archer C80 AC1900 - unable to disable 5G
2020-12-31 03:04:43

Thanks @Ivaylo for reminding.

 

@Tavocampana 

 

Do you own an Archer C80 also? Can I have a more detailed issue description about it? What kind of setting on the Tether APP will re-enable the 5G signal on the C80? Thanks a lot.

VPN Survey for Routers | Allow us to Understand Your VPN Service Requirements.
  0  
  0  
#7
Options
Re:Archer C80 AC1900 - unable to disable 5G
2021-01-01 10:18:26

@Kevin_Z 

 

It seems I finally found the software bug. It has nothing to do with the android app. It is in the router software.

When I enable "Wireless Schedule", the 5G  goes ON  automatically  and will re-enable each time I disable-it.

When Wireless Schedule is OFF, everything is fine. 

Please note that all my tests were made outside the time interval set in "Wireless Schedule".

 

  0  
  0  
#8
Options
Re:Archer C80 AC1900 - unable to disable 5G
2021-01-04 03:32:42

@Jujosan 

 

Thank you so much, we will soon check and investigate this.

VPN Survey for Routers | Allow us to Understand Your VPN Service Requirements.
  0  
  0  
#9
Options
Re:Archer C80 AC1900 - unable to disable 5G
2021-04-22 18:43:34 - last edited 2021-04-22 18:45:58

@Kevin_Z I have the same problem as Jujo, after turning on the wifi schedule, the 5GHz network will turn on immediately. After manually switching off this network, it switches on again automatically after some time. If the wifi schedule is inactive, 5Ghz does not turn on. The last update did not fix this bug, any solution? THX

  0  
  0  
#10
Options
Re:Archer C80 AC1900 - unable to disable 5G
2021-04-28 07:02:17

@spacewalker 

 

As confirmed with the engineer, the Wi-Fi Schedule will enable both 2.4GHz and 5GHz at the same time. While this would be optimized in the future firmware update, you may keep an eye on the official website for new firmware updates in the future.

VPN Survey for Routers | Allow us to Understand Your VPN Service Requirements.
  0  
  0  
#11
Options

Information

Helpful: 0

Views: 1247

Replies: 8

Related Articles