Deco X60 problems after the recent firmware update

Deco X60 problems after the recent firmware update
Deco X60 problems after the recent firmware update
2020-12-30 07:46:31
Model: Deco X60
Hardware Version: V2
Firmware Version: 1.0.5 Build 20201013 Rel. 64247

My Newly bought Deco X 60's firmware was recently updated. Post the update i noticed the Internet speed was dropped and was not matching the speed of my service provided. On contacting the customer care, they advised me to reset the deco. On resetting the Deco, the speed came back to normal as before and was working fine. But post that i started noticing the internet connection is getting frequently dropped across devices for unknown reason.

 

I am not sure if this issue is related to the Deco's firmware upgrade, but need help to understand how should I resolve this issue. Beofre the Firware got updated, my Deco was working perfectly fine across all devices in my house. But after this upgrade I am constantly facing different unexplained issues.

1
1
#1
Options
5 Reply
Re:Deco X60 problems after the recent firmware update
2020-12-31 05:16:46
my x20 after upgrade also having the same problem, but after i downgrade firmeware the internet speed is back to normal
0
0
#2
Options
Re:Deco X60 problems after the recent firmware update
2020-12-31 09:38:57

@SChaugule Thank you. But i am not usre if we can down grade the update.

 

When i contacted the helpdesk, they asked me to reset the Deco, which i did and the speed went back to normal however now my devices keep dropping the internet.

0
0
#3
Options
Re:Deco X60 problems after the recent firmware update
2021-01-08 02:23:55
u can downgrade from ur computer type 192.168.68.1 log in to ur acc deco then go to setting at that page can down grade ur firmware
0
0
#4
Options
Re:Deco X60 problems after the recent firmware update
2021-03-31 19:54:33

@jrtham 


I have same issue on my X20! Download drops randomly to 90-95mbps and won't be back to normal (490-500mbps) before I do a restart or take the power out. I'm running firmware 1.5.0 and I didn't have the problem before the two newest updates.

0
0
#5
Options
Re:Deco X60 problems after the recent firmware update
2021-04-09 06:52:13

@Orskaug 

try downgrade back the stable firmware the will back to normal

 

0
0
#6
Options