Archer C6 with Google Mesh - Double NAT

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Archer C6 with Google Mesh - Double NAT
Archer C6 with Google Mesh - Double NAT
2021-01-13 05:28:15
Model: Archer C6  
Hardware Version:
Firmware Version:

Hello. I'm using an Archer C6 as my primary router, effectively as a modem, with Google Mesh wifi to extend wifi across the house. 
 

I get double NAT with the setup.  Any fix? 

 

Understand the simplest solution is for the Archer C6 to be put into bridge mode but I can't work out how to do that.  It's not WDS bridging as the Google

Mesh router is connected direct to Archer C6 via ethernet cable, so bridging is done wireslessly.
 

I welcome any solution that effectively turns C6 into modem and eliminates double NAT

0
0
#1
Options
3 Reply
Re:Archer C6 with Google Mesh - Double NAT
2021-01-13 08:44:31

@wjmrogers 

 

The Archer C6 is not a modem, so there is no way to change it into a bridge mode. What I have understood from your description, it seems that it is not necessary to put the Archer C6 between the modem and the Google Mesh Wi-Fi, you can just connect the Google Mesh Wi-Fi to the ISP modem directly, do the settings you have on the Archer C6, then the internet should work.

 

Please correct me if I'm wrong. Thanks.

0
0
#2
Options
Re:Archer C6 with Google Mesh - Double NAT
2021-01-13 09:27:18

@Kevin_Z sorry, to clarify: The issue is that in Australia, our Nation Broadband Network, which is provided by the various ISPs, doesn't support Google

WiFi. Something about VLAN tag requirements.  So I have to put a intermediary router in between (one which does - Archer C6). I then use Google WiFi to extend the wifi over the hole house, which creates double NAT. Was wondering if there was any work around. 
 

thanks for the help. 

0
0
#3
Options
Re:Archer C6 with Google Mesh - Double NAT
2021-01-13 11:12:17

@wjmrogers 

 

I see. Is it possible to change the Google Wi-Fi to AP mode, which will avoid the double NAT issue in the network?

0
0
#4
Options