Archer c6 ports are limited at 100 mbit/s

Archer c6 ports are limited at 100 mbit/s
Archer c6 ports are limited at 100 mbit/s
2021-01-19 16:12:18 - last edited a week ago
Model: Archer C6
Hardware Version: V2
Firmware Version: 1.3.6

Hello,

I've seen many posts regarding this Archer c6 problem but none of them have a proper solution for it.

The problem is pretty much the same: the LAN ports are capped at 100 Mbit/s while the actual speed should be 400 Mbit/s. 

 

Archer c6 is connected to the Vodafone router (model: Arris TG3442DE) which also has 4 Gbit LAN ports, and the Arris router is connected to an internet line.

When my laptop is connected with the cable (CAT 6) to the Arris router LAN port, the speed is around 370Mbit/s (which is accurate), but when I connect the laptop to the Archer c6 LAN port with the same (CAT 6) cable, it only shows 95-97 Mbit/s, no matter how many times I measure. 

 

I tried this with both mods on Archer C6: access point, and router - the result is the same.

 

I also tried the instructions that were provided in the previous threads: in the router system settings the duplex is set to 1gbps; in my network adapter settings the duplex is set to full 1gbps; my network adapter is Realtek PCIe GbE Family Controller.

Attaching the screenshots as well. The laptop is connected to LAN port 3, it shows a 1Gbit full duplex, LAN ports 1 and 2 are offline (screenshot 1). 

Thank you in advance for any solutions.

 

0
0
#1
Options
1 Accepted Solution
Re:Archer c6 ports are limited at 100 mbit/s-Solution
a week ago - last edited a week ago

Thank you for your help @Ivaylo  and @Kevin_Z.

The issue is resolved now. 

 

To all users from Germany that use Vodafone internet provider with their default router (Arris TG3442DE in my case), in order to access 1GB\s speed on your second router (Archer c6 in my case) connected to the default router with CAT 6 cable, you need to do the following:

- register on their website (Mein Vodafone);

- go to settings -> internet settings and disable hotspot (it is activated by default);

- set up your second router in bridge mode (I used this tutorial);

- wait 7 days until the hotspot will be disabled (there is no way to do it faster).

 

And that's it. After my hotspot was disabled I got the speed I was looking for.

If this doesn't help you, then try to set up your default router in the bridge mode (mein vodafone > settings > internet settings > set bridge mode).

 

This thread can be closed, thank you.

Recommended Solution
3
3
#6
Options
6 Replies
Re:Archer c6 ports are limited at 100 mbit/s
2021-01-19 22:16:39 - last edited 2021-01-19 22:20:08

@Inquisit0r 

 

Are these screenshots from AP mode ? I supose you're using the C6 in AP mode.

If yes, would you check in Basic=>Network Map that the correct number of Wired/Wireless clients are reported by the device ?

I presume you don't have QoS configured at the moment.

There's no obviuos reason your internet connection to be limmited to 100 mbps, when the device port (LAN3) and your laptop's Realtek LAN adapter are connected @ 1 gbps.

The Internet port is also connected @ 1 gbps. (visible from the C6 interafce).

What if you set Duplex setting to: Auto negotioation. Does the C6 Internet port, LAN3 port or your laptop lan adapter speed change ?

 

0
0
#2
Options
Re:Archer c6 ports are limited at 100 mbit/s
2021-01-20 15:26:05

@Ivaylo 

The screenshots are done when the Archer C6 was in router mode.

Yes, QoS is off right now. 

The wired and wireless device amount is correct too.

When the duplex is set to auto negotiation the LAN 3 port (laptop) shows 1000Mbit/s. Tried also other ports, they show 1000Mbit/s too, but the speed is still capped at 100Mbit/s.

I attached the screenshots from my Arris router (to which Archer c6 is connected), it also shows 1Gbit/s.

Do you recommend turning on QoS?

 

0
0
#3
Options
Re:Archer c6 ports are limited at 100 mbit/s
2021-01-20 16:12:02 - last edited 2021-01-20 16:24:42

@Inquisit0r 

 

Regarding QoS, I asked, because I thought if you have set some kind of a priority, it may causing that, but obviously you didn't.

For the following, I have meant in AP mode - "...would you check in Basic=>Network Map that the correct number of Wired/Wireless clients are reported by the device ? "

If the speeds on both C6 LAN3 and main router LAN are 1gbps then better leave it to Auto Negotioation.

Do you have another client device to test with, except that laptop and your mobile ? Actually, what's the speed if you test with the mobile and laptop (via C6 wireless ) ?

0
0
#4
Options
Re:Archer c6 ports are limited at 100 mbit/s
2021-01-21 06:42:45

@Inquisit0r 

 

Just to add, what if you try to reset the C6 to factory defaults by holding the reset button, then reconfigure it all over, leave all the settings by default, then test the speed again.

 

BTW, what is the length of the cable between the C6 and modem, how about that between the PC and C6? We understand that the cable between these devices should be all good, but we still suggest you try with new and shorter cables to see if it will make any difference.

0
0
#5
Options
Re:Archer c6 ports are limited at 100 mbit/s-Solution
a week ago - last edited a week ago

Thank you for your help @Ivaylo  and @Kevin_Z.

The issue is resolved now. 

 

To all users from Germany that use Vodafone internet provider with their default router (Arris TG3442DE in my case), in order to access 1GB\s speed on your second router (Archer c6 in my case) connected to the default router with CAT 6 cable, you need to do the following:

- register on their website (Mein Vodafone);

- go to settings -> internet settings and disable hotspot (it is activated by default);

- set up your second router in bridge mode (I used this tutorial);

- wait 7 days until the hotspot will be disabled (there is no way to do it faster).

 

And that's it. After my hotspot was disabled I got the speed I was looking for.

If this doesn't help you, then try to set up your default router in the bridge mode (mein vodafone > settings > internet settings > set bridge mode).

 

This thread can be closed, thank you.

Recommended Solution
3
3
#6
Options
Re:Archer c6 ports are limited at 100 mbit/s
a week ago

@Inquisit0r 

That's fabulous, glad to hear that the issue is resolved now, this will help others who may encounter the same issue.yes

0
0
#7
Options