IP address reported as UNKNOWN for some devices connected to Deco M5

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.

IP address reported as UNKNOWN for some devices connected to Deco M5

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
IP address reported as UNKNOWN for some devices connected to Deco M5
IP address reported as UNKNOWN for some devices connected to Deco M5
2021-01-22 15:50:51 - last edited 2021-01-22 15:52:06
Model: Deco M5  
Hardware Version: V3
Firmware Version: 1.5.1 Build 20201022 Rel. 66804

When I wirelessly connect Roku 2 media player to Satellite Deco M5, it reports UNKNOWN IP address for that device in Deco app. Roku runs just fine, it is connected to Internet, speedtest is successful.

Also, my Android 9 smartphone shows its IP address properly when connected to same Satellite Deco M5. 

 

When I power off Satellite Deco M5, Roku reconnects to Main Deco M9, and then I can see its IP address in Deco app. 

 

Starting back M5 and forcing Roku to reconnect to M5 makes IP address dissapear in Deco app, reported as UNKNOWN. When I check Roku status through Deco Web interface, it is also reported with UNKNOWN IP address.

 

Deco mesh runs in Access Point mode.

 

This is minor annyance, really, not impacting mesh performance. Perhaps, there is some difference between firmware 1.5.1 for M5 and 1.4.3 for M9 that triggers this bug. Still worth escalating to Deco software developers, in my opinion.

 

Below are: screenshot of how Roku 2 is seen when connected to Deco M5, and screenshot of firmware versions of Deco nodes in my mesh.

 

 

 

 

 

  2      
  2      
#1
Options
4 Reply
Re:IP address reported as UNKNOWN for some devices connected to Deco M5
2021-05-19 09:03:32

@Alexandre. 

Hi,  I might miss this post before and I am quite curious whether you still suffered from this issue?

And I saw that both Deco M9 plus and Deco M5 have updated to the latest firmware; did the new firmware make any difference?

Thank you very much.

 

  0  
  0  
#2
Options
Re:IP address reported as UNKNOWN for some devices connected to Deco M5
2021-05-19 14:07:00

@TP-Link 

 

To fix that issue I had to power off all Deco units together, and reboot my ISP router. Just powering off/on Decos didn't fix the issue,

 

Not sure how it is related to ISP router, because it is Deco that reported unknown IP address, but this is what fixed it. My router: Hitron CODA-4582.

 

Haven't seen that issue since then.

  0  
  0  
#3
Options
Re:IP address reported as UNKNOWN for some devices connected to Deco M5
2021-05-20 01:09:37

@Alexandre. 

Thanks a lot for your reply.

I guess maybe Deco units are working on the access point mode and he thought DHCP was no longer his job.

But it is still quite strange since the APP could recognize it as an online client;

We have reported to the senior engineers and would keep attention to the similar feedback;

Thank you very much for your cooperation and support.

 

  0  
  0  
#4
Options
Re:IP address reported as UNKNOWN for some devices connected to Deco M5
2021-05-20 13:09:22

@TP-Link 

 

This is quite straightforward router, which doesn't care if there are other DHCP servers running on the network. I tested that in separate set of tests.

 

Also, while IP address was reported as unknown in Deco, I could see device with its proper MAC and IP address correctly reported by ISP router and shown as active. 

 

In any case, looks like it makes sense to bounce ISP router even if Deco runs in AP mode, when doing troubleshooting. 

  3  
  3  
#5
Options

Information

Helpful: 2

Views: 1861

Replies: 4