MAC address filtering issue on Archer AX73.

MAC address filtering issue on Archer AX73.
MAC address filtering issue on Archer AX73.
2 weeks ago - last edited Friday
Hardware Version: V1
Firmware Version: 1.0.1 Build 20200907 rel.76867(4555)

Hello.

 

I bought new great wifi router - Archer AX73. But I have an issue with MAC address filtering (white list).

I did a simple test:

- enable MAC address filtering with white list option and add few devices to white list (devices which use wifi and cable),

- restart router, and after restart the only cable devices can connect to my network, all wifi devices are blocked.

The "solution" is: disable MAC address filtering and restart router again, but it is not acceptable solution.

 

Also adding new MAC address to the existed white list gives no effect. After add new device, restart is required with disabled MAC filtering, and then enable it again.

 

Kindly want to ask you - do you have similar problems with Archer AX73 router? I believe it is firmware issue, but not sure...

 

Regards,

Maciej

 

0
0
#1
Options
1 Accepted Solution
Re:MAC address filtering issue on Archer AX73.-Solution
Friday - last edited Friday

@maciejp 

 

Received a beta version of the firmware. The problem is gone!

Recommended Solution
0
0
#33
Options
44 Replies
Re:MAC address filtering issue on Archer AX73.
2 weeks ago

@maciejp 

I confirm the problem.

 

0
0
#2
Options
Re:MAC address filtering issue on Archer AX73.
2 weeks ago

@maciejp 

Hi,

Have you enabled the private address on the wireless devices?

On the Android 10 or iOS 14 system, with Private Address turned on, each time it reconnects to the router's network, it will use a random MAC address, thus the router might recognize it as a new device and blocked it via whitelist.

And you could refer to the following suggestions:

Turn off the virtual MAC address feature on the device, then the device will connect with its actual MAC address;

iOS14:  Setting -> WLAN -> tap on the blue info icon at the left of the Wi-Fi name -> disable the Private Address feature.

(Picture refer to https://support.apple.com/en-us/HT211227

 

Android: Settings app -> Network and Internet -> Wi-Fi ->Connect to router’s Wi-Fi -> Tap the gear icon next to the current Wi-Fi connection -> Advanced ->  Privacy -> "Use device MAC"

 

Window 10: Setting -> Network and Internet -> "Wi-Fi" tab -> "Advanced Options." -> "Off" under "Random Hardware Address."  -> Restart your computer.

(Picture refer to https://it.nmu.edu/docs/disable-random-hardware-address-windows-10  )

Thank you very much and wait for your reply.

0
0
#3
Options
Re:MAC address filtering issue on Archer AX73.
2 weeks ago

@Kevin_Z 

 

Hi,

 

It is not Random Hardware Address issue.

I'm using static MAC address on all my wifi devices.

 

Regards,

Maciej

 

0
0
#4
Options
Re:MAC address filtering issue on Archer AX73.
2 weeks ago

@maciejp 

confirm.

static macs...

0
0
#5
Options
Re:MAC address filtering issue on Archer AX73.
2 weeks ago

@STN 

Sure

 

@Kevin_Z 

Could you confirm my simple testcase which reproduces a problem and forward information to support for prepare firmware update?

0
0
#6
Options
Re:MAC address filtering issue on Archer AX73.
2 weeks ago

@maciejp 

I confirm the problem. I sent a support request a few weeks ago.

0
0
#7
Options
Re:MAC address filtering issue on Archer AX73.
2 weeks ago

@STN 

Great, I did same 2-3 weeks ago via local tp-link support.

 

@Kevin_Z 

Could you help us? IMO, it is base feature (mac filtering) which must work fine.

 

0
0
#8
Options
Re:MAC address filtering issue on Archer AX73.
2 weeks ago

@maciejp 

 

Thanks for getting back. 

 

Just to confirm again, you are configuring the Access Control on the AX73, right? We have tested the Access Control feature on the AX73, and added devices into the whitelist, reboot the router, the devices still access the internet properly after the reboot.

 

If it is not Access Control, can you please show us the configuration screenshots on the AX73?

 

 

0
0
#9
Options
Re:MAC address filtering issue on Archer AX73.
2 weeks ago

@Kevin_Z 

 

Yes, exactly it is Access Control option with Witelist.

Please look at attached screen.jpg file.

 

File:
screen.jpgDownload
0
0
#10
Options
Re:MAC address filtering issue on Archer AX73.
2 weeks ago

@maciejp 

I acknowledge this failure.

If you enable the "Whitelist", then after reboot you cannot connect to WiFi: "Connection failure"....

No wireless client can connect. Notebooks, Smartphones, Robot - vacuum cleaner, TV... NO ONE!

Only wired clients work fine.

No connection to either 5GHz or 2.4GHz.

Smart Connect - no connection.

Although the networks themselves are broadcast on the air - I see them in a programs like INSSIDER.

I've tried changing all the options in the wireless settings.

If you turn off and then turn on, for example, OFDMA  from a wired client, then wireless clients will be able to connect.

It looks like some kind of re-initialization of the WiFi driver in the router is taking place.

But if you reboot the router again, the wireless connection is lost again. Regardless of the state of OFDMA  or other WiFi settings.

I've tried different encryption modes - the result is also negative.

Of course, the random MAC mode is disabled on clients.

I also do not use a hidden SSID.

White List and ARP only.

 

0
0
#11
Options