TL-WA1201 - DHCP Server Function - Unable to Disable

TL-WA1201 - DHCP Server Function - Unable to Disable
TL-WA1201 - DHCP Server Function - Unable to Disable
a week ago - last edited Thursday
Model: TL-WA1201
Hardware Version: V2
Firmware Version: 1.0.1 Build 20200709 rel.66244(5553)

Hello,

 

I own a TL-WA1201 Access Point and it appears to have a DHCP server function. I would like to disable this DHCP server as my router is providing that function (and the Wireless network and wired network are on the same subnet).

 

However, when I attempt to disable the DHCP function the web gui reports that it Failed.

 

Can someone assist with this please? It is set to Auto at the moment.

 

Cheers,

WSandMC

0
0
#1
Options
1 Accepted Solution
Re:TL-WA1201 - DHCP Server Function - Unable to Disable-Solution
Thursday - last edited Thursday

@TP-Link 

 

Just some progress here. I set the static IP address in the WAP's Network-->LAN settings and with the correct subnet mask (custom) 255.255.255.224 (I'm not using a /24) being served out for my range, and then tried again to save the DHCP server -> Disable setting and then it works.

 

To reproduce the issue, don't use a /24 but a /27 range in DHCP on the router instead and leave the LAN settings to Auto IP (DHCP). Then try to save the DHCP Server

 

Looks like some sort of issue with the LAN Settings or using DHCP and somehow getting the mask set incorrectly is causing the initial problem. Not really sure if this is a workaroudn or a solution. Probably a workaround.

 

I've used an Ip address outside the range of my DHCP server on the router but still within the 192.168.1.0/27 range to avoid a clash and am happy to work as it is.  The image below attempts to capture some of the success in saving the settings after switching to static IP address and setting the correct subnet mask.

 

 

Recommended Solution
0
0
#11
Options
11 Replies
Re:TL-WA1201 - DHCP Server Function - Unable to Disable
a week ago - last edited Thursday

@WSandMC 

 

By default, in Auto setting the AP should sense if there is an active DHCP server on your host router.

If there is, then the AP should switch off its DHCP server automatically -  basically as if you set its DHCP server to off.

You can refer the AP's user guide - chapter 3.3.

Are you experiencing different behavior ?

0
0
#2
Options
Re:TL-WA1201 - DHCP Server Function - Unable to Disable
a week ago

@Ivaylo Thanks for that info. Yes, it seems dormant at the moment set to auto and not serving out IP addresses on a single network setup. 

 

But I would prefer to be able to turn it off completely.

 

I can think of a use case where the DHCP server is not on a router but the router is using IP helpers to reach out to DHCP server sitting on a different box/network. I wonder if auto will work in this case?

 

Also, if TP Link are going to build an option to turn off the DHCP server completely, it should work.

 

Hopefully this gets fixed permanently instead of popping an error when you attempt to disable the DHCP server on the WAP.

 

Not sure if I'd recommend this product without the ability to disable the DHCP server completely. Let's just say it's lucky my current use case is supported by auto in that it doesn't serve out IP addresses as my router on the same network/subnet is doing it.  But there are other use cases which might result in the DHCP server becoming active when it shouldn't be. Like on a multi subnet network with DHCP IP helpers perhaps. Testing required to check this scenario, but rather just have the ability to switch off the DHCP server on the WAP completely than faff around with the auto setting hoping it behaves.

0
0
#3
Options
Re:TL-WA1201 - DHCP Server Function - Unable to Disable
a week ago

@WSandMC 

 

Completely agree with your thoughts. If the option is there - it should work.

About the use case when you are using router IP Helpers (DHCP server on a different box) - that should be tested to see if it behaves.

I wonder if you have upgraded the WAP FW recently. Sometimes a hard reset (by the button on the back) and re-configuring the device can fix such unusual behavior.

If it's not too much of an effort for you and you don't mind the downtime during the procedure, you can give it a try and see if that will help.

 

0
0
#4
Options
Re:TL-WA1201 - DHCP Server Function - Unable to Disable
a week ago

@Ivaylo 

 

I didn't have to update the firmware to the latest version when I bought the WAP. The firmware was already up to date out of the box.

 

Having said that, I might try the hard reset and see if that works a bit later.... when I have physical access to the WAP again.

 

What I can hope for is that TP-Link rectifies this issue in a future firmware release.  I will keep an eye out for this.

 

 

0
0
#5
Options
Re:TL-WA1201 - DHCP Server Function - Unable to Disable
a week ago
Sounds reasonable. When you already have tested the hard reset procedure get back to share the result.
0
0
#6
Options
Re:TL-WA1201 - DHCP Server Function - Unable to Disable
Wednesday

@WSandMC 

Hi,

How about now?

Would the issue still exist after reset?

If yes, I would be glad to forward your case to the senior engineers for further assistance.

Thank you very much and wait for your reply.

 

0
0
#7
Options
Re:TL-WA1201 - DHCP Server Function - Unable to Disable
Wednesday

@TP-Link 

 

I've tried a hardware reset and then connected to the admin page on the WAP and tried to disable the DHCP server. Same issue. A message appears stating Failed when trying to disable the DHCP function on WA1201.

 

I will leave it to you guys to fix in the next firmware version, hopefully. I don't believe there is anything else I can do on this end at the moment.

0
0
#8
Options
Re:TL-WA1201 - DHCP Server Function - Unable to Disable
Thursday

@WSandMC 

Hi,

I have tested on my side today with the same firmware;

And it turned out the settings could be saved correctly;

Could you please make sure that you are connected to the wireless network of 1201 directly?

Then if the issue still here, could you please save a video clip of this process?

Thank you very much.

 

 

0
0
#9
Options
Re:TL-WA1201 - DHCP Server Function - Unable to Disable
Thursday

@TP-Link 

 

Sure, here is a video clip.

 

I've used two different browsers, Microsoft Edge (chromium) and Mozilla Firefox. Same results. I've also flashed the latest version of the firmware for v2.0 of the hardware and same results.

 

The video clip is compressed and is of Microsoft Edge (chromium) connected directly to the WIFI on the WAP.

 

Cheers,

WS

File:
TL-WA1201.zipDownload
0
0
#10
Options
Re:TL-WA1201 - DHCP Server Function - Unable to Disable-Solution
Thursday - last edited Thursday

@TP-Link 

 

Just some progress here. I set the static IP address in the WAP's Network-->LAN settings and with the correct subnet mask (custom) 255.255.255.224 (I'm not using a /24) being served out for my range, and then tried again to save the DHCP server -> Disable setting and then it works.

 

To reproduce the issue, don't use a /24 but a /27 range in DHCP on the router instead and leave the LAN settings to Auto IP (DHCP). Then try to save the DHCP Server

 

Looks like some sort of issue with the LAN Settings or using DHCP and somehow getting the mask set incorrectly is causing the initial problem. Not really sure if this is a workaroudn or a solution. Probably a workaround.

 

I've used an Ip address outside the range of my DHCP server on the router but still within the 192.168.1.0/27 range to avoid a clash and am happy to work as it is.  The image below attempts to capture some of the success in saving the settings after switching to static IP address and setting the correct subnet mask.

 

 

Recommended Solution
0
0
#11
Options