Power LED continuously blinking after turning on

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.

Power LED continuously blinking after turning on

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Power LED continuously blinking after turning on
Power LED continuously blinking after turning on
2021-04-10 02:17:50
Model: Archer MR200  
Hardware Version: V4
Firmware Version: Archive MR200(EU)_V4_201127

When I turning on the router, the power LED continuously blinking.

Is there anybody who can help me with this.

 

Last month I upgrade my firmware and it works fine, but all of a sudden it showing this kind of problem.

 

I attached a video also . . .

File:
VID-20210409-WA0017.mp4Download
  1      
  1      
#1
Options
6 Reply
Re:Power LED continuously blinking after turning on
2021-04-10 12:00:45 - last edited 2021-04-10 12:14:31

Try, if you can, to power your router with another 12V/2A power supply.

 

I had a similar problem with an old TP-Link router, the power supply seemed to provide (good?) 12v but the router would not boot properly, replacing the power supply was the solution for me.

 

Few years later, I opened the router case because USB port don't working properly (USB 3G sticks weren't powered anymore by the router) and found a bad capacitor inside (I've replaced by a new one).

  1  
  1  
#2
Options
Re:Power LED continuously blinking after turning on
2021-04-13 06:10:27
Thanks for the reply friend . . . I tried with two different adopters with router's required input parameters, but it still with the same issue. Thanks again buddy . . .
  0  
  0  
#3
Options
Re:Power LED continuously blinking after turning on
2021-04-13 21:47:43 - last edited 2021-04-13 21:49:47

Did you tried to:

 

- do a FACTORY RESET by pressing the reset button 10 seconds?

 

- remove the SIM card and reboot without it?

  2  
  2  
#4
Options
Re:Power LED continuously blinking after turning on
2021-04-20 16:36:59
yes bro . . I tried this too
  0  
  0  
#5
Options
Re:Power LED continuously blinking after turning on
2021-04-20 16:39:09
I think there are some more peoples here with the same issue . . . check out this link:- https://community.tp-link.com/en/home/forum/topic/112088
  2  
  2  
#6
Options
Re:Power LED continuously blinking after turning on
2021-04-20 18:50:26 - last edited 2021-04-24 20:45:11

@Shaan15 

 

If the MR200 is not covered by TP-Link warranty anymore, you can try to open it.

Perhaps, you'll find a bad capacitor with bulge inside. If so, then you should try to replace it.

 

 

To give an example, I'm using this picture found on the Internet showing inside of TP-Link MR6400, maybe the MR200 is similar?

 

 

By example, if you find a bad 1000 uF/16v 85°C, replace it by a good 1000 uF/25v 105°C (for better voltage and temperature resistance).

 

  7  
  7  
#7
Options

Information

Helpful: 1

Views: 26090

Replies: 6