MR600v2 Band 40 not working

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
12

MR600v2 Band 40 not working

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
MR600v2 Band 40 not working
MR600v2 Band 40 not working
2021-05-08 03:30:00
Model: Archer MR600  
Hardware Version: V2
Firmware Version: 1.3.0 0.9.1 v0001.0 Build 210208 Rel.61056n

I have got the router from Amazon yestert and band 40 is now working with either Airtel or Jio sim. Only band 3 works. Please advise, I checked the same sim works on cell phone with band 40

  0      
  0      
#1
Options
11 Reply
Re:MR600v2 Band 40 not working
2021-05-08 09:30:22

@Manash 

 

Hi, have you tried to select the band manually on the MR600 web GUI? Please give it a go, reboot the device, then check the status again.

VPN Survey for Routers | Allow us to Understand Your VPN Service Requirements.
  0  
  0  
#2
Options
Re:MR600v2 Band 40 not working
2021-05-08 16:27:35

@Manash hi I believe there is some issue. Same issue I am getting if I selected band 40. It doesn't work. While the handset for the same sim is able to.  

  0  
  0  
#3
Options
Re:MR600v2 Band 40 not working
2021-05-08 16:34:45

@Kevin_Z 

Yes, I did I tried with 2 sim without luck. It works with band 3  band 8 in Airtel  and then band 3 & band 5 in jio. Not sure if the device itself is faulty.

  0  
  0  
#4
Options
Re:MR600v2 Band 40 not working
2021-05-08 16:37:36

@RSBasera 

 

Exactly, same issue. I am sure it's an issue with V2 or may be the firmware. I 'm thinking to return the device as band 40 provides best data speed and if we can't use that then what's the point of using this device. Seems like a false marketing if it's not a bug.

  0  
  0  
#5
Options
Re:MR600v2 Band 40 not working
2021-05-09 09:31:39

@Kevin_Z 

 

Any update, advise me if this is something related to software or hardware issue? If It's hardware I still have time to replace the item with seller.

  0  
  0  
#6
Options
Re:MR600v2 Band 40 not working
2021-05-09 11:25:19

@Manash hey I strongly think it's firmware level. Using Airtel Sim and tested with iPhone 12,Se and OnePlus 8 Pro (speeds are like 20-35 mbps with high ping and lot of disturbance).

 

jiofi and Airtel dongle is hardly giving 1-2 mbps.

 

This router is really good and now with band selection of 1 and 3 I am getting 4G+ LTE and speeds of constant 20mbps plus.

 

with band 40 this might get even better. I am able to select it but no difference in speed so pretty much it's a guess that it's firmware level issue.

 

My suggestion would be not to replace it

  0  
  0  
#7
Options
Re:MR600v2 Band 40 not working
2021-05-10 03:06:02

@RSBasera 

 

When you chose band 40, did it show disconnect on the Status page? Can we have the screenshot? Did you also try Jio and Airtel Sim card?

VPN Survey for Routers | Allow us to Understand Your VPN Service Requirements.
  0  
  0  
#8
Options
Re:MR600v2 Band 40 not working
2021-05-10 16:06:40

@Kevin_Z 

 

Yes it does say disconnected. Attcahed are the screenshots, no matter if we select the band manully also, it does not connect. Both airtel and Jio same story.

  0  
  0  
#9
Options
Re:MR600v2 Band 40 not working
2021-05-11 02:26:14

@Manash 

 

I see. To locate this issue and try to fix it, we would like to follow up on your case via email. Please check your inbox and provide the information that we need.

VPN Survey for Routers | Allow us to Understand Your VPN Service Requirements.
  0  
  0  
#10
Options
Re:MR600v2 Band 40 not working
2021-05-29 13:18:30

@Kevin_Z Hi, it does says connected but there is :

 

1. no carrier aggregation for 4g+
2. Also though it says connected. There is hardly any speed on hand 40

 

File:
127FFA79-E4D8-414A-A251-97EDD7EDEF0C.pngDownload
  0  
  0  
#11
Options