[New Firmware] 1.5.1 for Deco E4/ Deco W2400

[New Firmware] 1.5.1 for Deco E4/ Deco W2400
[New Firmware] 1.5.1 for Deco E4/ Deco W2400
2021-05-11 03:35:52 - last edited 3 weeks ago
Model: Deco E4
Hardware Version:
Firmware Version:

The new firmware 1.5.1 has been released for Deco E4 and Deco W2400 recently, please refer to the following information to get more details.

 

Modifications and Bug Fixes:

1. Fixed the problem that Zoom applications are banned by the Pay-to-Surf category under Parental Control.

2. Optimized the IPTV/VLAN feature.

3. Added Network Optimization feature.

4. Added the switch of "ignore Ping from WAN".

5. Added the "Service name" and "Access name" option when the Internet Connection Type is PPPoE. (For Deco E4 only!)

6. Added the feature of changing owner account.

7. Improved system security and reliability.

 

Notes:

1. This firmware can't be downgraded to the previous 1.4.x version!

2. Please update your Deco APP to the latest version for the new features.

3. If there are other Deco models in your Deco network, you may miss some new features till other models release updates in the near future.

4. The firmware upgrade is applied in sequence to the correct devices during the release process so not all users would get the new firmware notification in the first place.

0
0
#1
Options
22 Reply
Re:[New Firmware] 1.5.1 for Deco E4/ Deco W2400
2021-05-25 14:32:23

@TP-Link After updating this firmware. My wan port number 1 was not detecting the ISP connection signal but if i connec the 2 number port then everything fine. Why this happened...

2
2
#2
Options
Re:[New Firmware] 1.5.1 for Deco E4/ Deco W2400
2021-05-27 02:39:11

@Morshedengr 

Hi, Did this issue just start after the firmware and everything is fine on the previous firmware, right?

May I know who is your internet service provider and what is the model number of the ISP cable modem?

When the Wan port number 1 is connected, were you able to detect the hardware, but no internet connection coming through or even the hardware of the modem failed to detect?

Please try to log into the web UI and help me save the system log on the Deco E4;

Thank you very much.

0
0
#3
Options
Re:[New Firmware] 1.5.1 for Deco E4/ Deco W2400
2021-05-27 07:00:29 - last edited 2021-05-27 07:01:15

@TP-Link yes after updating the firmware. Router light become red. But when i change the port 1to 2then every thing fine. And i also tried to full rest this then connect. It does not work. But every time when i connect 1 port  it detect to failed  my PPPOE conection.

0
0
#4
Options
Re:[New Firmware] 1.5.1 for Deco E4/ Deco W2400
2021-05-28 00:58:13

@Morshedengr 

Thank you very much for your update.

I have forwarded your case to the senior engineers and please have a check of your email box.

 

0
0
#5
Options
Re:[New Firmware] 1.5.1 for Deco E4/ Deco W2400
2021-06-14 12:04:39 - last edited 2021-06-14 12:07:06

@TP-Link 

Hi,

 

E4R V1 (1.4.4 Build 20200921 Rel. 34199) owner, cannot upgrade even locally, directly from the Deco's page, message is: Operation Failed. Firmware file downloaded on computer.

While checking firmware versions on my main Deco page (X60 1.0), check for upgrades keeps spinning indefinitely...

 

What am I doing wrong?

 

Thank you!

0
0
#6
Options
Re:[New Firmware] 1.5.1 for Deco E4/ Deco W2400
2021-06-15 03:36:07

@golar3 

Hi, I checked your current firmware under your TP-Link ID and it seemed like all your firmware is up to date.

So I suppose the issue has been fixed by yourself already?

Thank you.

0
0
#7
Options
Re:[New Firmware] 1.5.1 for Deco E4/ Deco W2400
2021-06-15 12:15:39 - last edited 2021-06-15 12:16:55

@TP-Link 

Hi,

Thank you, I switched to another browser (Firefox), manually tried the update and the error message went away. Updated all my 3 E4 and now waiting for new firmware for the M4's and the X60's...

2
2
#8
Options
Re:[New Firmware] 1.5.1 for Deco E4/ Deco W2400
2021-07-11 00:03:32

@TP-Link 

Hello . After last update of the firmware the speed of downloading dropped to 10mBps, meanwhile uploading speed shows 80. Before upgrade both use to be 80.
On the router download 320mBps. What is the latest version for this one: 1.4.3 Build 20200918 Rel. 44982 ? Via web interface it shows that it is latest. What about V1.5.1?

0
0
#9
Options
Re:[New Firmware] 1.5.1 for Deco E4/ Deco W2400
2021-07-12 11:29:54

@GeorgeSA 

Hi, currently, the latest firmware for Deco E4 is 1.5.1;

If you haven’t got the firmware notification from the Deco APP, it is suggested to update this firmware via web UI;

By the way, how much bandwidth you have subscribed from the ISP?—Since the Ethernet port on E4 is up to 100m/s, so the maximum speed from E4 is 100m/s;

Did Deco E4 work on the wireless router mode or access point mode?

0
0
#10
Options
Re:[New Firmware] 1.5.1 for Deco E4/ Deco W2400
2021-07-12 21:44:19

@TP-Link 

Thanks for your reply.
1. Web user interface shows as follows: Firmware Version 1.4.3 Build 20200918 Rel. 44982   Latest Firmware Version 1.4.3 Build 20200918 Rel. 44982 

Your software is up to date! As below:

2. E4 used as wireless router, hardwire connected to the access point.
3. Speed from ISP is 350
4. I don't mind speed on E4 to be 90, as it was before the upgrade to the latest firmware, I appriciate restriction to 100 on the port.
I don't need more, but less rate, is a bit unpleasant.
Unfortunately, now the downloading speed sits at maximum 50, meanwhile uploading speed is close to normal: 86. 
It is very unusual, when uploading is faster, than downloading.
5. That is why I seek for the update of the firmware, in order to return to status quo, at least.
6. Below, the latest test result done with TP app.
7. Please provide or mail to the link to latest update.

0
0
#11
Options
Related Articles