Archer C20 Router Issue || showing "No Internet" Frequently

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Archer C20 Router Issue || showing "No Internet" Frequently
Archer C20 Router Issue || showing "No Internet" Frequently
2021-05-16 06:45:28 - last edited 2021-05-16 06:48:23
Model: Archer C20  
Hardware Version: V5
Firmware Version: 0.9.1 4.17 v0001.0 Build 200915 Rel.56357n(5553)

Hello All,

 

My Archer C20 model is two weeks old and it's not working properly since yesterday. I have tried to reset and factory default settings still facing the same problem.

 

Suddenly it shows "No Internet" under my WiFi Name on my Windows 10 laptop. After some time it will come back itself and I need to connect again to my router. I tried the PING test. Please check and let me know what could be done to resolve the issue. Thanks!

 

Note: I'm using the 5 GHz band, The issue is the same in all devices(i.e. in mobile) connected to the router when this happens.

 

  0      
  0      
#1
Options
1 Reply
Re:Archer C20 Router Issue || showing "No Internet" Frequently
2021-05-18 06:04:26

@Signup1 

 

Hi, please update the router firmware to the latest version first, then reconfigure it from scratch and confirm. Here is the download link for the latest firmware:

https://www.tp-link.com/en/support/download/archer-c20/#Firmware

  0  
  0  
#2
Options