Re650 is set up but not connecting to the internet

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Re650 is set up but not connecting to the internet
Re650 is set up but not connecting to the internet
2021-05-24 20:00:16
Model: RE650
Hardware Version: V1
Firmware Version: 1.0.6

I have set up my wifi extender at my marina. It appears to be working but is not connecting to the internet. Here are some screen shots  

 

 

please help!

0
0
#1
Options
1 Reply
Re:Re650 is set up but not connecting to the internet
2021-05-25 06:33:38

@RobertaMcc Good day, 

 

Thank you for your clear post, from the photo RE has not connected to router successfully. 

 

It is recommended to double-check router's Wi-Fi password by method below and reinstall  your RE as instructions below:

 

1>Please verify your Wi-Fi password by forgetting your Wi-Fi network on cell phone first :  
Go to Settings-> WiFi on your phone, Tap (or Long press  the router's WiFi name  ->Forget / Delete the network 
Please reconnect to your router wifi and it will ask for a password, will it accept your router password?

2> factory reset tp-link range extender : press the reset hole for 10 secs with RE powered on
On cell phone WIFI settings, connect to Range extender WiFi first ( do not connect to router wifi or and turn off mobile data)
3> follow instructions on Tether app or Web page step by step  ( carefully examine the Wi-Fi password you have put in, and it is recommended to create a different SSID/WiFi name for RE )

 

If the above does not work, please let us know Led status on your range extender, and the Model of your wifi router, many thanks. 

https://www.tp-link.com/support/faq/315/#2

 

0
0
#2
Options