Deco M9 Plus and Airplay Connection Problem

Deco M9 Plus and Airplay Connection Problem
Deco M9 Plus and Airplay Connection Problem
2021-06-08 08:35:07
Hardware Version: V2
Firmware Version: 1.5.1 Build 20210126 Rel. 59387

Hello there.

I've been a deco m9 plus user for 1 year. All the electronics in my house are connected to the deco network. I am having problems connecting with airplay between my samsung tv and my iphone.
 

Sometimes i can connect to airplay but most of the time i can't connect. I do not use any antivirus program.  2.4 ghz and 5 ghz networks are always active. When I turn off the deco network and use the modem's network, I can connect. My modem is running at 2.4 ghz and 5 ghz. I can also connect when I use my phone as a personal hotspot. but when i connect to deco network i have airplay connection problem.


Has anyone had a problem like the one I described and solved it?

 

 

0
0
#1
Options
4 Reply
Re:Deco M9 Plus and Airplay Connection Problem
2021-06-09 08:50:18

@mustafaalbat 

Hi,

Was the Samsung TV connected to the Deco via Wi-Fi or Ethernet cable?

Please try to turn off the Mesh technology of the IPhone on the Deco APP to see whether it helped or not;

And would there be any error message when you failed to cast the video from iPhone to TV?

 

By the way, could you please help me run a simple test:

Please connect the iPhone and Samsung TV to the same Deco and check whether airplay always works;

 

Thank you.

 

 

0
0
#2
Options
Re:Deco M9 Plus and Airplay Connection Problem
2021-06-09 13:39:06

@TP-Link 

 

Hi,

 

Samsung TV is wirelessly connected to Deco device. I had experimented with turning off the mesh system from the Mobile Deco application. But it couldn't solve my problem. When I want to use airplay, it finds Samsung TV, but it says connection failed.

 

I noticed something interesting in my experiments yesterday. I turned off the Samsung TV and modem together, waited ten seconds and then turned them back on. Airplay worked normally. i tried a few times and there was no problem.

Today I had airplay connection problem again. I first turned off the Samsung TV and tried again, but it didn't work. Then I turned the modem off and then on again but it still didn't work. Finally, I turned off the Samsung TV and the modem at the same time. When the devices turned on, I connected with airplay without any problems.

 

 

I don't think there is a logical explanation for this solution. Maybe you have an idea?

 

Thank you,

2
2
#3
Options
Re:Deco M9 Plus and Airplay Connection Problem
2021-06-11 06:54:38 - last edited 2021-06-11 06:57:49

@mustafaalbat 

Hi, Thanks for the update.

I am quite confused as well.

And what is the model number of your Wi-Fi modem? and did Deco M9 plus work as an access point or wireless router, by the way?

As for the SSID name for the modem and Deco, I suppose they have a different name?

Thank you.

 

0
0
#4
Options
Re:Deco M9 Plus and Airplay Connection Problem
2021-06-11 08:27:02

@TP-Link

 

Hi again,

 

 

I am sharing the modem(Docsis 3.0) photo given to me by the internet service provider turksat Kablonet. 

The 2.4 ghz and 5 ghz wireless networks of this modem are always turned off (I turned it off). 

This modem is connected to the deco device with an ethernet cable. I'm using 2.4Ghz and 5Ghz networks created by the Deco device itself. 

Yes, the modem and deco have different SSID names, but since the wireless networks of the modem are turned off, there is no possibility of confusion.

I use my deco device as a wireless router.

 

Thank you,

 

 

 

 

0
0
#5
Options