Power and all LAN led blinking on AC1750

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.

Power and all LAN led blinking on AC1750

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Power and all LAN led blinking on AC1750
Power and all LAN led blinking on AC1750
2021-07-10 13:10:44 - last edited 2021-07-12 10:49:11
Model: Archer A2  
Hardware Version: V2
Firmware Version:

MODEL : AC1750

So I bought an new Tp-link ac1750 v2 router from online marketplace. When I plug power adapter the power led, all the lan led and internet led blink constantly including the back USB led lights.  How can I troubleshoot? Is the router faulty?

 

Thanks in advance.

  1      
  1      
#1
Options
1 Accepted Solution
Re:Power and all LAN led blinking on AC1750-Solution
2021-07-12 10:48:28 - last edited 2021-07-12 10:49:11

@thisGuyanother 

 

What is the model number of the AX1750, is it Archer C7 or A7? Please check and verify this by locating the device bottom sticker.

 

How about the power supply printed on the original power adapter, please check if it is 12 V ⎓ 1.5 A if the model is Archer C7(EU) V5.

 

Check and ensure the power supply in your house is stable, and plug the power adapter into the wall socket.

 

If the issue persists, try to reset the router by pressing and holding the RESET button until all the LEDs flash off then on, check again if the router is powered on properly.

 

Still no luck, it is suggested to contact the online marketplace to check if this is faulty, and request a replacement.

If you found a post or response helpful, please click Helpful (arrow pointing upward icon). If you are the author of a topic, remember to mark a helpful reply as the "Recommended Solution" (star icon) so that others can benefit from it.
Recommended Solution
  0  
  0  
#2
Options
1 Reply
Re:Power and all LAN led blinking on AC1750-Solution
2021-07-12 10:48:28 - last edited 2021-07-12 10:49:11

@thisGuyanother 

 

What is the model number of the AX1750, is it Archer C7 or A7? Please check and verify this by locating the device bottom sticker.

 

How about the power supply printed on the original power adapter, please check if it is 12 V ⎓ 1.5 A if the model is Archer C7(EU) V5.

 

Check and ensure the power supply in your house is stable, and plug the power adapter into the wall socket.

 

If the issue persists, try to reset the router by pressing and holding the RESET button until all the LEDs flash off then on, check again if the router is powered on properly.

 

Still no luck, it is suggested to contact the online marketplace to check if this is faulty, and request a replacement.

If you found a post or response helpful, please click Helpful (arrow pointing upward icon). If you are the author of a topic, remember to mark a helpful reply as the "Recommended Solution" (star icon) so that others can benefit from it.
Recommended Solution
  0  
  0  
#2
Options

Information

Helpful: 1

Views: 4806

Replies: 1

Related Articles