M5 Capped at 100Mbit

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
M5 Capped at 100Mbit
M5 Capped at 100Mbit
2021-08-19 10:52:44 - last edited 2021-08-19 19:53:42
Model: Deco M5
Hardware Version:
Firmware Version: 1.5.3. Build 20210203 Rel.68223

I've just had my internet speed upped from 100 Mbit to 200 Mbit, and I'm having some issues, as my decos seem to be running at 100Mbit still only.

 

My network plan goes:

 

Provider hub > Main Deco > Switch > connected devices (every device in the house is either connected to deco wi-fi or through the switch, provider w-fi is switched off)

 

Other decos (4 in total) no Ethernet backhaul but devices are connected to the Ethernet hubs on the satellite decos.

 

All cables are Cat5e or Cat 6.

 

--------------------------------

 

I have connected my pc via Ethernet directly to the provider Ethernet and got the full 200Mbit so I know I'm getting full  speed from there.

 

I've run the 'Test Internet Speed' function on the android app and that also shows that the main dec is getting 200Mbit from the provider hub.

 

If I test my PC when it's connected to the Switch (TP-Link TL-SG1005D, 5 Port Gigabit Ethernet Network Switch) and run a speedcheck there it's only showing 100Mbit, but if I connect my PC directly to the main deco Ethernet port it's still only showing 100Mbit

 

On my satellite hub Ethernet port connected PC this is also only getting 100Mbit and that's Wi-Fi mesh connected only, it's not going through the switch.

 

I'm also only getting less than 100Mbit on my phone WiFi (Huawei P30 Pro) even when I'm only inches from the router.

 

Two issues.

 

1. Main Deco > switch (connected devices only get 100Mbit.

2. Satellite Decos Wifi/Phone Wi-Fi is not reaching higher than 100Mbit

 

To summarise:

 

Signal going to the Deco is correct

signal leaving the Deco (wired or wi-fi) is losing half of the speed (200 > 100Mbit)

 

Any help?

 

 

0
0
#1
Options
7 Reply
Re:M5 Capped at 100Mbit
2021-08-20 07:15:42

@tgo 

Hi, could you please check the link speed when the PC is wired to the main Deco?

Since later, I might need to forward your case to the senior engineers, could you please help get the following speed test screen-shots

1. the speed test from PC to provider hub.

2. the speed test from PC to main Deco.

3. the speed test from the Deco APP.

4. the 5ghz wireless speed from the main Deco on the Huawei P30 Pro to the main Deco

0
0
#3
Options
Re:M5 Capped at 100Mbit
2021-08-20 08:05:33

@TP-Link 

 

Ok here is the data you requested.

Link speed when connected directly to main deco (its1000 otherwise)

1. the speed test from PC to provider hub.

 

2. the speed test from PC to main Deco.

 

3. the speed test from the Deco APP.

 

4. the 2.4 ghz wireless speed from the main Deco on the Huawei P30 Pro to the main Deco

 

5. the 5ghz wireless speed from the main Deco on the Huawei P30 Pro to the main Deco

 

 

I hope this helps. (for what it's worth it seems like my M5 units have 100 Mbit Ethernet ports & WiFi as the WiFi too is similarly affected.)

0
0
#4
Options
Re:M5 Capped at 100Mbit
2021-08-20 09:48:19

@tgo 

Hi, I noticed that the Ethernet link speed on the computer is 100/100 but you could still get 103m/s from Deco, which is unexpected?

And when the PC is wired to the modem, the link speed is 1000/1000?

How about the wireless download speed from the mobile device over 5ghz

0
0
#5
Options
Re:M5 Capped at 100Mbit
2021-08-20 09:59:25 - last edited 2021-08-20 10:20:33

@TP-Link 

 

Virgin Media slightly understate their speeds, their 100Mbit is generally between  103 - 109, likelwise the 200 which is showing nearer 220

 

I'm not sure how I would measure the d/load speed on my phone, I can set it to 5Ghz only and d/load something but where to get the speed?

 

I'll also add that I've just made one of the other 4 M5's the Master and tested speed test again with the same results as before - just to eliminate the possibility of a faulty unit.

 

Runnig the speedtest with only 3 units connected rather than 4 made no appreciable difference to the results either.

 

 

0
0
#6
Options
Re:M5 Capped at 100Mbit
2021-08-25 15:32:56

@TP-Link  Any update/new information required on this please?

0
0
#7
Options
Re:M5 Capped at 100Mbit
2021-08-30 15:23:46

OK

 

Final update on this.

 

 

I'd got the wi-fi to work at my 200 Mbps provider speed, and also  comparable speeds on the satellite M5's but still had a big problem with the wired speed on the PC connected to the master M5

 

I removed the tp-link 4 port switch and wired the PC directly to the M5 but STILL couldn't get more than 98 Mbps or so.

 

Just prior to replacing all the Ethernet cables as it was the only thing  left that *could possibly* be at fault.

 

I swapped over the two Ethernet plugs into  the master M5

 

 

Bingo instant 200+ Mbps 

 

Turns out that it seems that  there must be an Ethernet IN & Ethernet OUT on the hub  (despite no documentation or markings on the ports themselves)

 

So By connecting the Master M5 to my modem using the port closest to the DC power supply  and the PC Ethernet to the port  farthest from the power supply I could get full speed, otherwise less than 100Mbps.

 

 

Rather annoying, but glad I've finally resolved it.

2
2
#8
Options
Re:M5 Capped at 100Mbit
2021-08-31 03:39:04

@tgo 

Hi, Thank you very much for the update.

The solution is quite unexpected and It is worth reporting to the senior engineers.

But there is no difference between these two ports.

I think somehow, the link speed has synced to 1000m/s when switching the ports.

And recently, beta firmware 1.6.0 has released for Deco M5 and there is a new feature that might help with our case:

[New Firmware] Deco M5 1.6.0

6. Added a prompt when the Ethernet link rate goes down to 100Mbps.

 I think it is worth a try.

0
0
#9
Options