Slow LAN Connection

Slow LAN Connection
Slow LAN Connection
2021-09-06 21:46:39
Model: Deco X20
Hardware Version: V1
Firmware Version: 1.5.1 Build 20210204 Rel. 50738

Hi all, I installed the Deco X20 but I'm facing a slow connection between devices on my local network; I tried to update the firmware to Deco X20(US)_V2.6_1.1.1_20210723 but the sistem doesn't accept this version.

 

I move QoS and the other thinks but doen't improve, somebody could help me to fix this issue?

0
0
#1
Options
5 Reply
Re:Slow LAN Connection
2021-09-09 08:45:43 - last edited 2021-09-10 02:35:23

@ahlongas07 

Hi, V1 could not update the firmware of V2 and you already have the latest firmware for V1.

As for the speed issue, could you please provide more details about the speed-test result.

1. What is the speedtest result via Deco APP?

2. How about the speed via Ethernet connection and 5ghz?—please also check the link speed when running the speed-test.

 

0
0
#2
Options
Re:Slow LAN Connection
2021-09-09 16:29:33

@TP-Link 

 

Hi, I follow all the things, and the connection between the master and slave is really healthy:

 

 

I made the test keeping in mind the rate and I get:

 

 

Theoretically I can get speeds around 108.25 MB/sec but in the practice I only get 1.1 MB/sec, really bad performance given this is a Wifi 6 device, exist a way to increase this speed?

0
0
#3
Options
Re:Slow LAN Connection
2021-09-09 19:59:08

@TP-Link Looking in the log I see: user.notice IMPROXY: INFO[imp_verify_multicast_addr@245]: Group address 224.0.0.251 is Local Network Control Block, seens like something is limiting the connection, where I can review this kind of limitations?

0
0
#4
Options
Re:Slow LAN Connection
2021-09-10 02:48:24 - last edited 2021-09-10 02:48:51

@ahlongas07 

Hi, Thank you very much for the update.

I noticed you only mentioned the Lan connection between PC and NAS. So the internet speed from WAN is ok, right?

(May I know how much speed you could get on the PC via speed-test?)

As for the NAS and PC, May I know how are they connected to the Deco? PC 5ghz to the Study Deco, how about the NAS server?

 

Later I would like to follow up on your case by email in case it needs to be forwarded to the senior engineers.

Thank you again.

 

0
0
#5
Options
Re:Slow LAN Connection
2021-09-10 16:51:09 - last edited Hace 3 semanas

@TP-Link 

Hi, thanks for your answer, my network topology is:

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

I turned off the 2.4 GHz link, so the only way to connect to the slave is using the 5GHz link.

 

My NAS has a 100 Mbps connection, so when I connect the laptop directly to the ISP modem I can get 80 MB/sec transferring files, but when I'm is connected in  the slave and  I try to transfer a file to the NAS, the speed is 1.2 MB/sec.

 

Regarding the WAN connection, when I connect a device to the Master, I can get a speed similar to the ISP offer me, but when I'm is connected to the slave the speed is 60Mbps for download and 10 Mbps for upload.

 

This is the connection between the Master and the Slave:

 

 

 

I think the connection is healthy.

0
0
#6
Options