(TL-SG1024) Switch is on but connectivity is down

(TL-SG1024) Switch is on but connectivity is down
(TL-SG1024) Switch is on but connectivity is down
2021-09-16 16:26:30
Model: TL-SG1024
Hardware Version: V11
Firmware Version: ?

Hi,

 

Since this morning (after 3 years), my unmanaged switch (TL-SG1024) breaks the connection to the router.

I have 20+ devices that are not able to communicate and this is a serious problem.

 

The only solution so far is to power cycle the switch, and then connectivity comes back for around 2 to 3 minutes before losing it again.

 

What is weird is that the green LED are on and I can see the activity and if the connection is gigabit or not so I dont understand why the traffic is not send to the router.

0
0
#1
Options
5 Reply
Re:(TL-SG1024) Switch is on but connectivity is down
2022-02-08 01:53:26
Similar issue, all of the sudden half my network is out, keeping dropping the connection , T1700G-28TQ v 3 i am using, sfp ports specifically, uplink. Nothing in the logs either. I can shortly reset by unplugging cable or rebooting switch, stays up for 1-5 minutes then down again.
0
0
#2
Options
Re:(TL-SG1024) Switch is on but connectivity is down
2022-02-08 02:03:44

@minispeeder I bought another one and had the same issue after a couple of days. Since I didn't get any reply anywhere about this issue, I gave up and bought another brand and so far, so good. My trust to TP Link brand/devices is pretty low now...

1
1
#3
Options
Re:(TL-SG1024) Switch is on but connectivity is down
2022-03-20 15:30:56

  @CedGex 

So odd my TL-SG1024 switch suddenly stopped working just shy of 3 years.  Never had an issue with TP Link, but first time.  The link lights are flashing, and switch looks like it is working, but nothing connected to it can get DHCP from the router, or connect to Internet.  I dropped in a 16 port TP Link switch and everything is working, but just dropped $100 on a new TP Link 24 port switch on Amazon.  I'm wondering if I should have ordered a different brand.

0
0
#4
Options
Re:(TL-SG1024) Switch is on but connectivity is down
a week ago

 I'm mean I can't say that the switch isn't going bad but if it's pretty new - it should switch at wire line speed 1gbps. Are all your NICs gig? What cable cat are you using? At least cat5e and how long are the runs?

0
0
#5
Options
Re:(TL-SG1024) Switch is on but connectivity is down
a week ago

  @BettyVeronicasi The issue is not that it can't use gigabit (as opposed to 100mbps). The issue is that all of a sudden, the switch became unresponsive: devices connected to it won't get IP address via DHCP, or allow internet access even with a static IP address). To be honest, I spent quite some time troubleshooting this issue, trying to isolate the problem to, at least, understand what is happening and the fact that I got the exact same issue on a brand new one after a couple of days is very confusing.

 

The second comment I have is that on an official TP Link forum, noone bothered come and ask question in this thread (after 7 month).

 

As I said, I changed brand and so far, so good.

0
0
#6
Options