Deco P7 PPPoE ignores IPv6 DNS settings and assigns Google DNS

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Deco P7 PPPoE ignores IPv6 DNS settings and assigns Google DNS
Deco P7 PPPoE ignores IPv6 DNS settings and assigns Google DNS
2021-09-22 07:23:31
Model: Deco P7
Hardware Version:
Firmware Version: 1.4.9

Hi.

 

I'm quite happy with my Deco P7 units, however, I'm dealing with an odd IPv6 related quirk.

 

Situation

- IPv6 enabled with PPPoE.

- Get IPv6 address set to stateful (also tried "No address" to no avail).

- Prefix delegation enabled.

- Get DNS automatically enabled.

- Type: SLAAC+RDNSS (also affects SLAAC+Stateless DHCP)

- Dutch ISP: KPN

 

The actual problem

The IPv6 DNS servers from my ISP are visible in the Deco app settings, but they're not supplied to any of the IPv6 clients. It seems like Deco gives out Google DNS IPv6 servers instead.

This also happens when setting a custom IPv6 DNS server. It's simply ignored by Deco.

 

Semi-workaround

A semi-workaround is to set IPv6 type to DHCPv6, but that stops to function for me after a couple of days. And on top of that DHCPv6 is unfortunately not supported by Android.

 

tl;dr

When using SLAAC+RDNSS Deco refuses to use the IPv6 DNS servers set in the app. It simply decides on it's own to supply Google IPv6 DNS to clients.

 

Is there a fix or decent workaround for this issue?

 

Thanks in advance. :)

2
2
#1
Options
3 Reply
Re:Deco P7 PPPoE ignores IPv6 DNS settings and assigns Google DNS
2021-09-24 07:48:49 - last edited 2021-09-24 07:51:21

@SignalPlease 

Hi, Thanks for the feedback.

Could you please send me some screenshots of the IPv6 details page on the Deco APP?

Did all your devices have the same issue? And have you ever set up any static DNS settings on the clients?

By the way, how did you notice the clients are using Google IPV6 DNS? would there be any screenshots, and what are these clients?

0
0
#2
Options
Re:Deco P7 PPPoE ignores IPv6 DNS settings and assigns Google DNS
2021-09-24 08:20:53

Thanks for the reply.

 

- I haven't used the Google DNS service before. Even if I did use a custom DNS before (either on clients or the Deco DHCP server), it was set to Cloudflare or a local DNS resolver (e.g. AdGuard Home).

- Just in case I've powered-off all Google devices (such as a Nest Hub, Nest cams, etc.) in my network and then did a Deco factory reset. Deco still gave out Google IPv6 DNS servers.

- All client devices using non-custom IPv6 DNS servers are affected by this issue (tried with multiple Android phones, Windows desktops, Linux servers and iOS & macOS devices). I've checked DNS servers via the usual ways (ipconfig /all in Windows, WiFi information page in iOS/macOS settings, systemd-resolve --status in Linux, etc.).

- Setting my custom IPv6 DNS servers instead of those from my ISP doesn't change things. These settings are simply ignored by clients, albeit that they're shown in the IPv6 settings panel in the Deco app).

- I've done numerous factory resets with different Deco configurations in the hopes that it would fix the problem.

 

The only thing that I can think of is that somewhere in the Deco firmware Google DNS IPv6 are defined and used instead of my ISP or custom ones. Although I must admit that I'd be surprised if Deco sets their own DNS servers.

 

 

0
0
#3
Options
Re:Deco P7 PPPoE ignores IPv6 DNS settings and assigns Google DNS
2021-09-26 02:06:47

@SignalPlease 

Hi, thank you for the update.

I have forwarded your case to the senior engineers and please refer to the email for further assistance.

 

 

0
0
#4
Options