Archer T4U(EU) ver 3.2 won't connect to USB 3.0 but work on USB 2.0

Archer T4U(EU) ver 3.2 won't connect to USB 3.0 but work on USB 2.0
Archer T4U(EU) ver 3.2 won't connect to USB 3.0 but work on USB 2.0
2021-10-09 16:19:05 - last edited 2021-10-13 01:30:20
Model: Archer T4U
Hardware Version: V3
Firmware Version: 3.2

Hi! 
Recently i bought wifi adapter archer T4U as in title. My problem is that it can't connect to usb 3.0 port but works fine in usb 2.0 port. On usb 2.0 I can connect to 5g network. On 3.0 port I have constant sound of unpluging a device and I cant see any networks in network panel. I bought that adapter esspecialy to match network speed but without usb 3.0 compatibility I am bottlenecked. I have installed latest drivers. OS is windows 10. If any additionals information is required please let me know.

0
0
#1
Options
1 Accepted Solution
Re:Archer T4U(EU) ver 3.2 won't connect to USB 3.0 but work on USB 2.0-Solution
2021-10-12 07:57:42 - last edited 2021-10-13 01:30:20

@Solla-topee Ok I am after UEFI update to P1.80 and my driver work fine but with adapter I see something strange. When I have driver installed even with windows reboot I have the same problem as in first post but without driver adapter work but speed is greatly reduced (2.4G 100 Mb/s max, 5G 280 Mb/s max). My network speed is up to 600Mb/s.

I tried also updating USB driver but system can't find anything new. Drive work with 3.0 speed on the same port as I am trying adapter. Link to chipset won't work for me so I can't try it.

Recommended Solution
2
2
#4
Options
4 Reply
Re:Archer T4U(EU) ver 3.2 won't connect to USB 3.0 but work on USB 2.0
2021-10-12 01:49:28 - last edited 2021-10-12 01:52:26

 Hello@Fajter ,  

If the adapter could not be recognized by Windows and trigger ' unplugging sound' , you can try suggestions here: 

 

If the issue persists, may I know does other device work fine on the same USB port, what is the model of your computer? 

 

0
0
#2
Options
Re:Archer T4U(EU) ver 3.2 won't connect to USB 3.0 but work on USB 2.0
2021-10-12 06:53:04

@Solla-topee Ok i tried few things and I think I see a problem. My normal devices works fine on 3.0 ports but when i plugged my external drive that is also compatible with 3.0 my PC can't see him. That drive work on normal 2.0 port like adapter. I think I need to update my BIOS because I found some info on internet that that matherboard had some problems. I have Asrock b450 pro4 motherboard with UEFI version B450 Pro4 P1.30 and amd ryzen 5 2600 processor.

0
0
#3
Options
Re:Archer T4U(EU) ver 3.2 won't connect to USB 3.0 but work on USB 2.0-Solution
2021-10-12 07:57:42 - last edited 2021-10-13 01:30:20

@Solla-topee Ok I am after UEFI update to P1.80 and my driver work fine but with adapter I see something strange. When I have driver installed even with windows reboot I have the same problem as in first post but without driver adapter work but speed is greatly reduced (2.4G 100 Mb/s max, 5G 280 Mb/s max). My network speed is up to 600Mb/s.

I tried also updating USB driver but system can't find anything new. Drive work with 3.0 speed on the same port as I am trying adapter. Link to chipset won't work for me so I can't try it.

Recommended Solution
2
2
#4
Options
Re:Archer T4U(EU) ver 3.2 won't connect to USB 3.0 but work on USB 2.0
2021-10-13 01:29:57

Hello @Fajter , Glad to hear that you USB 3.0 could recognize the adapter now, thank you for sharing the solution!

To improve the speed you could try some suggestions here:

-  Make sure other devices like laptop/ phone could get good speed at the same location  

-  Log in router and try a different 5Ghz channel like 36/40/44/48 etc. and set 5Ghz channel width at 80Mhz. 

Change 2.4Ghz wifi to 40Mhz. 

-  Disable other built-in adapter except for tp-link adapter

 

If still the concern persist,  can you compare the 5Ghz speed test results as well as the 5Ghz WiFi link soeed on T4U computer and a different device which located in the same spot and share the screenshot of speedtest and link speed. 

How to check the associated/link speed on a wireless client https://www.tp-link.com/support/faq/2265/

What is the model of router, and can you  please share a photo of router's wireless settings? 

Can I have a photo of your computer motherboard:  https://www.tp-link.com/support/faq/2722/

0
0
#5
Options