I switched hide SSID on and now my devices won’t connect to 5Ghz wifi

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.

I switched hide SSID on and now my devices won’t connect to 5Ghz wifi

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
I switched hide SSID on and now my devices won’t connect to 5Ghz wifi
I switched hide SSID on and now my devices won’t connect to 5Ghz wifi
2021-10-31 21:10:08 - last edited 2021-10-31 21:13:31
Model: TP-Link Routers  
Hardware Version: V2
Firmware Version: 1.0.3 Build

Using AC750 RE220. My devices except my phone which has the app won't connect to 5Ghz network after hiding SSID. My TV will only manually connect 2.4Ghz and my laptop won't connect to either. My laptop giving multiple security type options to chose WEP, WPA3-personal,WPA2-personal or enterprise, 802.1x and then a security key which I am guessing is the router password? I want my TV connected to 5g and laptop 2.4g could anyone help?

  0      
  0      
#1
Options
1 Reply
Re:I switched hide SSID on and now my devices won’t connect to 5Ghz wifi
2021-11-01 07:39:54 - last edited 2021-11-01 07:44:47

@Marz10 

 

Before you hide the SSID of extended network, could TV connects to 5Ghz Extended Wi-Fi, and could laptop connect to 2.4Ghz?

Range extender uses the same wireless security type as main router, normally that is WPA2-personally(WPA2-PSK) or WEP.

If the laptop is Win10 , you could check wireless security type WEP, WPA2_PSK in Wi-Fi properties.  ( Select the Wi-Fi network  icon on the right side of the taskbar, then select Properties underneath the Wi-Fi network name.)

It is suggested using different SSIDs for extender 's 2.4G and 5G, if TV or laotop still will not connect to, can I have a photo of the error message? 

  0  
  0  
#2
Options

Information

Helpful: 0

Views: 222

Replies: 1