Deco M5 not working with P7

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
12
This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Deco M5 not working with P7
Deco M5 not working with P7
2021-12-04 11:00:37 - last edited 2021-12-06 16:13:40
Model: Deco M5
Hardware Version: V1
Firmware Version: 1.1.6 Build 20171103

Hi everybody,

 

I have three Deco P7. One P7 is the main Deco. All working in Router mode. I now bought a Deco M5 to extend my Wi-Fi range. I added the M5 to my network using the Deco App. M5 is recognized and added.
But my devices do not connect to the M5 even if I am standing directly next to it. Tried everything in AP mode but with the same result.

What is it that I am not seeing?

 

Thanks for your help

0
0
#1
Options
1 Accepted Solution
Re:Deco M5 not working with P7-Solution
2021-12-06 16:09:40 - last edited 2021-12-06 16:13:40

@schillkroete 

 

Yes, if you can't see M5 in WiFi analyzer, that would explain why devices won't connect to it. 

 

If you want to, you could give it one last try and see if you can install firmware 1.6 beta for M5. Nothing to lose by installing beta code, and if it installs you may be able to get more useful information from that node in Deco app. Here is link: [New Firmware] Deco M5 1.6.0

 

If that does not work either, it looks like you will have to return M5. Still, time was not lost: you gained useful information on Deco mesh (and WiFi mesh in general) troubleshooting.

 

Keep WiFi analyzer app: it may show you dead or weak spots in your home WiFi coverage. Just walk to the place where mobile devices experience issues with your home network WiFi such as signal drops or slow Internet, turn WiFi off/on on smartphone to get fresh reading and check WiFi analyzer. If you don't see in it WiFi nodes with good signal at that location, it means you've got to rearrange your nodes for better coverage of that spot.

Recommended Solution
0
0
#15
Options
15 Reply
Re:Deco M5 not working with P7
2021-12-04 12:41:55 - last edited 2021-12-04 12:55:20

@schillkroete 

 

Consider upgrading M5 to latest hardware firmware, as a first step. You may need to do it manually, by downloading it from TP-Link Web site of your region.

 

It might be possible that this old firmware (from 2017, really?) does not support modern security protocols for devices to connect to it.

1
1
#2
Options
Re:Deco M5 not working with P7
2021-12-04 12:52:37 - last edited 2021-12-04 12:52:53

@Alexandre. Thanks for your answer. I am trying to upgrade to a new firmware since hours. Does not work at all. Nor via web interface neither via M5 upgrade tool. Upgrade via App is not possible.

What do you mean with upgrading to newest hardware version?

0
0
#3
Options
Re:Deco M5 not working with P7
2021-12-04 12:59:07

@schillkroete 

 

In regard to hardware I made a typo, sorry. Have my mind preoccupied with hardware issues I am dealing with on my server, these are unrelated to Deco. 

 

With such an old firmware, upgrade through app won't work. If you can't upgrade M5 to latest firmware manually, try the previous, older version, available from TP-Link Web site. If that does not work either, try next one and go down the list till you find one that can be installed manually. After that, check in app if newer version became available and upgrade, if not, do it manually going up the list. At some point, in app upgrade will become available.

 

If nothing works and you can't upgrade firmware at all, escalate to TP-Link support and if they are of no help, return that M5 to seller.

2
2
#4
Options
Re:Deco M5 not working with P7
2021-12-06 06:50:12

@schillkroete 

Hi, did you purchase Deco M5 recently? And from your internet service provider or online retailers?

Since I did not find your current firmware in the database, it might be a customized version for your service provider.

Back to the current problem that no devices are able to connect to Deco M5, do you have any wired laptops and we could test whether the Ethernet connection is working or not?

By the way, are you able to check whether this M5 is broadcasting wireless signal:

For example, you could power off all three P7 and check whether there is any signal left.

Thank you very much.

0
0
#5
Options
Re:Deco M5 not working with P7
2021-12-06 06:57:27

@TP-Link 

Hi, thanks for your answer. I buyed it in a Shop for refurbished Hardware in eBay with 12 months warranty.

The LAN Signal is working. I tried that already. I can Test the wireless Signal this afternoon. The M5 does not have to be the Main deco, does it?

0
0
#6
Options
Re:Deco M5 not working with P7
2021-12-06 14:28:46

@TP-Link 

I tried that now. When I turn off all the P7 (one of the P7 is the main Deco), I can find a Wifi named "TP-Link". So I think the wireless function of the M5 does work.

When I turn on the P7 main deco again my devices somehow do not connect to the M5. I tried in my garage. I put the M5 into the garage an had poor Wifi connection even when I was standing directly next to the M5. When I had one of the P7 installed in the garage I had full Wifi all over the place. Same in my bathroom and other rooms.

Woud you recommend me to return the M5 to the seller?

2
2
#7
Options
Re:Deco M5 not working with P7
2021-12-06 14:57:14

@schillkroete 

 

If Deco M5 is connected to Ethernet, please disconnect it from Ethernet cable so that it will use WiFi connection to your Deco mesh. Then, please clarify the following for me.

 

1. LED on M5 is green.

 

2. You can see M5 succesfully added to your Deco mesh, in the list of Deco units in Deco app. Example:

 

 

3. With M5 is connected wirelessly to the rest of Deco mesh, you do see both 2.4GHz and 5GHz bands in M5 signal source. Example:

 

 

4. What is SSID name of your Deco mesh Main Network?

 

5. Are you OK to install WiFi analyzer app on your smartphone (I'll provide you with app name from Google or Apple app store) to check additional information that smartphone sees from that M5?

0
0
#8
Options
Re:Deco M5 not working with P7
2021-12-06 15:17:40

@Alexandre. 

Thanks for your answer.

I can See M5 in the overview. SSID is "Pretty fly for a Wifi"

But I do not See where to find the two GHz Bands. I activated both 2.4 and 5 GHz.

The offline Decos in the picture ate the P7 which I die not reconnect Yet. Dr is the M5.

I am fine with installing a Analyzer app.

0
0
#9
Options
Re:Deco M5 not working with P7
2021-12-06 15:28:35

@schillkroete 

 

In Deco app, on that screen that you copied to reply, touch Deco icon named Dr and new screen will open with Signal Source information in it. Please copy it to your reply. Example:

 

 

 

 

WiFi analyzer app name: WiFiMan by Ubiquiti. Link to Google app store: https://play.google.com/store/apps/details?id=com.ubnt.usurvey

Same app is available in Apple app store.

 

When you have it installed on smartphone, let me know and I'll tell you what to check in it.

0
0
#10
Options
Re:Deco M5 not working with P7
2021-12-06 15:34:16

@Alexandre. 

I took a Screenshot from both main Deco and M5.

M5 only Shows a MAC Adresse but no IP.

Analyzer App is installed

0
0
#11
Options