Cant access any devices connected to the switch after changing to a new Router

Cant access any devices connected to the switch after changing to a new Router
Cant access any devices connected to the switch after changing to a new Router
2022-05-02 13:11:05
Model: TL-SG1016D  
Hardware Version: V5
Firmware Version: no idea

Hi I'm experiencing something strange - I just changed ISP & replace my router from Sky to G.Network & now every device connected to my switch cant access internet - I can see them in the attached devices in the router but they cant access the internet like my Apple TV etc. I then reverted back to the old Router & still cant access the internet - I pulled off the switch power cable & left it off for a couple of mins & it didnt make a difference - I can see the lights flickering on the switch but no internet access for the devices attached - what else can I do to get it working again or do I have to replace? Thx in advance

0
0
#1
Options
3 Reply
Re:Cant access any devices connected to the switch after changing to a new Router - No Apple TV Streaming
2022-05-02 20:23:48

  @alist4ir after further tests I have noticed that my devices connected to the TP-Link_TL-SG1016D switch are all connected i.e. have an IP address & are in the correct subnet  but I cant stream anything, that applies to my LG TV, Apple TV & I cant at all connect to my QNAP NAS drive, when I connect directly with the router to these devices they all work fine so there is something in this unmanaged switch stopping them from streaming - any help is appreciated before I bin this TP-Link switch & never buy one again as it has taken all my bank holiday wkend to resolve this & still no wiser

0
0
#2
Options
Re:Cant access any devices connected to the switch after changing to a new Router - No Apple TV Streaming
2022-05-05 20:58:27 - last edited 2022-05-05 21:02:46

  @alist4ir 

 

Hey

 

As this is an un-managed switch I can say with 99% certainty this IS NOT the issue (outside of a hardware failure).   A managed switch just chucks data out ports, what you are experiencing sounds like a DNS or default gateway issue and that points to the router

 

Have you any details of what IP addresses are being given out?  are you using DHCP or static?  Can you ping the router from the clients?    Really need more details to help you further, at the moment its looking like an IP issue for sure

0
0
#3
Options
Re:Cant access any devices connected to the switch after changing to a new Router - No Apple TV Streaming
2022-05-05 22:58:34

  @Philbert Thx for your response - I managed to get it troubleshooted with TP-Link support & it pointed out to a hardware failure & Im getting it replaced

To answer your question...

Have you any details of what IP addresses are being given out?  yes they all have IPs

are you using DHCP or static?  DHCP mainly with 1 static - neither can access internet

Can you ping the router from the clients?    No

 

0
0
#4
Options