Can't get WDS set up on Archer D7

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
12

Can't get WDS set up on Archer D7

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Can't get WDS set up on Archer D7
Can't get WDS set up on Archer D7
2022-05-06 12:23:54
Model: Archer D7  
Hardware Version: V1
Firmware Version: 0.9.1 1.3 v002d.0 Build 150911 Rel.30949n

I'm trying to set up a "D7" as a repeater (an extended router) on a wifi network (of Sagemcom "Box" 12, the root router) but I'm running into multiple issues when following the TP-Link guide for WDS on a D7.

 

The steps, in summary:

  1. Login to the web-interface (in my case http://192.168.1.1 or http://tplinkmondem.net)
  2. Go to Advanced > Network > LAN, configure the IP address. The repeater should be in the same subnet with the root router. If the IP of the root router is 192.168.0.1, the IP address of the repeater might be 192.168.0.2, for example. Click Save.

  3. Go to Advanced\Wireless\Wireless Settings\Advanced Setting. In WDS, select Enable WDS Bridging. Click Save.
  4. Click on Scan. Find the SSID of your root AP and click on Connect. Click Save.
  5. If the wifi of the root router is encrypted, please configure the security settings according to the root router's wifi encryption. Click Save.
  6. Go to DHCP Settings and select disable. Click Save.

 

My problems start quickly.

  1. I configure the IP address of the D7 from 192.168.1.1 to 192.168.2.2.
  2. The TP-Link reboots. I can connect to the wifi but I cannot connect to the webinterface on 192.168.2.2 or http://tplinkmondem.net.

 

What might be going on?

  0      
  0      
#1
Options
13 Reply
Re:Can't get WDS set up on Archer D7
2022-05-07 09:33:33 - last edited 2022-05-07 12:10:12

  @Crike_Jr 

 

If your main router is with an IP address 192.168.1.1 you should set the D7 LAN with an IP address in the same subnet i.e. 192.168.1.2.

If this was helpful click on an arrow pointing upward. If this solves your issue, click the star to mark it as a "Recommended Solution".
  0  
  0  
#2
Options
Re:Can't get WDS set up on Archer D7
2022-05-07 11:30:42 - last edited 2022-05-07 12:39:54

  @terziyski Unfortunately, I'm struggling changing the IP.

 

The Sagemcom "Box" root modem/router has the IP 198.162.2.254. The IP of the TP-Link "D7" is 192.168.1.1 or tplinkmodem.net.

 

I can change the D7 to 192.168.0.1 or 192.168.3.1 but when I change it to 192.168.0.2 192.168.2.2 or .250 or any other address on the subnet of the Box, the web interface of the D7 becomes unreachable.

 

  0  
  0  
#3
Options
Re:Can't get WDS set up on Archer D7
2022-05-07 11:47:26 - last edited 2022-05-07 12:08:46

  @Crike_Jr 

 

If the root modem is with IP address 198.162.2.254 you should use an IP address in the same subnet, which is the range 192.168.2.1-192.168.2.253.

Try setting the D7 LAN with an IP address 192.168.2.253 and test again.

If this was helpful click on an arrow pointing upward. If this solves your issue, click the star to mark it as a "Recommended Solution".
  0  
  0  
#4
Options
Re:Can't get WDS set up on Archer D7
2022-05-07 11:51:24

  @terziyski I did, but: "Web page not available" ERR_CONNECTION_TIMED_OUT for both tplinkmodem.net and 192.168.2.253.

  0  
  0  
#5
Options
Re:Can't get WDS set up on Archer D7
2022-05-07 11:55:19 - last edited 2022-05-07 15:21:58

  @Crike_Jr 

 

Try the following:

Set you computer LAN adapter with a static IP address of 192.168.2.100 and you'll be able to access it (when D7 LAN is with 192.168.2.253).

Remember that you have to connect your computer with an ethernet cable to D7 LAN port to be able to see the D7 WebGUI.

Then you can disable D7 DHCP server and continue with its WDS setup.

If this was helpful click on an arrow pointing upward. If this solves your issue, click the star to mark it as a "Recommended Solution".
  1  
  1  
#6
Options
Re:Can't get WDS set up on Archer D7
2022-05-07 11:56:20

Crike_Jr wrote

  @terziyski Unfortunately, I'm struggling changing the IP.

 

The Sagemcom "Box" root modem/router has the IP 198.162.2.254. The IP of the TP-Link "D7" is 192.168.1.1 or tplinkmodem.net.

 

I can change the D7 to 192.168.0.1 or 192.168.3.1 but when I change it to 192.168.0.2 or .250 or any other address on the subnet of the Box, the web interface of the D7 becomes unreachable.

 

  @Crike_Jr 

 

I meant to say, when I change it to 192.168.2.2 or .250 or any other address on the subnet of the Box, the web interface of the D7 becomes unavailable.

 

Apparently I still had the example subnet I used before on my mind.

  0  
  0  
#7
Options
Re:Can't get WDS set up on Archer D7
2022-05-07 12:13:08

terziyski wrote

  @Crike_Jr 

 

Set you computer LAN adapter with a static IP address of 192.168.2.100 and you'll be able to access it (when D7 is with 192.168.2.253).

Remember that you have to connect your computer with an ethernet cable to D7 LAN port to be able to see the D7 WebGUI.

  @terziyski 

 

I don't understand. You are correct, that I'm trying to change the D7's IP over a Wifi connection. When I change the D7 to any variation of 192.168.x.1 I can reconnect without any problems to the WebGUI over Wifi on any subnet except 192.168.2.x.

 

? As the IP of the Android 9 tablet I'm using is normally on the Box root router subnet I'm trying to bridge with the D7, could that be causing the problems reconnecting to the D7 after I move its IP to the Box's subnet? Some caching issue? Because I can change the D7 IP to any other subnet and reconnect without issue via Wifi. That said, restarting the tablet doesn't fix the problem.

 

? You recommend modifying the D7 with a PC over Ethernet, after changing the IP of the PC to x.x.x.100. Is loss of connection/instability usual when changing the IP of a D7? And, will it remain inaccessible over Wifi after it has been set up as a repeater?

  0  
  0  
#8
Options
Re:Can't get WDS set up on Archer D7
2022-05-07 13:14:45 - last edited 2022-05-07 13:15:37

  @Crike_Jr 

 

Crike_Jr wrote

As the IP of the Android 9 tablet I'm using is normally on the Box root router subnet I'm trying to bridge with the D7, could that be causing the problems reconnecting to the D7 after I move its IP to the Box's subnet? Some caching issue? Because I can change the D7 IP to any other subnet and reconnect without issue via Wifi. That said, restarting the tablet doesn't fix the problem.

 

Yes, that could be a problem, because when changing D7 to 192.168.2.253 you already have 2 DHCP servers in this subnet - Sagemcom router and the D7.

And yes, this could be a chaching issue with the tablet.

 

You recommend modifying the D7 with a PC over Ethernet, after changing the IP of the PC to x.x.x.100. Is loss of connection/instability usual when changing the IP of a D7? And, will it remain inaccessible over Wifi after it has been set up as a repeater?

 

Just use a computer with an ethernet cable connected to the D7 LAN for its configuration. That way you'll avoid potential caching issues with your tablet.

There's no reason that D7 LAN can't be configured in 192.168.2.0/24 subnet.

 

If this was helpful click on an arrow pointing upward. If this solves your issue, click the star to mark it as a "Recommended Solution".
  1  
  1  
#9
Options
Re:Can't get WDS set up on Archer D7
2022-05-09 03:34:39

  @terziyski 

I've gotten my D7 on the wifi network of the Box, but while I can now get to the web interface of the D7 from the wireless network of the Box, devices that connect to the D7 don't get access to the internet, and can't connect to either the web interface of the Box or the D7.

 

I'm not sure what might be the issue. If the WDS bridge is successful (as indicated by the D7 being reachable on the Box's wifi) I don't understand why the devices connecting to the D7 to piggyback on its connection with the Box aren't getting internet.

  0  
  0  
#10
Options
Re:Can't get WDS set up on Archer D7
2022-05-09 09:36:59 - last edited 2022-05-09 09:40:42

  @Crike_Jr 

 

Check if the devices connected to D7 Wi-Fi have a valid IP addresses in the 192.168.2.0/24 subnet.

Also check what's their DNS - it should be the same as if they were connected to the Sagemcom router.

Look for a WDS status - on some wireless routers there's a dedicated status line in the Wireless section:

 

 

Upon successful WDS configuration It should display WDS Status: Run.

I am not sure if this was implemented in D7 WebGUI but it's worth checking.

Here's a brief video configuring WDS on Archer D5 which is the same as for your Archer D7 (just as an example).

If this was helpful click on an arrow pointing upward. If this solves your issue, click the star to mark it as a "Recommended Solution".
  1  
  1  
#11
Options

Information

Helpful: 0

Views: 283

Replies: 13

Related Articles