Archer MR600 4G Band Selection issue

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.

Archer MR600 4G Band Selection issue

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Archer MR600 4G Band Selection issue
Archer MR600 4G Band Selection issue
2023-06-22 19:19:21 - last edited 2023-07-14 07:32:00
Model: Archer MR600  
Hardware Version: V3
Firmware Version: 1.0.0 0.9.1 v0001.0 Build 220307 Rel.60743n

Hi TP-Link,

I have a very frustrating issue with this router.

The router has 100% signal strength only when I leave the "Band" selection as manual, and select the 3 possible 4G Bands for my ISP/carrier.

However, I have to do this every single day!

 

During the night-time, when we're sleeping, somehow, the router goes back to 50% signal strength.

The next day, only when I do a manual Band search and select the bands again, then the router becomes 100% signal strength and the Internet works fast again.

I select "Save" and the manual Band selection is seemingly saved, but the next day, even when that's apparent, this happens again.

 

(Auto Band mode would only give me 50% signal strength at all times)

 

I have to, essentially, do a manual Band search and pick my Bands manually every single day if I want to have 100% signal strength.

It lasts for as long as I'm using the Internet on my devices, but, during the night-time when no one is using the router, the next morning signal strength is back to 50%.

 

This is really frustrating. It's a router bug or issue. How do I fix it? Are you planning on fixing this, at all?

 

Here's what it looks like right now after I did a manual Band search + selection this morning (100% signal strength).
 

screenshot

 

Tomorrow morning, it's going to say again "Signal Strength: 50%" and my Internet will be slow again until I repeat this entire thing.
Also, router is set to 4G only mode. 4G here is 4G+ and works well. Thanks!

  0      
  0      
#1
Options
1 Accepted Solution
Re:Archer MR600 4G Band Selection issue-Solution
2023-07-14 07:31:55 - last edited 2023-07-14 07:32:00

  @Rick-Santos 

 

For carrier aggregation/4G+ issue, please refer to this post: Carrier Aggregation or 4G+ doesn’t work properly on LTE Advanced Router

If you found the post or response helpful, please click Helpful. If an answer solves your problem, click "Recommended Solution" so that others can benefit from it.
Recommended Solution
  0  
  0  
#8
Options
8 Reply
Re:Archer MR600 4G Band Selection issue
2023-06-23 13:51:52

  @Rick-Santos 

Today this happened (as usual) and now I have a screenshot of it happening yet again with the 50% signal strength.
Now I have to go do a manual band search yet again and select the *same* bands that are already selected, and signal strength will go back to 100%.

  0  
  0  
#2
Options
Re:Archer MR600 4G Band Selection issue
2023-06-25 15:20:56

Hello? Can anyone help? I can select only Band 20 and Signal Strength will remain at 100% everyday, but the network speed is bad. I only get my ISP's 40 Mbps if I have all three bands manually enabled, but have to re-select them every morning.

Is there a planned update or firmware fix? I'd like an answer from TP-Link, if possible.

  0  
  0  
#3
Options
Re:Archer MR600 4G Band Selection issue
2023-06-26 07:55:53

  @Rick-Santos 

 

Hello, based on the two screenshots, band 20 shows 100% signal while band 1 shows 50% signal, it is recommended to select band 20 only when you manually select the band, then it will not switch to band 1 anymore.

 

Please test if it solves the issue.

If you found the post or response helpful, please click Helpful. If an answer solves your problem, click "Recommended Solution" so that others can benefit from it.
  0  
  0  
#4
Options
Re:Archer MR600 4G Band Selection issue
2023-06-26 11:05:50

  @Sunshine Hi, the issue isn't only with signal strength.

Most of the day, the router will show (in Advanced - Status) that the Band is actually "20, 1". So both bands are operating at the same time, which is seemingly a feature of this router.

When I get both bands working, they give my max speed of 40Mbps (even higher sometimes when testing the speed).

So I can't only select Band 20, as Band 20 only gives me a max speed of ~20Mbps.
The router's firmware seems bugged to that extent, because it should be operating both bands at the same time which is marketed as a feature that other competitors don't have, but then, every morning, I have to manually search for the Bands again - and most of the times, only one Band is operating (like "1" or "20"). Only if I'm lucky the router does "20, 1" which is what I need and why I bought it.

Is there an expected firmware update for this version of the router (V3)? I'm quite disappointed with my purchase.

  0  
  0  
#5
Options
Re:Archer MR600 4G Band Selection issue
2023-06-27 09:38:00

  @Rick-Santos 

 

Hi, the feature of working on two bands is called carrier aggregation.

Carrier Aggregation is enabled by default for LTE Advanced devices, when connecting to LTE network, the TP-Link device will report its own carrier aggregation capability to the network, and then the network side allocates frequency band resources, and the allocation of resources depends entirely on the network side. Therefore, we are unable to force the device to always work on two bands.

 

If possible, please insert the same SIM card into another 4G+ device to see if it will always work on two bands, if so, please check which bands it uses for comparison.

Note: Please ensure another 4G+ device supports the same UE Category, such as Cat6, which is the same as Archer MR600.

If you found the post or response helpful, please click Helpful. If an answer solves your problem, click "Recommended Solution" so that others can benefit from it.
  0  
  0  
#6
Options
Re:Archer MR600 4G Band Selection issue
2023-06-29 16:22:40
Hi, the SIM works with those bands and with 4G+. This issue has been reported multiple times here, and even 3 years ago. Carrier aggregation barely works with my router, and, when it does, it changes automatically to the weakest band (Band 1), even though I have manual band selection. The Internet only works really well when it’s using both bands and 4G+, but it has to have Band 20 First, then Band 1 Second. - It should show “Band: 20,1”. - But, sometimes, it’ll show “Band: 1,20” and the signal strength is horrible due to band 1 being prioritized. Nevertheless, I get like 1 day a week of carrier aggregation working here, while it works on any other 4G+ device constantly. The issue is with the router, it seems to be a bug.
  0  
  0  
#7
Options
Re:Archer MR600 4G Band Selection issue-Solution
2023-07-14 07:31:55 - last edited 2023-07-14 07:32:00

  @Rick-Santos 

 

For carrier aggregation/4G+ issue, please refer to this post: Carrier Aggregation or 4G+ doesn’t work properly on LTE Advanced Router

If you found the post or response helpful, please click Helpful. If an answer solves your problem, click "Recommended Solution" so that others can benefit from it.
Recommended Solution
  0  
  0  
#8
Options
Re:Archer MR600 4G Band Selection issue
2023-08-16 09:57:56

  @Rick-Santos I have a similar situation. I have the latest firmware installed as I read about issue swith selecting bands.

 

But I am with EE and on some occasions when I select manual for band selection I get a list from Band 1-20 with 1,3 and 20 having EE next to it (well sometimes they do, other times they have no EE). If I choose auto or tick bands 1,3,20 it always reverts to 3. Unfortunataly the area I am in is very conjested and I suspect Band 3 is the worse culprit as it is the default for many devices. So I have tried deselecting 3 but if I select Bands 1 or 20 (even if it has EE next to the Band) it will think about it but then come back as disconnected.

 

My strength ranges from 75-100% and RSRP and RSRQ are also really good.

 

Seems very flaky to me.

  0  
  0  
#9
Options

Information

Helpful: 0

Views: 946

Replies: 8

Related Articles