WoL via OpenVPN

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.

WoL via OpenVPN

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
WoL via OpenVPN
WoL via OpenVPN
2023-08-09 23:56:08 - last edited 2023-08-10 00:01:05
Model: Archer C1200  
Hardware Version: V2
Firmware Version: 2.0.3

Hello,

 

I have been trying to start my PC from abroad using a Wake on Lan app while connected to an OpenVPN I have configured on my Archer C1200 router. I have found a similar thread where the solution was changing the IP for the VPN client to one in the same subnetwork as the PC.

 

In my case, the computer succesfully starts while I am connected to the same network with the smartphone I am using the WoL app on. The smartphone connects succesfully to the OpenVPN server (I can connect with a Remote Desktop app to the PC once it is on). The WoL command even works via WAN (targetting a TP-Link DDNS I have set) when a Virtual Server is configured on the router, forwarding the corresponding port to the PC's IP (which is bound on the ARP list and reserved by the DHCP server).

 

However, the WoL won't work when connected from the Internet via OpenVPN. I'd like this option to work so I can close the port on the router's NAT forwarding configuration, since I am concerned for the security of having the Virtual Server always enabled.

 

Regarding the existing thread mentioned before, I can't find a way of setting an IP for the VPN client in the same subnetwork as the PC, as the router will answer me with an error message ("The VPN Subnet/Netmask conflicts with the reserved IP adress. Please enter again.").

 

How can this setting be done with the Archer C1200 (without using PPTP VPN instead of OpenVPN, since it is not recommended on the router's manual)?


Thank you in advance.

  0      
  0      
#1
Options
4 Reply
Re:WoL via OpenVPN
2023-08-10 10:15:27 - last edited 2023-08-10 10:21:41

  @KinoR 

 

Hi, thank you very much for posting on TP-Link Community.

May I know the Wake on LAN App name and version on your smartphone? and please also provide the complete firmware version of your Archer C1200 V2.

 

It is normal that OpenVPN subnet cannot be the same as the router LAN subnet, the WoL issue over OpenVPN now might be related to how the App works on your smartphone.

We would like to escalate your case to the support engineers, and they will help follow it up, if you are willing to do further analysis, please check your inbox and respond.  

If you found the post or response helpful, please click Helpful. If an answer solves your problem, click "Recommended Solution" so that others can benefit from it.
  0  
  0  
#2
Options
Re:WoL via OpenVPN
2023-08-10 13:44:22

@Sunshine thank you for your reply. The app I am using is this one: https://apps.apple.com/es/app/wake-me-up-wake-on-lan/id1465416032. It is updated to its last version available on the App Store (1.3).

 

I have also tried this one: https://apps.apple.com/es/app/wolow-wake-on-lan/id1500970060, using its last version as well, and results are the same.

 

The complete firmware version of the router is 2.0.3 Build 20211219 Rel. 67401 (EU).

  0  
  0  
#3
Options
Re:WoL via OpenVPN
2023-08-11 10:38:24

  @KinoR 

 

Thank you very much for the reply, I've already forwarded your case to our support engineer via email, they will use the same Apps for testing first, and please wait for their reply.

 

Please also let the community know if the issue can be located or resolved.

If you found the post or response helpful, please click Helpful. If an answer solves your problem, click "Recommended Solution" so that others can benefit from it.
  0  
  0  
#4
Options
Re:WoL via OpenVPN
2023-08-11 22:12:14

  @Sunshine alright, I will.

 

Thank you for your help.

  0  
  0  
#5
Options

Information

Helpful: 0

Views: 855

Replies: 4

Related Articles