OpenVPN TLS Version error

OpenVPN TLS Version error

OpenVPN TLS Version error
OpenVPN TLS Version error
2023-08-11 13:18:09 - last edited 2023-11-17 11:14:20
Tags: #VPN
Model: Archer VR2100  
Hardware Version:
Firmware Version:

I recently bought an Archer VR2100 and set up the OpenVPN server on it, so I can access my home network when I am out of home. I downloaded the OpenVPN client for my Macbook Air and installed the configuration file. I get an error on the OpenVPN client saying that "Authentication Failed Server TLS Version too low". What is going wrong? Thanks.

  0      
  0      
#1
Options
1 Accepted Solution
Re:OpenVPN TLS Version error-Solution
2023-11-17 11:14:15 - last edited 2023-11-17 11:14:20

  @Gremnet 

 

Hi All,

 

For the OpenVPN TLS Version error issue, please refer to the solution in this thread and let us know if it resolves the problem:

"Authentication failed, Server TLS version is too low" appears when connecting to OpenVPN Server

Recommended Solution
  0  
  0  
#9
Options
19 Reply
Re:OpenVPN TLS Version error
2023-08-14 10:11:48

  @IanDo 

 

Hi, do you mean the OpenVPN client software fails to connect the OpenVPN Server with error "Authentication Failed Server TLS Version too low"?

 

What is the version of your OpenVPN Client software? If possible, please test a lower version client software to see if it has the same error.

 

By the way, what is the hardware and firmware version of your Archer VR2100?

  0  
  0  
#2
Options
Re:OpenVPN TLS Version error
2023-08-16 12:01:25

  @Sunshine 

 

Correct - the OpenVPN client software fails to connect to the OpenVPN Server with error "Authentication Failed Server TLS Version too low"

 

The OpenVPN client software is version 3.4.3.

 

I tried to download an earlier version but it failed to install.

 

FYI - The Tunnelblick client seems to work OK, but I would prefer to use the official OpenVPN client if possible.

 

Thanks,

 

Ian

 

  0  
  0  
#3
Options
Re:OpenVPN TLS Version error
2023-08-21 08:44:14

  @IanDo 

 

Hi, thank you very much for the reply.

May I know what the hardware and firmware version of your Archer VR2100 is?

  0  
  0  
#4
Options
Re:OpenVPN TLS Version error
2023-08-22 09:19:51

Hi @Sunshine 

 

The Hardware is version V1.

 

The firmware is 1.6.0 0.9.1 v009e.0 Build 220518 Rel.41627n

 

Thanks

  0  
  0  
#5
Options
Re:OpenVPN TLS Version error
2023-11-02 15:44:54

Hi,

 

just messing around with exactly the same Problem on a VR2100 and it is VERY annoying !!!

 

at the moment VPN only works with PPTP.

 

so please TP Link, fix this!

 

Regards

Gremnet

  0  
  0  
#6
Options
Re:OpenVPN TLS Version error
2023-11-12 09:13:39
Same problem here. Only use the VPN occasionally but it was definitely working in late August. Now trying to use OPENVPN Client 3.4.0 to connect to VR2100 on latest firmware and get "Authentication Failed Server TLS Version too low"
  0  
  0  
#7
Options
Re:OpenVPN TLS Version error
2023-11-12 12:26:15 - last edited 2023-11-12 12:27:06

  @BrianHS 

 

checked this out:

 

now i'm using OpenVPN Client 2.5.0 on both Windows 7 and 10.

 

It is working!

 

I had to change the IP-Range from 10.0.8.x to 10.0.9.x to get the routing work properly.

 

On Android Version 0.7.5 is working (you have to download the APK from a suitable site)

 

BUT: the old TLS versions are a security risk. TP-Link should fix this in the Firmware or makes it possible to update the Server itself.

 

 

  0  
  0  
#8
Options
Re:OpenVPN TLS Version error-Solution
2023-11-17 11:14:15 - last edited 2023-11-17 11:14:20

  @Gremnet 

 

Hi All,

 

For the OpenVPN TLS Version error issue, please refer to the solution in this thread and let us know if it resolves the problem:

"Authentication failed, Server TLS version is too low" appears when connecting to OpenVPN Server

Recommended Solution
  0  
  0  
#9
Options
Re:OpenVPN TLS Version error
2023-11-17 16:44:08

  @Sunshine 

 

Hello!

 

tried this at a Debian System, it worked.

Have no actual Client installed on Windows, i'll try this next week.

older Client V2.5.0  works on both Win 7 and 10

 

BUT: this is a major security leak anyway, TLS 1.0 is VERY outdated....

 

Regards

Gremnet

  0  
  0  
#10
Options
Re:OpenVPN TLS Version error
2023-11-20 06:52:02

  @Gremnet 

 

Hi, thanks a lot for the feedback, we have reported the issue to our senior engineer and as you can see, we have made beta firmware for some models to support higher TLS version.

  0  
  0  
#11
Options

Information

Helpful: 0

Views: 4048

Replies: 19

Tags

Related Articles