5GHz-2 ONLY, isn't findable by most of my devices

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.

5GHz-2 ONLY, isn't findable by most of my devices

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
5GHz-2 ONLY, isn't findable by most of my devices
5GHz-2 ONLY, isn't findable by most of my devices
2023-09-20 08:52:16 - last edited 2023-09-22 06:42:21
Model: Archer GX90  
Hardware Version:
Firmware Version:

Hello everyone,

I bought the GX90 router yesterday, all works perfectly except that the 5GHz-2 isn't findable by most of my devices.

I can connect to the 5ghz-1 with everything, and the 2.4 as well.

I could only connect to the 5ghz-2 by scanning the QR code with my iphone 12 pro, which should be able to find it wirelessly, and the network itself works well.

I could find the 5ghz-2 only with android devices, like samsung TV and an android phone, but everything else cant.

I tried to to add it manually, but it gives "out of range" message. 

i am trying to connect my Pico 4 (VR headset) to it, it manages to find the 5gh-1, but cant find the 5ghz-2.

I tried to switch the channels and channel width with no luck.

i noticed that the channels are 100-140 (DFS), i checked my country's(IL) regulations and it seems to be okay.

 

Any help would be appreciated 

 

  0      
  0      
#1
Options
1 Accepted Solution
Re:5GHz-2 ONLY, isn't findable by most of my devices-Solution
2023-09-22 06:42:14 - last edited 2023-09-22 06:42:21

  @All_Might 

 

i managed to fix it

for anyone in the future encountering this: the problem is the region setting of the pico,
there are some regions that the headset blocks itself from using the DFS channels.
so to fix: i factory reset the pico, and when you need to choose your country, choose something else like the united states, and the next screen you choose network and it will pop up there. (remember your username and password before u reset, everything you purchased will still be there)

for the iphone it had an old modem firmware, so i upgraded it and it could see it. ( i think you need higher than 4.0)

Recommended Solution
  0  
  0  
#3
Options
3 Reply
Re:5GHz-2 ONLY, isn't findable by most of my devices
2023-09-21 09:22:47

  @All_Might 

 

Hi, what is the hardware and firmware version of your Archer GX90? please make sure it is using the latest firmware version.

 

In addition, since Android devices can find the 5GHz-2 WiFi and connect fine, the router broadcasts 5GHz-2 WiFi properly, for the devices that cannot find the 5GHz-2 WiFi, it is recommended to use WiFi analyzer etc. to scan all wireless networks nearby, if there is any other 5G WiFi using channel 100-140, please check if those devices could find other 5G WiFi with channel 100-140 or not.

If you found the post or response helpful, please click Helpful. If an answer solves your problem, click "Recommended Solution" so that others can benefit from it.
  1  
  1  
#2
Options
Re:5GHz-2 ONLY, isn't findable by most of my devices-Solution
2023-09-22 06:42:14 - last edited 2023-09-22 06:42:21

  @All_Might 

 

i managed to fix it

for anyone in the future encountering this: the problem is the region setting of the pico,
there are some regions that the headset blocks itself from using the DFS channels.
so to fix: i factory reset the pico, and when you need to choose your country, choose something else like the united states, and the next screen you choose network and it will pop up there. (remember your username and password before u reset, everything you purchased will still be there)

for the iphone it had an old modem firmware, so i upgraded it and it could see it. ( i think you need higher than 4.0)

Recommended Solution
  0  
  0  
#3
Options
Re:5GHz-2 ONLY, isn't findable by most of my devices
2023-09-22 07:09:43

  @All_Might 

 

Thanks a lot for the update, which is very helpful. Glad to hear that you've solved the problem, hope you could enjoy the internet!

If you found the post or response helpful, please click Helpful. If an answer solves your problem, click "Recommended Solution" so that others can benefit from it.
  0  
  0  
#4
Options

Information

Helpful: 0

Views: 355

Replies: 3

Related Articles