Server TLS version is too low.

Server TLS version is too low.

Server TLS version is too low.
Server TLS version is too low.
2023-10-28 14:19:27 - last edited 2023-11-17 10:09:09
Tags: #VPN
Model: Archer VR2800  
Hardware Version: V1
Firmware Version: 0.7.0 0.9.1 v006c.0 Build 210313 Rel.74106n

Hi,

 

I have been using OpenVPN on my TP Link Archer for years without any issues. Recently OpenVPN client on my iPhone was updated to 3.4.0 (5457) and it has stopped working with the message 'Authentication Failed. Server TLS version is too low'. I can still connect with previous version of OpenVPN client from my Windows desktop. Unfortunately I can't downgrade the OpenVPN client on my iPhone. Any workaround or firmware update happening? Please help!

 

Server TLS is too low - OpenVPN

 

Thank you.

  0      
  0      
#1
Options
1 Accepted Solution
Re:Server TLS version is too low.-Solution
2023-11-17 06:16:44 - last edited 2023-11-17 10:09:09

  @Ferdyz @Tom1111 @humgurung 

 

Hi, for the issue with error "Authentication failed, Server TLS version is too low" when connecting to OpenVPN Server of TP-Link DSL modem routers, please refer to the solution on this thread and let us know if it resolves the problem:

"Authentication failed, Server TLS version is too low" appears when connecting to OpenVPN Server

Recommended Solution
  0  
  0  
#8
Options
8 Reply
Re:Server TLS version is too low.
2023-10-31 07:23:32

  @humgurung 

 

Hi, please try to download and install the latest firmware to see if it solves the problem:

Firmware Download for Archer VR2800

  0  
  0  
#2
Options
Re:Server TLS version is too low.
2023-11-05 17:57:45

I'm facing the same issue as @humgurung but on a TP Link Archer VR900 v2. There is no new firmware available yet. Do you plan to publish a new one?

  0  
  0  
#3
Options
Re:Server TLS version is too low.
2023-11-11 05:59:46

  @humgurung 

 

Same error since a week ago. Not able to fix it.

I can go to advanced settings and enable risky protocols, but the actual services that I use openVPN for (cctv) don't work anyway.

Needs firmware update.

  0  
  0  
#4
Options
Re:Server TLS version is too low.
2023-11-13 02:15:43

  @Ferdyz 

 

May I know the firmware version of your VR900 V2?

  0  
  0  
#5
Options
Re:Server TLS version is too low.
2023-11-13 02:16:16

  @Tom1111 

 

Hi, what is the model no., hardware and firmware version of your TP-Link device?

  0  
  0  
#6
Options
Re:Server TLS version is too low.
2023-11-15 17:44:56

Hi  @Sunshine 

 

it is as:

 

Device Information

Firmware Version: 1.6.0 0.9.1 v0068.0 Build 220118 RC.71103n

Hardware Version: Archer VR900v v2 00000000

 

  0  
  0  
#7
Options
Re:Server TLS version is too low.-Solution
2023-11-17 06:16:44 - last edited 2023-11-17 10:09:09

  @Ferdyz @Tom1111 @humgurung 

 

Hi, for the issue with error "Authentication failed, Server TLS version is too low" when connecting to OpenVPN Server of TP-Link DSL modem routers, please refer to the solution on this thread and let us know if it resolves the problem:

"Authentication failed, Server TLS version is too low" appears when connecting to OpenVPN Server

Recommended Solution
  0  
  0  
#8
Options
Re:Server TLS version is too low.
2024-01-30 14:46:15

  @Sunshine There is a setting in my android open VPN client (under advanced) which allows insecure connections. Since I use VPN to access home from the mobile netwoek, not to protect transactions from insecure WiFi venues, I can live with this risk.

 

So I ticked the box, and voila, no more 'out of date cersion' error. Just FYI. I am not recommending it.

  0  
  0  
#9
Options

Information

Helpful: 0

Views: 2440

Replies: 8

Tags

Related Articles