AX10 & RDP

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.

AX10 & RDP

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
AX10 & RDP
AX10 & RDP
2023-11-01 08:12:51 - last edited 2023-11-03 08:25:29
Model: Archer AX10  
Hardware Version: V1
Firmware Version: 1.3.9 Build 20230728 Rel. 45716(4555)

Hi, Is it possible to RDP to a Win 11 Pro PC on the same LAN as my S8 Ultra 5G from an AX10?

 

I was able to do this with my Plusnet Hub 2 router and the MS RDP client from Google Play but not with the AX10.

 

I've set up a 'Reserved' IP for the Win 11 PC under DHCP options on the AX10.

 

Tutorials I've read mention setting up 'Virtual Server' on the TP-Link router's NAT Forwarding menu but this option is not included on my AX10.

 

Would I be right to assume the AX10 is not compatible with RDP?

 

I similarly have lost SMB2 access to the same PC since switching to the AX10. all that does work now is SFTP.

  1      
  1      
#1
Options
1 Accepted Solution
Re:AX10 & RDP-Solution
2023-11-02 11:47:29 - last edited 2023-11-03 08:25:29

Thanks both for your input.

It was indeed as easy as I hadn't flipped the new Ethernet connection for the AX10 to 'private network' in Win 11. I guess in the default 'public' mode the firewall blocks most stuff.

Recommended Solution
  0  
  0  
#4
Options
4 Reply
Re:AX10 & RDP
2023-11-01 11:18:21 - last edited 2023-11-02 11:49:01

  @myke52 

 

AX10 allows you to RDP to a MS Windows on a computer in your internal network without opening virtual port TCP 3389.

You need to open this port only in you're trying to access this computer from an external network (from internet).

SMB should work as well in youtr internal network.

Make sure that the connection between AX10 and MS Windows computer is of type Private network - not a Public network.

AX10 also has port forwarding capability which is the same as Virtual Servers in some other TP-Link WebGUI:

 

If this was helpful click once on the arrow pointing upward. If this solves your issue, click once the star to mark it as a "Recommended Solution".
  3  
  3  
#2
Options
Re:AX10 & RDP
2023-11-02 11:11:46

  @myke52 

 

Hi, is your Archer AX10 working on Router Mode or AP mode? NAT Forwarding functions are for router mode only.

 

Besides, the AX10 will not block RDP packets within the LAN by default, are you trying to RDP the Win11 Pro PC within the same LAN network? that is to say, both your phone and the PC are connected to the same router network.

If so, usually port forwarding is not necessary, as it would be needed when you need to access the PC via RDP from an external network.

Please try to disable firewall on the WIN11 Pro PC and make sure it allows to be accessed via RDP.

 

If you found the post or response helpful, please click Helpful. If an answer solves your problem, click "Recommended Solution" so that others can benefit from it.
  1  
  1  
#3
Options
Re:AX10 & RDP-Solution
2023-11-02 11:47:29 - last edited 2023-11-03 08:25:29

Thanks both for your input.

It was indeed as easy as I hadn't flipped the new Ethernet connection for the AX10 to 'private network' in Win 11. I guess in the default 'public' mode the firewall blocks most stuff.

Recommended Solution
  0  
  0  
#4
Options
Re:AX10 & RDP
2023-11-03 08:25:50

  @myke52 

 

Thank you very much for the update, glad to hear that you've solved the problem.

If you found the post or response helpful, please click Helpful. If an answer solves your problem, click "Recommended Solution" so that others can benefit from it.
  0  
  0  
#5
Options

Information

Helpful: 1

Views: 366

Replies: 4

Related Articles