DNS not working at Wireguard server on AX72 [SOLVED]

DNS not working at Wireguard server on AX72 [SOLVED]

DNS not working at Wireguard server on AX72 [SOLVED]
DNS not working at Wireguard server on AX72 [SOLVED]
2023-12-10 16:05:17 - last edited 2024-02-26 01:01:10
Model: Archer AX72  
Hardware Version: V1
Firmware Version: 1.2.1 Build 20230626 rel.36899(4555)

Hello All,

 

My home network looks like this:
ISP router -> AX72 (internet connection details were took by ISP router DHCP) & PiHole with DNS and DHCP server. All LAN devices have broadcasted settings that gateway points to AX72, but DNS pointing to PiHole Device. All is working properly.

I've configured WireGuard on AX72 and profile was imported to Android device. Android device can connect successfully to AX72 from LAN and from internet (port was forwarded from ISP router to AX72) via Wireguard. Devices inside the network are visible from Android device and also see Android device (ping). Wireguard was configured at suggested settings (IP range). During Wireguard's configuration i was able to enable or Disable DNS. I wanna use my PiHole's DNS, so i enabled DNS at Wireguard. Unfortunately Android device can't solve the domain names :( I've tried to point DNS to PiHole device (it's pingable), but without luck. Also tried to use suggested DNS entry during Wireguard's configuration also without luck :( I'm able to ping internet's IP's like 8.8.8.8 from Android Device.

 

Client Access is set to Internet and Home Network at Wireguard server on AX72.

 

Could anyone help with that issue?

 

This is my Wireguard config for Android device:
 

[Interface]
PrivateKey = :):):)
Address = 10.5.5.2/32
DNS = 10.5.5.1

[Peer]
PublicKey = :):):)
PresharedKey = :):):)
AllowedIPs = 0.0.0.0/1,128.0.0.0/1
Endpoint = 192.168.0.202:51820 <=> This is IP of AX72 WAN's interface, used to connect from inside network. For connecting outside the home network here is used IP from ISP.
PersistentKeepalive = 25

  0      
  0      
#1
Options
1 Accepted Solution
Re:DNS not working at Wireguard server on AX72 [SOLVED]-Solution
2024-02-25 15:10:57 - last edited 2024-02-26 01:01:10

  @RonDeChaka Hello.

 

My problem was solved. There was problem with firmware. After Remote session and technical analysis, Support Team provided me beta frimware which fixed the problem. Currently firmware is available to download from official site, so kindly try to update Your router to the newest official firmware and re-check.

 

I hope it will help in Your case.

Recommended Solution
  0  
  0  
#6
Options
8 Reply
Re:DNS not working at Wireguard server on AX72
2023-12-12 08:20:10

  @ktosik87 

 

Hi, 

 

Do you mean setting up PiHole's DNS and also 8.8.8.8 as the WireGuard VPN DNS are both not working?

And how do you confirm the VPN DNS doesn't work? especially when using 8.8.8.8 as the VPN DNS?

 

In your case, if you would like to use PiHole's DNS as your LAN devices DNS and also VPN client DNS, you could also configuring the PiHole's DNS as the WAN DNS of the AX72 Router, you could set it on Advanced->Network->Internet page to see if it works for you.

  0  
  0  
#2
Options
Re:DNS not working at Wireguard server on AX72
2023-12-12 17:36:58 - last edited 2023-12-12 17:37:39

  @Sunshine 

 

Hi :)

 

Do you mean setting up PiHole's DNS and also 8.8.8.8 as the WireGuard VPN DNS are both not working?
Exactly. At config file i've changed below entry:

[Interface]
PrivateKey = :):):)
Address = 10.5.5.2/32
DNS = 10.5.5.1 -> this i'm changing to my PiHole IP or to Google's DNS

 

Also then trying to disable / enable DNS at Wireguard's configuration on AX72 when i changed this config file and re-uploaded in WireGurard app on Android device.

 

And how do you confirm the VPN DNS doesn't work? especially when using 8.8.8.8 as the VPN DNS?

On Android device i have installed Termux software, from which i can use some simple commands like ping. I can ping PiHole IP or 8.8.8.8 IP with successfull reply, but when i try to ping some address by hostname like "google.com" i had information that hostname wasn't found. Offcourse i'm unable to open any website.

 

In your case, if you would like to use PiHole's DNS as your LAN devices DNS and also VPN client DNS, you could also configuring the PiHole's DNS as the WAN DNS of the AX72 Router, you could set it on Advanced->Network->Internet page to see if it works for you.

Yes, currently i had entered 8.8.8.8 as primary DNS and DNS server provided by ISP as secondary. But this is not helps at all since, DHCP server on AX72 is disabled and PiHole is serving DHCP. DHCP service must be enabled on PiHole and disabled on other network devices.

 

Nevertheless, I've tried this before I wrote the post without luck :(

 

  0  
  0  
#3
Options
Re:DNS not working at Wireguard server on AX72
2023-12-13 02:30:08

  @ktosik87 

 

Hi, To assist you efficiently, I've forwarded your case to the TP-Link support engineers who will contact you with your registered email address later.

Please pay attention to your email box for follow-up.

 

  0  
  0  
#4
Options
Re:DNS not working at Wireguard server on AX72
2024-02-25 06:15:24

  @ktosik87 
Not only DNS is not working but also not able to connect to the home IPs like 192.168.0.XXX.

  0  
  0  
#5
Options
Re:DNS not working at Wireguard server on AX72 [SOLVED]-Solution
2024-02-25 15:10:57 - last edited 2024-02-26 01:01:10

  @RonDeChaka Hello.

 

My problem was solved. There was problem with firmware. After Remote session and technical analysis, Support Team provided me beta frimware which fixed the problem. Currently firmware is available to download from official site, so kindly try to update Your router to the newest official firmware and re-check.

 

I hope it will help in Your case.

Recommended Solution
  0  
  0  
#6
Options
Re:DNS not working at Wireguard server on AX72 [SOLVED]
2024-02-25 16:36:18 - last edited 2024-02-25 16:42:20

  @ktosik87 

 

what is the version of the firmware ?

Mine is

Firmware Version :
1.2.2 Build 20230927 rel.58345(5553)
Hardware Version :
Archer AX72 v1.0
  0  
  0  
#7
Options
Re:DNS not working at Wireguard server on AX72 [SOLVED]
2024-02-25 21:05:21 - last edited 2024-02-25 21:13:38

  @RonDeChaka 

Hi,

 

this is mine details:

Firmware Version:

1.2.2 Build 20230927 rel.58345(4555)

Hardware Version:

Archer AX72 v1.0

Please note, that i'm from EU (Poland) area, so it can be differnet versions across the globe.

 

Regarding my problems, that were solved:

- i was able to ping any devices in home network after connecting to wiregurard via wireguard tunnel

- except DNS host from wireguard
- even if could ping device in network that was temporary set as DNS server (except wireguard default host), my device didn't used it

- this occured with DNS server checked and unchecked option at wireguard server's page configuration

 

There were also some other strange behaviours, but it doeasn't matter now (like my printer interferences, evrythinf works on brand new device till my backup copy was restored on it, etc.).

 

On this frimware i don't have any problems. Also i have set to use DNS and specified my own server on client side configurationa and is working - pihole (nslookup, blocking ads etc.)

  0  
  0  
#8
Options
Re:DNS not working at Wireguard server on AX72 [SOLVED]
2024-02-26 06:58:59

  @ktosik87 

 

Okay yeah mine is US version.

 

 

Cool then I will create another thread.

  0  
  0  
#9
Options

Information

Helpful: 0

Views: 462

Replies: 8