Port forwarding not working

Port forwarding not working

Port forwarding not working
Port forwarding not working
2024-01-17 09:58:59
Model: Archer C5  
Hardware Version: V2
Firmware Version: 3.17.6 Build 20150515 Rel. 63652

Hello TP-Link community,

 

I'm currently facing difficulties setting up port forwarding on my Archer C5 v2 router. Here's a breakdown of my configuration:

 

  1. I've assigned a static IP to my PC.
  2. In the router settings, I've created a "virtual server" to forward port 25565 for a Minecraft server I'm hosting for myself and my friends.

 

Despite these configurations, the port doesn't seem to be opening. To troubleshoot, I used Nmap to scan all open ports, and it reports that port 25565 is closed. Additionally, I've tried other port numbers, but none of them seem to be opening either.

 

I'd really appreciate any help or advice in fixing this. Your insights mean a lot to me!

Thank you.

  1      
  1      
#1
Options
18 Reply
Re:Port forwarding not working
2024-01-17 10:26:44 - last edited 2024-01-17 10:28:35

  @RogueMan 

 

Look at the router WAN port IP address here:

 

 

This address should be your public IP address for port-forwarding to work.

You can check that by typing in Google "What's my IP address" and compare with the IP address from the router WebGUI.

If they are different then you're behind double NAT or CG-NAT and that's the reason port-forwarding not working.

If this was helpful click once on the arrow pointing upward. If this solves your issue, click once the star to mark it as a "Recommended Solution".
  1  
  1  
#2
Options
Re:Port forwarding not working
2024-01-17 10:33:49 - last edited 2024-01-17 10:36:13

@terziyski Thank you for your reply. I should've mentioned this is in the question but my ISP is indeed using CG-NAT. I already contacted them last week and they changed my WAN IP so it should support port forwarding. I have scanned my router's local IP (192.168.0.1) using Nmap and the configured ports aren't showing as open ports.

  0  
  0  
#3
Options
Re:Port forwarding not working
2024-01-17 10:52:16

  @RogueMan 

 

Nevertheless you should do the check I mentioned to be sure that your ISP has done the job you've requested.

If your C5 v2 WAN IP address is in these IP ranges the port-forwarding won't work:

 

10.0.0.0 – 10.255.255.255
172.16.0.0 – 172.31.255.255
192.168.0.0 – 192.168.255.255
100.64.0.0 – 100.127.255.255

If this was helpful click once on the arrow pointing upward. If this solves your issue, click once the star to mark it as a "Recommended Solution".
  0  
  0  
#4
Options
Re:Port forwarding not working
2024-01-17 10:55:22

  @terziyski I checked and my WAN IP is not in one of those ranges.

  0  
  0  
#5
Options
Re:Port forwarding not working
2024-01-17 11:03:22

  @RogueMan 

 

If that's the case you may have to open some additional ports on your C5 v2 - refer this thread for details.

If this was helpful click once on the arrow pointing upward. If this solves your issue, click once the star to mark it as a "Recommended Solution".
  0  
  0  
#6
Options
Re:Port forwarding not working
2024-01-17 11:14:44
I have followed the steps in the referred thread (several times) and the port is still not opening. Any other suggestions?
  0  
  0  
#7
Options
Re:Port forwarding not working
2024-01-17 11:24:38 - last edited 2024-01-17 14:46:31

  @RogueMan 

 

A port may indicate itself as closed due to a lack of service behind it as well. Check if your Minecraft server is configured properly.

You may check as well if this port is open on any local firewall that you may have on the hosting machine.

If this was helpful click once on the arrow pointing upward. If this solves your issue, click once the star to mark it as a "Recommended Solution".
  0  
  0  
#8
Options
Re:Port forwarding not working
2024-01-17 11:31:50

  @terziyski 

 

I double-checked the firewall and the server configurations and there don't seem to be any issues. I can connect to the Minecraft server on another computer via the local IP address of the host.

  0  
  0  
#9
Options
Re:Port forwarding not working
2024-01-17 11:48:51

  @RogueMan 

 

There has to be something else that prevents the access to this port. I can confirm that Archer C5 v2 port-forwarding is working properly.

Aside from that there's a newer FW release for this device - here. You can update it manually, but that's not related to your current issue.

If this was helpful click once on the arrow pointing upward. If this solves your issue, click once the star to mark it as a "Recommended Solution".
  0  
  0  
#10
Options
Re:Port forwarding not working
2024-01-17 13:18:54

  @terziyski 

 

I'll check out the firmware update; it might be beneficial to install it even if it's unrelated to the current issue. Any other insights on what might be causing this problem?

  0  
  0  
#11
Options

Information

Helpful: 1

Views: 711

Replies: 18

Related Articles