AX23 change default HTTP management port

AX23 change default HTTP management port

AX23 change default HTTP management port
AX23 change default HTTP management port
2024-02-04 20:07:14
Model: Archer AX23  
Hardware Version: V1
Firmware Version: 1.1.0 Build 20230725 Rel. 56344(4555)

Hi!

 

I'm trying to port forward port 80 to another internal device in my home network.

 

Rule is Simple: external port 80 forward to port 80 of internal device.

 

When I'm trying to access my port forwarded website I'm redirected to my router's external management website with 8443 port.

 

I've also another port forwarding rule related with 443 port: external port 443 od forwarded to port 443 of internal device. This port forwarding is working properly.

 

I think I cannot Access port 80 from internet, because it's fixed for router's management website.

 

How to change default internal ports for router's management website on AX23?

 

It's possible to do that on another routers like ML2330.

 

  0      
  0      
#1
Options
11 Reply
Re:AX23 change default HTTP management port
2024-02-04 20:54:22

  @nitz88 

 

Try this and check how it goes:

 

 

If this was helpful click once on the arrow pointing upward. If this solves your issue, click once the star to mark it as a "Recommended Solution".
  1  
  1  
#2
Options
Re:AX23 change default HTTP management port
2024-02-04 22:01:14

  @terziyski 

 

In my router there is no configuration option for HTTP remote access:

 

I don't know is it only a problem on my router (mistake during firmware upgrade process?) or generally mistake (purpose or not?) of a firmware.

 

Is it possible to pull a request to TP-Link?

  0  
  0  
#3
Options
Re:AX23 change default HTTP management port
2024-02-04 22:04:46

  @nitz88 .

 

I would try login the router via web browser on a PC to check if this option exists.

Apart from that the community admins will see your thread for sure.

If this was helpful click once on the arrow pointing upward. If this solves your issue, click once the star to mark it as a "Recommended Solution".
  0  
  0  
#4
Options
Re:AX23 change default HTTP management port
2024-02-05 11:04:26

  @terziyski 

 

Thank You for reply.

 

On PC situation is the same - option is still missing:

 

  0  
  0  
#5
Options
Re:AX23 change default HTTP management port
2024-02-05 11:54:54

  @nitz88 

 

To be precise I have AX23 router with v1.20 hardware.

  0  
  0  
#6
Options
Re:AX23 change default HTTP management port
2024-02-05 12:14:30

  @nitz88 

 

I have also checked configuration on TP-Link's firmware emulator (https://emulator.tp-link.com/Emulator_AX23v1/index.html#networkMap):

 

 

Part selected in the red square is missing in my router with latest firmware.

  0  
  0  
#7
Options
Re:AX23 change default HTTP management port
2024-02-05 12:23:30

  @nitz88 

 

That's odd. Most of the routers have this option in their web management interface.

I doubt that this settings has been removed. Probably @Sunshine can give some thought on that.

If this was helpful click once on the arrow pointing upward. If this solves your issue, click once the star to mark it as a "Recommended Solution".
  0  
  0  
#8
Options
Re:AX23 change default HTTP management port
2024-02-05 17:23:25

  @nitz88 

 

I have several AX55 routers and they do not have an option to set the HTTP port, only the HTTPS port.

 

  0  
  0  
#9
Options
Re:AX23 change default HTTP management port
2024-02-05 18:41:44

  @jra11500 

 

That's strange. I thought it's a common function on modern routers.

 

In addition this configuration is avalaiable on offical emulator of AX23 router.

 

Is it possible to reverse it back?

  0  
  0  
#10
Options
Re:AX23 change default HTTP management port
2024-02-05 20:04:33

I'll understand if removing router HTTP remote access has been deprecated due to a security concerns.

But when one wants to open router's TCP port 80 for accessing an internally hosted web server:

"Rule is Simple: external port 80 forward to port 80 of internal device.

When I'm trying to access my port forwarded website I'm redirected to my router's external management website with 8443 port."

This prevevnts access to an internally hosted web server on TCP port 80.

If this was helpful click once on the arrow pointing upward. If this solves your issue, click once the star to mark it as a "Recommended Solution".
  0  
  0  
#11
Options

Information

Helpful: 0

Views: 532

Replies: 11