AX72 US V1 wireguard vpn server - LAN connectivity Issue

AX72 US V1 wireguard vpn server - LAN connectivity Issue

AX72 US V1 wireguard vpn server - LAN connectivity Issue
AX72 US V1 wireguard vpn server - LAN connectivity Issue
2024-02-26 09:26:58 - last edited 2024-02-27 15:43:38
Tags: #VPN #WireGuard #vpn server
Model: Archer AX72  
Hardware Version: V1
Firmware Version: Firmware Version: 1.2.2 Build 20230927 rel.58345(5553)

# Problem

Not able to access LAN devices from connecting to wireguard VPN server of Archer ax72

 

# Steps to reproduce

1. Open the router config page

2. Open advance tab

3. Open VPN server and from there enable the wireguard vpn with 10.20.0.1/24 tunnel ip with giving access to home and internet

4. Create user with with allowed ips ( client ) 0.0.0.0/1,128.0.0.1/1 and allowed ips (server) 10.20.0.1/24 and assign  the ip 10.20.0.2/24 to the user

5. enable preshared key and download the config and change the public ip if needed

6. Run it on the device using wireguard client

 

Expected behaviour

1. public Ip change in the vpn connected device

2. Able to access servers in home LAN

3. Home devices able to access VPN devices

 

Working

1. Public IP change of VPN connected device

2. Internet working

 

Trouble shooting attempt

1. adding 192.168.0.1/24 to the allowsed ip (server )

2. changing client allowed ips from 0.0.0.0/1,127.0.0.1/1 to 0.0.0.0/0

 

TLDR

1. internet working through VPN

2. Public IP change in vpn connected device

3. NOT ABLE TO CONNECTED TO LAN DEVICES LIKE 192.168.0.1 or 192.168.0.XXX:3000 ( local speedtest server )

4. NOT ABLE TO CONNECT to the vpn connected devices via ftp or http

  0      
  0      
#1
Options
1 Accepted Solution
Re:AX72 US V1 wireguard vpn server - LAN connectivity Issue-Solution
2024-02-27 12:46:05 - last edited 2024-02-27 15:43:38

  @RonDeChaka 

as per the message I have installed beta firmware.

and LAN connection issue is not here,

 

here are the results

This is speedtest server in my localhost and its giving this results. This is speedtest server in my localhost and its giving this results. ping to 192.168.0.1 from my 5G connection to the router

 

Recommended Solution
  0  
  0  
#4
Options
3 Reply
Re:AX72 US V1 wireguard vpn server - LAN connectivity Issue
2024-02-27 08:23:43

  @RonDeChaka 

 

Hi, I've sent you a private message, please have a check and let us know if it resolves the issue.

If you found the post or response helpful, please click Helpful. If an answer solves your problem, click "Recommended Solution" so that others can benefit from it.
  0  
  0  
#2
Options
Re:AX72 US V1 wireguard vpn server - LAN connectivity Issue-Solution
2024-02-27 12:46:05 - last edited 2024-02-27 15:43:38

  @RonDeChaka 

as per the message I have installed beta firmware.

and LAN connection issue is not here,

 

here are the results

This is speedtest server in my localhost and its giving this results. This is speedtest server in my localhost and its giving this results. ping to 192.168.0.1 from my 5G connection to the router

 

Recommended Solution
  0  
  0  
#4
Options
Re:AX72 US V1 wireguard vpn server - LAN connectivity Issue
2024-02-28 00:50:02

  @RonDeChaka 

 

Thanks a lot for the update, glad to hear that it works now.

If you found the post or response helpful, please click Helpful. If an answer solves your problem, click "Recommended Solution" so that others can benefit from it.
  1  
  1  
#5
Options

Information

Helpful: 0

Views: 532

Replies: 3

Tags

VPN WireGuard
vpn server
Related Articles