Deco XE75 downgrade from 1.3.2

Deco XE75 downgrade from 1.3.2

Deco XE75 downgrade from 1.3.2
Deco XE75 downgrade from 1.3.2
2024-03-28 11:08:34 - last edited 2024-04-01 01:23:13
Model: Deco XE75  
Hardware Version: V1
Firmware Version: 1.3.2

Hello

 

After updating to firmware version 1.3.2 I have multiple issues with clients connecting to 2.4G network. I enabled IOT network, which somehow fixed clients connecting to my main 2.4G network and they stayed connected when I turned the IOT off. But now one device (a indoor monitor from Dahua) can't connect to the cloud, while other monitors connect normally. I also notice that other devices on wirelles network can't access internet but they are connected to WI-FI. So I would like to downgrade to previous version, which was 1.2.9. Can I do that via web UI?

  2      
  2      
#1
Options
1 Accepted Solution
Re:Deco XE75 downgrade from 1.3.2-Solution
2024-03-29 19:55:11 - last edited 2024-04-01 01:23:13

  @David-TP 

Now it's working. So, the Dahua monitors have a static IP address. Even if there was no IP conflict, I enabled DHCP on the monitor that had connection issues and it imediately connected to cloud services. And right after that I changed it back to static IP with the same settings as it was before and it stays connected to the cloud and everything works as it should. I don't know why there was an issue but it sorted out.

Thank you!

Recommended Solution
  1  
  1  
#4
Options
6 Reply
Re:Deco XE75 downgrade from 1.3.2
2024-03-29 09:58:35

  @StaneB Thanks for the feedback.

I believe the firmware downgrade from 1.3.2 to 1.2.9 needs firmware recovery.

How to use firmware recovery on Deco

 

But it is suggested to refer to the following suggestions to see whether it helped with the wireless connection:

1. Please refer to this link to change the WAN DNS server to 8.8.8.8/8.8.4.4.

2. Enable UPNP under Deco APP>More>Advanced>NAT Forwarding

2. Please turn off "Fast roaming" and "Beamforming" under the Deco APP>More>Advanced.

 

Wait for your reply and best regards.

  0  
  0  
#2
Options
Re:Deco XE75 downgrade from 1.3.2
2024-03-29 14:40:52

  @David-TP 

Hello

 

Thank you for the feedback. I did what you suggested but the result is the same. So next step would be a firmware downgrade?

Br

  0  
  0  
#3
Options
Re:Deco XE75 downgrade from 1.3.2-Solution
2024-03-29 19:55:11 - last edited 2024-04-01 01:23:13

  @David-TP 

Now it's working. So, the Dahua monitors have a static IP address. Even if there was no IP conflict, I enabled DHCP on the monitor that had connection issues and it imediately connected to cloud services. And right after that I changed it back to static IP with the same settings as it was before and it stays connected to the cloud and everything works as it should. I don't know why there was an issue but it sorted out.

Thank you!

Recommended Solution
  1  
  1  
#4
Options
Re:Deco XE75 downgrade from 1.3.2
2024-04-16 11:52:14
Hi, where does one get firmware 1.3.2?
  0  
  0  
#5
Options
Re:Deco XE75 downgrade from 1.3.2
2024-04-17 04:17:15

  @Radiolex 

You can get it by using the UPDATE DECO function in the Deco app. I have Deco XE75 version 1.0.

  0  
  0  
#6
Options
Re:Deco XE75 downgrade from 1.3.2
3 weeks ago

David-TP wrote

  @StaneB Thanks for the feedback.

I believe the firmware downgrade from 1.3.2 to 1.2.9 needs firmware recovery.

How to use firmware recovery on Deco

 

But it is suggested to refer to the following suggestions to see whether it helped with the wireless connection:

1. Please refer to this link to change the WAN DNS server to 8.8.8.8/8.8.4.4.

2. Enable UPNP under Deco APP>More>Advanced>NAT Forwarding

2. Please turn off "Fast roaming" and "Beamforming" under the Deco APP>More>Advanced.

 

Wait for your reply and best regards.

  @David-TP Found this thread because my IoT devices all of a sudden lost their mind.  Connections dropping constantly over the last week, etc.  Realized my XE75's had recently taken 1.3.2 so was looking for a way to downgrade.  Decided to try these steps.  1&2 were already set that way by default, but Beamforming was on.  Turned it off and everything stabilized right up.  No problems since.

 

Hope this helps someone.

 

Thanks David-TP for the advice!

  1  
  1  
#8
Options

Information

Helpful: 2

Views: 394

Replies: 6

Related Articles