Archer D5 and "Wake on Wan" not working with firewall enabled

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Archer D5 and "Wake on Wan" not working with firewall enabled
Archer D5 and "Wake on Wan" not working with firewall enabled
2014-10-18 23:17:30
Region : Argentina

Model : TD-W8968

Hardware Version : V3

Firmware Version : 0.9.1 0.4 v002e.0 Build 140804 Rel.40392n

ISP : Telecom Italia


Dear Sirs,

I've bought an Archer D5 to replace a Netgear DGN2200v1 with ModFS: after configuring the new ADSL router I cannot "wake on wan" my PCs with firewall enabled.

This was the situation with Netgear DGN2200v1 with ModFS:

Wake on Lan: working
Wake on Wan: working

and this is the situtation with Archer D5 (same PCs, same switches and same cables)

Wake on Lan: working
Wake on Wan with firewall disabled: working
Wake on Wan with firewall enabled: NOT working

With firewall disabled, WoW is working, so ARP binding and Virtual Servers should be ok.
In any case i paste the virtual server and firewall rule (IP and port are not real):

Virtual server

[CODE]Service Port IP Address Internal Port Protocol Status
44500 10.0.0.4 9 UDP Enabled[/CODE]

Firewall rule

Description: WoW
LAN Host: 10.0.0.4 (LAN HOST defined as 192.168.0.4 / 44500)
WAN Host: Any Host
Schedule: Any Time
Action: Allow
Status: Enabled
Direction: IN
Protocol: UDP

This is the result of nMap online:

[CODE]Starting Nmap 6.45 ( http://nmap.org ) at 2014-10-17 23:45 Central Europe Daylight Time
Nmap scan report for XXX.XXX.XXX.XXX
Host is up.
PORT STATE SERVICE
44500/udp open|filtered unknown
Nmap done: 1 IP address (1 host up) scanned in 2.84 seconds[/CODE]

I've tried to change ports and trying to open all the ports towards 10.0.0.4, but I've not been able to make it working.

Any ideas?
Thank you in advance
0
0
#1
Options
6 Reply
Re:Archer D5 and "Wake on Wan" not working with firewall enabled
2014-10-20 16:59:44
0
0
#2
Options
Re:Archer D5 and "Wake on Wan" not working with firewall enabled
2014-10-20 20:37:13
Thank you for your help. The link you've posted is not valid, but I know what you mean. I've already searched the TP-Link forum but I've not found a problem like mine (at least it seems so). The vast majority is about ARP Binding, Static IP Address or DHCP reservation and missing firewall or pat (virtual server) rules.

My case is a little bit different, probably because a not so obviuos firewall rule is not in place...the "obvious" settings, at least for my understanding, are already there. Probably the next step is Wireshark and a lot of luck. And I don't call "Disabling firewall" as a solution :P
0
0
#3
Options
Re:Archer D5 and "Wake on Wan" not working with firewall enabled
2014-10-21 16:39:23
Tried with Wireshark...with firewall enabled you won't see any wol packet coming from the router. This happens even with a rule that permits all incoming packets. With firewall disabled, you clearly see the WOL packet and it is exactly what I would expect: external dynamic port to UDP port 9. From the first questions by TP-Link local support it seems they don't have a clue what's happening and I'm just in time for returning the D5 to Amazon. Probably the firmware needs improvements, the product is still a bit young.

Anyway thank you for the support. I promise that I will post back about the new router, even if it was my fault and not Archer D5 fault.
Bye.
0
0
#4
Options
Re:Archer D5 and "Wake on Wan" not working with firewall enabled
2014-10-22 19:04:24
It seems that among ADSL wireless 802.11ac router I cannot find an alternative which is WoL from Internet "certified" so Archer D5 will not leave for now.

Another thing that I don't like very much is the virtual servers limit which, in my opionion, is too low for a device of this class (16 entry).

A part from this Archer D5 is very good product and I hope to solve my problem.

Bye.
0
0
#5
Options
Re:Archer D5 and "Wake on Wan" not working with firewall enabled
2014-10-23 16:44:16
The local support is smarter than I thought. I've sent my config files and I wait for their feedback: it seems the anti-flooding that comes with firewall is not "user-removable", so If you enable the firewall every packet forwarding for broadcast address is blocked. From a security point of view it makes perfect sense but I should be free to make my network more vulnerable if I wanted to...
0
0
#6
Options
Re:Archer D5 and "Wake on Wan" not working with firewall enabled
2014-10-24 17:32:11
This is the support answer:

The Archer D5 firewall is a TCP/IP:PORT firewall so the broadcast packets are blocked in both firewall configuration modes (block, passthrough).


:(
0
0
#7
Options