BUG Archer D9 firmware upgrade build 150826

BUG Archer D9 firmware upgrade build 150826
BUG Archer D9 firmware upgrade build 150826
2015-12-02 08:17:28
Hello,

I bought a TP-LINK ARCHER D9 AC1900 WIRELESS DUALBAND GIGABIT ADSL2+ MODEM ROUTER about 42 days ago.
It had been working perfectly for 42 days without any disconnections or errors (pkts), even with over 1 week system uptime.
My new archer with firmware version 0.9.1 0.1 v0041.0 Build 141027 Rel. 40300n (hardware version archer d9 v1 00000000) WAS PERFECT FOR 42 DAYS.
After firmare upgrade to 0.9.1 0.1 v0041.0 Build 150826 Rel. 42046n (hardware version archer d9 v1 00000000) I got these problems.
THIS IS OFFENSIVE FOR A MODEM PAID 150 EURO.

After a disconnection I can't connect again without manually (hardware-physical switch) turning the modem off and on. Even a modem-software reboot doens't let my archer d9 reconnect after a disconnection.
And even the Connecting process is slower than before, about 3 times slower.
And when the modem is connected and I can surf on internet, I get a lot of errors (pkts). It depends: more than 10 but less than 100 errors (pkts). I'd get more than 100 errors if the modem doesn't disconnect.

DSL Modulation Type: ADSL_2plus
Annex Type: Annex A/L
CURRENT RATE UPSTREAM: 640 KBPS;
CURRENT RATE DOWNSTREAM: 16998 KBPS;
SNR MARGIN UPSTREAM: 27dB,
SNR MARGIN DOWNSTREAM: 10dB,
LINE ATTENUATION UPSTREAM: 11.7dB,
LINE ATTENUATION DOWNSTREAM: 22dB.

My ISP company is Infostrada (WIND) in Italy.

I'm furious. Fix the firmware immidiatly! This is outrageous.
In the meantime give me a copy of my old firmware. An official copy from an authorized source/person in order to not void my warranty.
0
0
#1
Options
22 Reply
Re:BUG Archer D9 firmware upgrade build 150826
2015-12-02 16:27:33
You can download the 150826 firmware here.
This is the latest firmware on the website.
You can update it and check if it works fine.
0
0
#2
Options
Re:BUG Archer D9 firmware upgrade build 150826
2015-12-03 15:36:11
Acher D9 set the default "connection type" for my ISP Libero (Wind) and Libero/Wind/Infostrada to ppoa. PPOA is wrong for the most of Infostrada/Wind/Libero adsl connection.
After changing from ppoa to ppoe, I don't have any disconnection anymore.
The old firmware inside archer d9 had ppoe as default connection for my ISP company Libero/Wind/Infostrada.
But I have a lot of Downstream Errors(pkts).
I disabled Bitswap with SNR enabled but I still see a lot of errors(pkts) in the modem control panel,
I disabled SNR and enabled Bitswap but I still get a lot of errors(pkts) in the modem control panel,
I disabled both snr and bitswap and I still get a lot of errors(pkts) in the modem control panel.

What do you advice me? As I told before, with the old firmware I didn't see any errors(pkts) in the modem control panel.
0
0
#3
Options
Re:BUG Archer D9 firmware upgrade build 150826
2016-01-07 03:26:05
I thought I was the only one with this issue but I was seeing exactly the same results.
150826 firmware showed hundreds of errors over several days, whereas the previous firmware 140515 firmware shows 0.
Either there is a firmware issue with 150826 or it is more sensitive to errors and is logging them as such.
Given that I dislike the new UI compared to the old release and also that the bugs fixed on't affect me, I have downgraded the firmware back to 140515.
Also one of the most annoying features of the newer firmware is no readily available 'System Up Time' counter as was on the home page of the older firmwares. I just can't see it anywhere.
I used the config that I had saved previously and now I'm back to 0 errors. Haven't lost anything that I can see.
If you downgrade I'd suggest backing up your 150826 config incase later firmwares fix the problem. You can simply upgrade and reimport the newer config.
I'm staying with 140515 for now and will do so until another release comes out.
0
0
#4
Options
Archer D9(EU)_V1_160303 Firmware
2016-03-24 04:02:31
Anyone tried out the Archer D9(EU)_V1_160303 firmware to see if this fixes the error issues?

Being as you can't downgrade this time I'm more than a little nervous to try it without good reason.
0
0
#5
Options
Re:BUG Archer D9 firmware upgrade build 150826
2016-03-24 07:48:32
We have tried the 160303 firmware. Some bugs are fixed, but several others have been introduced (such as no WiFi 5GHz channels above 46). TP Link seems to have some serious firmware problems with the D7 and the D9. We are waiting for improvements. I would stay with the older firmware for the moment. The "EU" versions are not helpful.
0
0
#6
Options
Re:BUG Archer D9 firmware upgrade build 150826
2016-03-24 17:41:02
Thanks for the reply.
I've never had any performance or other issues with firmware 150514. That I am aware if anyway.
I have always held off upgrades unless I am affected by a specific issue that gets fixed. I also didn't like the new UI particularly.
I'll hold fire again and browse the forums if and when a new firmware is released whether it is any better.
Is there a specific list of issues with my firmware 150514 and the ones after?

Thanks in advance.
0
0
#7
Options
Re:BUG Archer D9 firmware upgrade build 150826
2016-03-24 20:00:25
bugs that firmware 150514 have
1) -
printers can't be shown in the UI after being recognized.
2) -
LED of USB didn't flash after being recognized.
3) -
address reservation is missed
4) - error message not shown
5) - 5Ghz wifi link speed issue
6) - disconnection issue where it
[COLOR=#333333] error [COLOR=#333333]Please try to configure your DNS manually
maybe more .. but i don't encounter them ..

Firmware Build 150826 fix issue from 1 to 4 & New UI
Firmware Build 160303 fix 5GHz old wifi issue ... but new
5GHz issue had been introduced .. (example no upper channel 149 to 161) , sometimes very unstable wifi link speed , unstable speed when USB printer is connected etc..
0
0
#8
Options
Firmware Build 160303 Withdrawn?
2016-03-29 04:45:50

chplff94 wrote

bugs that firmware 150514 have
1) -
printers can't be shown in the UI after being recognized.
2) -
LED of USB didn't flash after being recognized.
3) -
address reservation is missed
4) - error message not shown
5) - 5Ghz wifi link speed issue
6) - disconnection issue where it
[COLOR=#333333] error [COLOR=#333333]Please try to configure your DNS manually
maybe more .. but i don't encounter them ..

Firmware Build 150826 fix issue from 1 to 4 & New UI
Firmware Build 160303 fix 5GHz old wifi issue ... but new
5GHz issue had been introduced .. (example no upper channel 149 to 161) , sometimes very unstable wifi link speed , unstable speed when USB printer is connected etc..


Looks like Firmware Build 160303 has been withdrawn from the site?
Hopefully a newer better one will follow soon.
Sticking with 150514 for now.
0
0
#9
Options
Re:BUG Archer D9 firmware upgrade build 150826
2016-04-05 06:09:13
I am having the same problem which is usually the modem showing disconnected , confguer modem manually. . With 160115 seem to be less but I had to change the NTU to 1492 the default value 1480. and turning off upnp.
0
0
#10
Options
Re:BUG Archer D9 firmware upgrade build 150826
2016-04-18 01:22:27
I
I'm having a lot of trouble with my d7 also

I have to reboot router after intensive 20 minutes of use if i want to have tv and net again. it crashes a lot.

The profile of single edge MEO (Portuguese profile) is wrong. It should be dynamic and it is set to static.

I have ipv6 in my line and it uses dhcp-pd witch i cannot select on the router. Only dhcpv6 or slaac, non of this works.

I test ipv6 and it is working on tp link w8968 v5 and also i have the option to select dynamic or static when i select the meo single edge profile

Adress reservation still have problems, most of my devices sometimes adquire wrong ip's or have dificult to connect.

My tv has wireless and loose connection very often, this didn't happen with the isp device witch is a thomson with wireless range of a phishing rod

Any help or advise on this? I have latest firmware installed. Should i downgrade firmware?

Thanks
0
0
#11
Options