TD-W8960N no wireless connection

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
TD-W8960N no wireless connection
TD-W8960N no wireless connection
2015-12-10 04:05:25
Model :

Hardware Version : Not Clear

Firmware Version :

ISP :

I need help with this problem - I have tried everything.

Out of the box yesterday. Connected to landline without problem - working fine. Put in WiFi settings - nothing. I have pretty much tried everything to get it going without success. Wireless devices will pick up the SSID but it mostly says 'out of range' and this is sitting in front of the modem. I applied the firmware update without anything improving. I did notice in the settings that the Country was defaulted to United States but dont think that would be the problem - I changed it to Australia.

There are times when wireless devices will connect but that last for a few seconds and it drops out and displays out of range. I would be grateful if anyone can solve this problem for me.
  0      
  0      
#1
Options
2 Reply
Re:TD-W8960N no wireless connection
2015-12-11 01:31:14
Wireless is probably faulty, either return for place of purchase for testing/replacement or phone TP-LINK support and ask support and then an RMA if support is unable to help. RMA help when you are dealing with a retailer that is being uncooperative and refuses to replace a faulty product.

All brands have duds out of the box occasionally, I've purchased probably a hundred networking devices and 2-3 had faulty wireless from the get go.
  0  
  0  
#2
Options
Re:TD-W8960N no wireless connection
2015-12-12 02:44:24
Check antennas are properly screwed on all the way til firm if you have a revision of the TD-W8960N with removable antennas.
  0  
  0  
#3
Options