TL-PS110U - Http server no longer working after firmware upgrade

TL-PS110U - Http server no longer working after firmware upgrade
TL-PS110U - Http server no longer working after firmware upgrade
2016-09-08 18:30:16
Model :

Hardware Version :

Firmware Version :

ISP :

Hey everyone first post i have a bit of a problem with my printer server. It still works fine but after downloading the firmware and uploading it the web browser settings page doesn't work. When you scan it with nmap the port is open (80) and if identifies as http but i can't get any other response on that port. It just times out however you can just as easily recognize and use the printer. It even still responds when i ran putty and called it up on telnet but i couldn't find anything to help with my situation.

I had a bit of a search around but i can't seem to find any solutions on this one is there a way to upload firmware again in an attempt to fix it or am i going to have to deal? I suppose it isn't that bad but i still wouldn't mind knowing. I tried that ps wizard thing and couldn't find anything either but i easily miss things.

Its running an epson 1410

All of the settings are standard, ip settings auto.
0
0
#1
Options
5 Reply
Firmware downloaded from tp-link breaks tl-ps110u web interface
2016-09-13 16:31:05
It looks like the firmware for them tl-ps110u print server that is on the tp-link website breaks the web user interface.
Although my printserver still seems to be working. It is now impossible to configure through the web interface.

There seems to be some corruption of the internal webserver files with the browser error showing: ERR_CONTENT_LENGTH_MISMATCH no matter which page you try to reach.

There is some limited configuration ability using telnet but there doesnt seem to be a way to upload new firmware via telnet.

Please tell us how we can fix this!!
0
0
#2
Options
Re:TL-PS110U - Http server no longer working after firmware upgrade
2016-09-13 16:36:31
Yep I agree. I also used the firmware currently posted on the TP-Link website and my print server web interface doesn't work. The browser shows an error ERR_CONTEN_LENGTH_MISMATCH.
It looks like there is some corruption of the web pages or an error with the internal webserver. Weird thing is that it looks like the wrong firmware version is on the TP-Link website.
0
0
#3
Options
TL PS110U Http server no longer working after firmware upgrade
2016-11-12 16:19:21
Yes thats possible. Odd that the laptop is ok and its had the anniversary update. If it hadnt worked either I would just give up on it. How would windows 10 do as a server anyway? would it work headless like WHS does?
0
0
#4
Options
Re:TL-PS110U - Http server no longer working after firmware upgrade
2021-09-17 14:51:43

@derpinbird 

 

Hi there Derpinbird and community,

 

A couple days ago, I came to the TP-Link website to update the firmware for my TL-PS110U device. I downloaded the firmware binary file to my computer and proceeded to upload the firmware file to my printer server. To my horror, the web interface was completely unaccessible. The device would boot up but give me white pages and the console shows a "ERR_CONTENT_LENGTH_MISMATCH" error.

 

It wasn't until I contacted Support that I realized my mistake. Here's the details of that conversation.

 

--------------------

 

Agent Glen_Ford is at your service and hope the service will be satisfactory to you.

2021-09-14 14:45:32

Good day to you! We will be glad to help you out with your inquiry.

Hello?

Hello Brogan, How can i help?

2021-09-14 14:47:39

Hi there. I have a TL-PS110U network printer server, and I just updated to the latest firmware on your website and now I can't use it at all.

 

The web interface doesn't seem to work.

 

Is there a solution for reverting to a previous firmware?

 

Let me check on this

 

kindly provide me a moment

2021-09-14 14:48:44

Thanks.

2021-09-14 14:52:12

Please bear with me for a moment, I will update to you soon. Thank you!

2021-09-14 14:53:44

Okay.

Still checking on this

2021-09-14 14:56:29

Hi Brogan, there is no way for us to revert the previous firmware back to the device

...

 

So essentially your website is serving a firmware update that bricks the device?

2021-09-14 14:58:42

Not really, i'm not quite sure what happen, but that firmware is already almost 2 years on our website. And this is the 1st time heard about this kind of case

Actually, I just found this. https://community.tp-link.com/en/home/forum/topic/90119

 

It seems like this has been a know problem for some time.

2021-09-14 14:59:43

its way back 2016

 

the firmware is 2019

My hardware version is version 2.6 so its almost 11 years old...

the date on the forum is 2016, and the lastest firmware was release 2019

2021-09-14 15:00:44

TL-PS110U_V2_100706

Download
Published Date: 2010-07-06 Language: English File Size: 278.811 KB

That is not the latest firmware

Thats whats showing for hardware version 2.

2021-09-14 15:03:31

Is there anything else I can help you?

Thats not whats showing on your website.

 

https://www.tp-link.com/ca/support/download/tl-ps110u/v2/#Firmware

 

I don't know what you're looking at.

that screen shot is from our website

 

https://www.tp-link.com/us/support/download/tl-ps110u/v2/#Firmware

Yeah, I'm not in the US.

 

I'm Canadian.

 

Your website automatically takes me to the Canadian version of your website.

can you send me the sticker label of the device

2021-09-14 15:07:31

I do apologize but my shift is about to end, let me endorse your case to my colleague to continue the troubleshooting that we are doing.
Please give me at least a minute or 2 to transfer your case.
We do appreciate your understanding.

Okay

The current service has been transferred to Jean.

2021-09-14 15:08:42

Hi, I'm glad to take over this interaction and help.
Please give me a moment to review the chat log and see what has already been discussed, thank you!

Thanks. I need to know if its possible to push the latest firmware to this device without the web interface.

2021-09-14 15:12:56

Please bear with me for a moment, I will update to you soon. Thank you!

 

You're using the Utility,correct?

 

Yeah, but it only seems to let me change the IP address. I'

 

I need to use the web interface but the browser keeps getting an error.

 

192.168.0.10/:1 GET http://192.168.0.10/ net::ERR_CONTENT_LENGTH_MISMATCH 200 (OK)

2021-09-14 15:16:43

The utility doesn't seem to have the ability to do a firmware update.

The Default IP of the print server is 192,168.0.10. Before doing the settings, please confirm the IP of the router. Normally, it’s the gateway IP of your computer.

Listen, I know its connecting to the router and spitting out an error. The IP address isn't the problem.

 

The utility shows the device is there, connected to the network using its default IP, all as expected.

 

The problem is the web interface isn't working and the utility can't replace the firmware.

2021-09-14 15:20:36

Please bear with me for a moment, I will update to you soon. Thank you!

2021-09-14 15:22:23

Thank you for patiently waiting, regarding with this case we do apologize but there's no way to roll back the firmware of it

 

--------------------

 

 

 

So there you have it. On the Canadian TP-Link website, they are serving and older version of the firmware that "bricks" your device and they offer absolutely no solutions to solve the problem. I, however, refused  to have a bricked device. So I investigated my options. After some experimentation, I realized that the web server on the device still receives input and that it simply has a broken response vehicle. The server is generating its pages and messages but they are lost before transmission. That being said, all thats needed to upload a firmware is an interface that can push the POST message with the firmware's file to the server.

 

Thats where this tool I've created comes in.

 

 

Using this simple tool I've created, you too can push a firmware file through the non-existent web interface to recover your printer server. Download the files, extract them to the same directory, open the recovery executable, change any variables, click the Upload Firmware button, once completed you may need to use the Restart button.

 

Written in VB6. Windows required.

 

Thats it. I hope this helps someone!

File:
TLPS11OU FW Recovery.zipDownload
0
0
#5
Options
Re:TL-PS110U - Http server no longer working after firmware upgrade
2022-01-29 19:14:12

@Brogan I can't tell you how thankful I am that I found this thread. it helped me immesley after the 2010 firmware release of the firmware bricked the web interface of my TL-PS110U print server. 

I thought I'd have to install the fimware updates incrementally so I started with the oldest and was going to proceed with the latest after that. 

After the firmware bricked the print server, I donwload your utility along with the latest firware and loaded it. It worked fantastic!

 

The fact that this thread is from 2016 and it has still helped me in 2022 is amazing. Thanks to Brogan!

I have a HP LaserJet Pro 400 Color that has a damaged network port so I added the TP-Link printer server I had laying around to get it back on the network.

 

This thread helped me recover my print server thanks to the efforts of Brogan and his utility.

 

Thanks again!

 

Joe

 

0
0
#6
Options