Deco M4 became brick during update?Please come in~

Used Products:


Last Sunday when I opened my deco app, I noticed that there is a new firmware available for my M4 so I was glad to tap on update and wait for the app to update the firmware. However, the power just cut off suddenly in my house and everything was down including my updating Deco units! I called the electricity company and finally power came back. Unfortunately, when I powered on again my three M4 units, all of them just stuck on startup and showed solid yellow LED. So I guess they all become brick. I tried many attempts to recover, like rebooting, reset, but with no joys. So I sent an email to TP-Link tech support and they replied me quickly with detailed instructions to help recover the router and everything just back to normal again. Thus I decide to share my experience and hope it would help you!

As technical support suggested, first of all I went to TP-Link official website to download the latest firmware for my Deco M4 V1 which is Deco M4(EU)_V1_190620 and unzip it on my PC, then I plugged my PC into the LAN port of the M4.

Secondly, according to the support’s instruction, I setup a static IP address which is with subnet mask as and left others as empty. (If you have no idea how to setup static IP address on your PC, you may refer to this FAQ for some helps:

Thirdly, with the PC still plugging into the M4 with a cable, I powered off the Deco unit, pressed and holding the RESET button on the back panel, then power on the unit while still holding the RESET button. (It’s suggested to put your M4 upside-down since that would be much easier to power on the device while holding the reset button or you may ask your daughter to help plug the power into the M4).Wait for about 10 seconds until the LED become yellow blinking from solid yellow. And now we can release the reset button.

Finally, I opened google chrome and login the page under private browsing mode, and I saw the following page which means this M4 is ready to be updated.

So I chose the unzipped bin file which I have already saved on my PC and click on upgrade, and after 2 minutes the process bar stated as 100% and page shows me the Deco updated successfully like the following page showing!

So excited am I! I checked my Deco M4 and it has white LED again like normal! So I just repeated those steps and updated all of them with the latest firmware finally. Everything works perfectly now! wink



Hi, There is also a detailed FAQ about the firmware recovery instructions for all Deco models;

How to use firmware recovery if the Deco become brick

Thank you.

Hi, I followed the procedure above exactly, successfully installed the new firmware. The TP link is still on solid yellow after I waited 5 min or more.


What next?

I have done a reset again, and the TP link flashes yellow constantly.

I cant get the recovery page to load. It says took to long to respond

I have a Bricked X60 unit and the above procedure does not work. 

Any suggestion or alternative approach?



Didn't work on my x20, it won't enter recovery mode and remains at a yellow solid light following the posted procedures. Is there anything else that can tried?


subsequently, i redesignated a working x20 node as main and my network is up and running on two nodes. Will to tplink replace one of the modes without sending back all three under warranty?  If not, can I replace the x20 main node with a faster upgraded node ie a x55, without replacing the two remaining x20s?