HS100 will connect to network but Kasa always fails setup

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
12
This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
HS100 will connect to network but Kasa always fails setup
HS100 will connect to network but Kasa always fails setup
2017-11-29 04:38:35
I've done this about twenty times now and it fails the same way every time, I've tried modifying my routers wireless settings reducing security,changing SSID visibility, changing from mixed to just 2.4 GHz but to no avail. AP isolation is NOT on. Setup via the Kasa app always gets to the stage where it says it is finishing and connecting to my network, the HS100 wi-fi light turns green and I can see on my router that it has a connection but the app always says the connection has failed and I am stuck with only the option to restart setup. I've tried resetting the HS100, reinstalling the app, I just don't know what more I can do, the HS100 is clearly managing to connect to my network. edit: I forced my phone off the wireless network during this stage and it prompts me to connect to the correct network, searches again and then fails so I know it's attempting to connect on the correct network.
0
0
#1
Options
12 Reply
Re:HS100 will connect to network but Kasa always fails setup
2017-11-29 19:33:07
If the HS100 wifi light turns green that means it has connected to your router. At this moment just log out and log in kasa again then wait a minute and refresh the device list, it should be displayed.
0
0
#2
Options
Re:HS100 will connect to network but Kasa always fails setup
2017-11-29 23:40:44
I just get "No Devices yet!" and the prompt to add a new device. I'm not logging out and in of anything though, I'm just setting this up locally, not via an account.
0
0
#3
Options
Re:HS100 will connect to network but Kasa always fails setup
2017-11-30 02:13:40
I'm having almost the same exact problem. I checked my router settings and I'm pretty sure it's a 2.4ghz router because all of the channels are 2.4XXghz. I follow the directions on the app and I keep having to add it manually. I follow the directions and connect to the TP Link connection like it says, put in the password for my network and it says its finishing up only to say that it has failed.
0
0
#4
Options
Re:HS100 will connect to network but Kasa always fails setup
2017-11-30 03:12:41
think I'm a little closer to the issue, the AP shows the switch as a wireless client but the router does NOT show it as having a DHCP lease
0
0
#5
Options
Same problem
2017-11-30 04:10:47

johnA wrote

I've done this about twenty times now and it fails the same way every time, I've tried modifying my routers wireless settings reducing security,changing SSID visibility, changing from mixed to just 2.4 GHz but to no avail. AP isolation is NOT on. Setup via the Kasa app always gets to the stage where it says it is finishing and connecting to my network, the HS100 wi-fi light turns green and I can see on my router that it has a connection but the app always says the connection has failed and I am stuck with only the option to restart setup. I've tried resetting the HS100, reinstalling the app, I just don't know what more I can do, the HS100 is clearly managing to connect to my network. edit: I forced my phone off the wireless network during this stage and it prompts me to connect to the correct network, searches again and then fails so I know it's attempting to connect on the correct network.


I have the same problem, and I have done everything also. This should be a lot easier. It needs a better ap. Please help me to connect
0
0
#6
Options
Re:HS100 will connect to network but Kasa always fails setup
2017-11-30 17:45:49
What's the OS of your smart phone? If for iOS after the led turn green you need to manually connect your smartphone to router's wifi within certain time.
0
0
#7
Options
Re:HS100 will connect to network but Kasa always fails setup
2017-11-30 21:15:00
It's Android in one of my tests I deliberately forced my phone off the network in the final phase to test it was connecting over the correct network.

I have had a minor breakthrough and managed to create a hotspot with an old phone and used that and it will set up the plug using a duplicate of the settings for my real nework, then when I switch back to the real AP all devices reconnect to it fine....except the HS100. There's defintiely something about my wireless nework it does not like and with no feedback at all from the device or the app it's virtually impossible to tell what it is.
0
0
#8
Options
Re:HS100 will connect to network but Kasa always fails setup
2017-12-01 01:05:12
I used another more basic access point and got the same result, everything works except the HS100, it connects to the AP but gets no IP address. Finally I turned on the dhcp server on the access point and turned it off on the router and it connects the plug, but then no devices connected to the AP can connect to the internet. There looks to be a severe dhcp problem with HS100, it sems related to the AP not being the dhcp server / router, even with a dhcp forwarder it does not work. It looks like it's the HS1000 connection versus everything else on the Access Point. As every other device is playing nice I'm afraid its the HS100 that goes out the door unless I can think of anything else, although I've probably spent times times the HS100s worth of my own time on looking at this now so that is unlikely.
0
0
#9
Options
Re:HS100 will connect to network but Kasa always fails setup
2017-12-01 03:55:03
Very similar issue here. I have a Mini Plug (HS105) that initially connected but would continually drop off the network. I finally took the advice of someone in support and removed the device in Kasa and then tried to reinstall it within Kasa. However it goes through the entire setup fine until it asks me to give it a familiar name; then it fails the renaming. It used to pop up a message saying "Setting name failed: Unable to perform request. Please check your network and try again". After Kasa updated a week or so ago, the message changed to just saying "Failed".

My network connection does change from my regular home network to "TP-Link_Smart Plug_617A" when I try to add the plug back into my network, but I notice that the TP-Link network has no internet connection. Should it?

Anyway this HS105 Mini Plug is completely useless to me as is. Any advice?

Thank you.

Jim
0
0
#10
Options
Re:HS100 will connect to network but Kasa always fails setup
2017-12-01 19:59:25
Well, I finally got it to work by running two dhcp servers on the same vlan, one on the router that works with *every* other device and a second on the access point (for a set of addresses I have excluded from the main pool) which the HS100 is happy connecting to. I had to install custom firmware to allow me to change the dhcp server on the AP to forward on the routers IP as gateway/dns. I may remove this now only the HS100 uses it so it can't phone home.
0
0
#11
Options