Random Disconnects - TL-PA9020P

Random Disconnects - TL-PA9020P
Random Disconnects - TL-PA9020P
2017-12-27 01:57:01
Model :

Hardware Version :

Firmware Version :

ISP :

Model : TL-PA9020P

Hardware Version :

Firmware Version : 3.2.4_902101_170628_901





Hi guys -

I am trying to set up a Powerline network throughout the house but are having major issues so far.
Everything is working fine - speed is decent - and then randomly the connection drops.

Here is a screenshot that shows what both the tpPLC and Mac Network status look like when everything works:






This is what it looks like once the connection drops:

- At first the computer is not able to get an IP at all
- Then it 'Self-Assigns" an IP but still does not have any connection to the internet/router
- The entire time the tpPLC is not able to connect to the Powerline adapter and claims 'No Device Connected'.














To add some more confusion to all this:
- All 3 lights on the unit are green.
- After a while tpPLC sometimes claims that it connected to a powerline adapter but its a 500Mbps unit with different device name (neither exists in our house).





- Once the unit comes back after a while and connects again, I am also receiving completely different information about the speeds when I connect via ethernet vs. via Wifi (via the routher that the Master Powerline adapter is connected to). Shouldn't the speeds be identical?

This is what it looks like connecting via Ethernet:




Via Wifi:




I think it is important to mention here that even though some connections looks really poor (e.g. 11Mbps) they still perform well and achieve the same download/upload performance in a Speedtest.
Another thing that I notice is that while my connection drops, I am able to still see the remaining network of Powerline Adapters via the Wifi. Which means its not a Mode or Router issue.

So far I've done the following to fix this issue without any luck:

- Install latest FW on all units
- Deactivate Sleep/Power Safe mode
- Reset all devices
- Relink all devices
- Switched around units to eliminate that just one faulty unit is causing the issues.

I am curious to hear if you guys have any idea whats going on here.

Thanks for any help.

Cheers!
0
0
#1
Options
3 Replies
Re:Random Disconnects - TL-PA9020P
2017-12-28 05:49:56
Exact same problem with the TL-PA9020P KITs on my side.


- I'm unable to Install latest FW on all units the download fails from TP-Link site
- Deactivate Sleep/Power Safe mode
- Soft Reset all devices
- Relink all devices
- Switched around units to eliminate that just one faulty unit is causing the issues.
- Hard Reset does the trick for a day or two until for no discernable reason it again.
0
0
#2
Options
Re:Random Disconnects - TL-PA9020P
2017-12-28 10:44:16
it seems these devices were slept, maybe you should contact with the support
0
0
#3
Options
Re:Random Disconnects - TL-PA9020P
2017-12-28 23:45:05

p0et wrote

it seems these devices were slept, maybe you should contact with the support


I reached out to them. Will post here if I should find a solution for this issue.
0
0
#4
Options