smart plug not actually turning on light

smart plug not actually turning on light
smart plug not actually turning on light
2019-11-05 20:26:05
Model: HS100
Hardware Version: V2
Firmware Version: 1.5.4

Hello! 

I have tried combing through the depths of the internet to answer my problem, but have found nothing helpful. I'm hoping that I can get some insight here. 
I have two HS100s, and have had them for a couple years with no problems. This morning, the one I use in my room for my plant lights didn't actually turn on the light. I already went through and reset the device, reconnected to the (reset) household WiFi, and made sure the firmware was up-to-date. And I have already checked the light itself, as I initially thought that maybe the bulb went bad, but the light plugged into the power strip directly does indeed turn on. Yes, the light is always in the "on" position, I tried toggling between off and on and nothing happened, and everything on the Kasa app indicates that it should be on - it at least THINKS the light is on. I tried another lamp in my room through the HS100, and that did not turn on, either. As in, I turned on the lamp, unplugged it (I know, probably not the safest thing, but I needed to test this), plugged in the HS100, then the lamp, and it stayed off. Plugged the lamp back into the empty socket (this is directly in a wall, btw, since I already tested a power strip I wanted to test on a wall socket too) after removing the HS100, and it came on, like it should have. Yes, the HS100 power button is illuminated, like it should be, indicating that it's on. 
Could something in the Smart Plug be broken? If so, that's a huge bummer, as I really don't know what could have caused it. It's long out of warranty, so I don't even think it's worth sending in for repairs or anything, but I just really wanted to know if this has happened to anyone else, and if there was a way to fix it. Thanks! 

1
1
#1
Options
8 Replies
Re:smart plug not actually turning on light
2019-11-06 00:02:43

@yossarian 

 

If the smart plug is "clicking" when you try to turn it off or on and nothing happens to the connected appliance then something may have failed internally. 

 

If the purchase date of the device is less then two years then it would still be under warranty.

 

 

0
0
#2
Options
Re:smart plug not actually turning on light
2019-11-06 04:16:25

@Tony 

No, there's no sound at all, which seemed really strange to me. I think I got it around the holidays about two or three years ago. 

0
0
#3
Options
Re:smart plug not actually turning on light
2019-11-06 18:28:22

@yossarian 

 

Sounds like it might be out of warranty.

 

Have you tried to physically press the wireless button which is the physical button to turn what ever is plugged in on or off?

0
0
#4
Options
Re:smart plug not actually turning on light
2019-11-07 20:43:24

@Tony 

Yep! Definitely tried that, too, and nothing happened. 

0
0
#5
Options
Re:smart plug not actually turning on light
2019-11-07 20:50:37

@Tony 

OK I looked and actually, I've still got about two weeks left of the limited warranty. I registered the product and would love to get the RMA process started if at all possible. Thanks!

0
0
#6
Options
Re:smart plug not actually turning on light
2019-11-07 23:04:18 - last edited 2019-11-07 23:05:50

@yossarian

 

You will need to get a hold of our home support.

 

They will go through the troubleshooting as per protocol, and if they determine the device is bad, the replacement process will start (registering, verifying warranty, etc.)

 

Here is the link to get a hold of them: Link

0
0
#7
Options
Re:smart plug not actually turning on light
2019-11-09 07:38:31 - last edited 2019-11-09 08:04:22

I’m having the same problem all of a sudden on 5 different plugs HS100’s. The problem started yesterday. I reset all of them, did a firmware update on the plugs and connected to my WiFi network. All worked fine last night. Today none of them are working again. The lights on the plug are red (not amber). I can press the button on the plugs to turn on the lights that are plugged into the plugs. Tried resetting one of them several times. I can select it in my settings list but it can’t find my WiFi. We also have a Tp-link wall switch that stopped working at the same time. None of our Tp-link devices are working.

 

We have several other smart smart devices (other brands) and Echoes on the network that are working fine. The Tp-link plugs had been working without a problem for a few years. The one I tried resetting today is plugged directly into wall.

 

I purchased all of them in 2016.

0
0
#8
Options
Re:smart plug not actually turning on light
2020-06-27 01:31:39

@Tony  mine is clicking; no response from plug.  Tried on three different lights (LED, pigtail).  Firmware updated, wifi connected,  power sources at wall or power strip. Nothing but a click.  Also out of warranty.  This is plug #4; also have several bulbs-- the rest are fine.  

0
0
#9
Options