Updating smartthings

Updating smartthings
Updating smartthings
2019-12-12 18:12:34
Model: AC50
Hardware Version: V1
Firmware Version:

I have my Kasa account connected to my Smartthings account and just added some new smart plugs to Kasa.  I want to control them in SmartThings but they aren't showing up.  I've tried adding new devices but it just keeps showing me the 2 devices I had previously.  It's been over 2 hours and I don't see a way to make it pull in the new plugs.  Am I missing something or should they "just show up" at some point?

0
0
#1
Options
5 Replies
Re:Updating smartthings
2019-12-15 00:57:17
I have the same problem. Shows up in both my Echo and Google Home accounts, just not SmartThings.
0
0
#2
Options
Re:Updating smartthings
2019-12-16 17:56:41

Just in case someone finds this.  Hopefully this helps them.  The missing devices ended up showing up in SmartThings about 2-3 hours after I added them.  It just took time for them to show up.

0
0
#3
Options
Re:Updating smartthings
2019-12-16 18:08:15

@kasper22 Mine showed up 24 hours later.

0
0
#4
Options
Re:Updating smartthings
2020-01-13 16:09:37

@kasper22 

 

I had set up one smart plug a few days before I got a SmartThings hub / account.  When I used the SmartThings app, I was able to find and add the plug easily.  I then decided to add a second smart plug (after setting it up through the Kasa app), but the SmartThings app did not show it.  Out of curiosity, I deleted the first plug to see if SmartThings would show me both plugs or just the first one when attempting to add devices.  It showed neither.

 

A little more than an hour passed with no success.  I saw this thread and figured I might have to wait a few more hours (or a day) for the plugs to appear.  I then thought about trying to remove my Kasa authorization from the SmartThings app to see if I could reauthorize it and then discover the plugs.  I went into the Settings portion of the SmartThings app (the main app, not the classic app) and clicked on 'Connected services.'  When I clicked on 'TP-Link | Kasa Smart', it suddenly showed both smart plugs!

 

I'm not sure if it was a coincidence or if clicking on the connected service option caused a refresh that the add-device process didn't trigger.  I'm hoping it's the latter in case someone else runs into this issue.

 

1
1
#5
Options
Re:Updating smartthings
2 hours ago

I went into the connected services in the SmartThings settings as you mentioned and it found my missing light switch instantly.  Thank you for this tip. 

@boolittlek 

0
0
#6
Options