AC2600 RE650 VERY slow connection

AC2600 RE650 VERY slow connection
AC2600 RE650 VERY slow connection
2020-03-06 16:23:58

I have the TP-Link AC2600 (RE650) Wi-Fi Range Extender and use the TP-Link App, my wireless modem/router is the AT&T U-Verse. My issue is I have 300Mbps download from my AT&T Wi-Fi but only 20Mbps download through the RE650 (using iPhone to test both). The RE650 is located in line of sight to the AT&T router. I would expect to see the same Mbps or close to it on both units.

 

What am I missing?

 

Dennis

0
0
#1
Options
2 Replies
Re:AC2600 RE650 VERY slow connection
2020-03-06 20:35:33

@Mr_D 

 

Range extenders work in half duplex so look around getting around 50%-60%, take into account of the environment which will drop that speed further.

 

If you have internet from the extender then at that point you need to test every single possible location and see where is the best performance.

 

You can also try this method as well to see if it may help with performance. What it does is to connect one band of the range extender to the router while the other band is made available to wireless devices. 

 

https://www.tp-link.com/us/support/faq/943/

0
0
#2
Options
Re:AC2600 RE650 VERY slow connection
2020-04-15 14:02:23

@Mr_D 

 

Hi,

 

I'm seeing the same thing.  I've been able to recover the speed by rebooting the extender.  Try this to see if it helps.  

 

1. Run some sort of speed test to see what your bandwidth is.  Mine will drop from 150Mbs to 10Mbs over time.  

2. Sleep your computer so it doesn't try to switch networks

3. Power the RE 650 down, wait several seconds and then power it back on

4. Wait until it comes clear back up and is connected (all blue)

5. Start your computer back up and check the speed again. Mine will be back up to 150Mbs.  

 

 

Kind regards

 

Mike

0
0
#3
Options