Static Routes on Archer C1200

Static Routes on Archer C1200
Static Routes on Archer C1200
2020-04-15 21:35:51
Hardware Version: V2
Firmware Version: 2.0.2 Build 20180117 rel.70858 (US)

Hello,

 

I have an Archer C1200 (hardware v2, firmware version 20180117) and I am unable to add static routes.

 

On the web interface, I go to the Advanced tab, then click "Network" and "Advanced Routing". I click "add" to add a new route, then enter the information. For example I want computers on my network to reach the IP addresses 192.168.2.x via 192.168.0.222:

 

Network Destination: 192.168.2.0

Subnet Mask: 255.255.255.0

Default Gateway: 192.168.0.222

Interface: LAN

Enable this entry: (checked)

 

I then click "Save", but the route is not added to the system table and my network is still unable to reach the desired addresses at 192.168.2.x. I have disabled and re-enabled the route, and I have rebooted the router, and neither have resolved the issue.

 

Based on TP-Link's FAQ about static routes, this method should do exactly what I want. Is this a bug in the firmware? If so, is there a workaround?

 

Thanks for your help!

0
0
#1
Options
4 Reply
Re:Static Routes on Archer C1200
2020-04-16 15:37:23

@Ian-Taylor 

 

Even though you do not see it in the system table, does the newly created router show in the static routing section?

 

Would it be possible to show a simple diagram of your topology?

1
1
#2
Options
Re:Static Routes on Archer C1200
2020-04-16 16:49:18

@Tony Thank you very much for your quick reply. I'll try to describe my setup with relevant detail.

 

After adding the static route through the web interface, yes it does appear in the static routing table. Here is a screenshot of what I see after adding the routes:

 

Using the system diagnostics ping tool, I cannot reach a device which I know is at 192.168.2.90:

 

My network

 

There are actually two static routes I would like to add.

  • The devices directly connected to my router (over wifi or ethernet) have IP addresses 192.168.0.x.
  • I have a raspberry pi ("searle") connected to the TP-Link router by Wifi, which acts as a gateway to an HDHomeRun on its ethernet port. The subnet behind the raspberry pi is 192.168.2.x, and the raspberry pi's IP addresses are 192.168.0.222 and 192.168.2.1.
  • I have another raspberry pi ("nightingale") connected to the router by ethernet which is running an OpenVPN server. The VPN clients are in the 10.8.0.x subnet, and the raspberry pi's IP addresses are 192.168.0.254 and 10.8.0.1.

 

Here is a diagram (please excuse the ASCII art laugh):

 

Both Raspberry Pis have the appropriate entries in their routing tables, and routing enabled.

 

Thanks again!

 
0
0
#3
Options
Re:Static Routes on Archer C1200
2020-04-17 18:22:41

@Ian-Taylor 

 

Thank you for the information. I checked and it looks like it should be showing for both entries, not just static routes. I need to look into seeing why that is the case. Were the static routes also set for the raspberry pi devices as well?

0
0
#4
Options
Re:Static Routes on Archer C1200
2020-04-17 18:35:15 - last edited 2020-04-17 18:35:34

@Tony Yes, here are the routing tables and sysctl routing setting for each device:

 

searle:

 

pi@searle:~ $ route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         192.168.0.1     0.0.0.0         UG    303    0        0 wlan0
192.168.0.0     0.0.0.0         255.255.255.0   U     303    0        0 wlan0
192.168.2.0     0.0.0.0         255.255.255.0   U     202    0        0 eth0
pi@searle:~ $ sysctl net.ipv4.ip_forward
net.ipv4.ip_forward = 1

 

nightingale:

 

pi@nightingale:~ $ route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         192.168.0.1     0.0.0.0         UG    202    0        0 eth0
10.8.0.0        0.0.0.0         255.255.255.0   U     0      0        0 tun0
192.168.0.0     0.0.0.0         255.255.255.0   U     202    0        0 eth0
pi@nightingale:~ $ sysctl net.ipv4.ip_forward
net.ipv4.ip_forward = 1


(The Archer C1200 is at 192.168.0.1)

 

Thanks again!

0
0
#5
Options