Firmware for TL-WPA8630(P) TL-PA8033(P) TL-PA8030(P) TL-PA8010(P) QCA75XX-2.11.0.0043

Re:Firmware for TL-WPA8630(P) TL-PA8033(P) TL-PA8030(P) TL-PA8010(P) QCA75XX-2.10.0.0032
2021-02-16 11:21:38

@pstlr78 The problem is similar to what I see. The PIB from the 2.0 firmware is an older version than 2.2 and upwards.

You would need to specify a newer PIB from 2.2 fw for your adapter, and the upgrade process fills in the necessary parameters (network name, etc.) from the one on the adapter if everything runs well. From 2.2 on, you can update straight to 2.10 technically, but then maybe some changes stemming from newer PIBs would not get to your adapter, eg. tone curve optimizations.

 

  1  
  1  
#73
Options
Re:Firmware for TL-WPA8630(P) TL-PA8033(P) TL-PA8030(P) TL-PA8010(P) QCA75XX-2.10.0.0032
2021-02-16 11:58:44

@netadair 

Thanks for that.

So considering that I cannot find any existing pib for 8010p (UK) v1.0 adapters already at 2.2.3 firmware, shall I use PA8010P_V2_UK_2.2.3.pib or am i likely going to (soft)brick my device?

Also, in relation to your second point about losing some features, do you suggest holding off completely from upgrading from 2.0.0 or do the benefits from updating to 2.10 likely outweigh the fact that some features/functions will be lost?

Thanks!

 

  0  
  0  
#74
Options
Re:Firmware for TL-WPA8630(P) TL-PA8033(P) TL-PA8030(P) TL-PA8010(P) QCA75XX-2.10.0.0032
2021-02-16 12:55:11

@pstlr78  8010P 2.0 and 3.0 is based on the QCA7550 whereas 1.0 was based on QCA7500. I am not sure about the exact differences on PIB level between the two.

I checked my pib collection, but didn't find one for 8010P 1.0 (UK). You can use (EU) :) as the only soft difference is probably the tone map anyway.

 

Upgrading is definitely worth it as far as long-term reliability is concerned. Much better yet not 100% with 2.8, and allegedly better with 2.10 . 

 

  0  
  0  
#75
Options
Re:Firmware for TL-WPA8630(P) TL-PA8033(P) TL-PA8030(P) TL-PA8010(P) QCA75XX-2.10.0.0032
2021-02-16 15:33:51
Regarding stability of 2.10, when upgrading one site where I had the isolation problem (in this moment just on one adapter), when upgrading the current CCO and thus on reset the CCO switched to another adapter which already ran 2.10, it let the adapter in isolation happily rejoin the network which was prevented before. So this was promising... In the Trendnet PLC utility, I found an option where it seems a station isolation can be enabled when SIR threshold is above a certain level. Maybe that feature was enabled somehow but just broken before 2.10 ...
  1  
  1  
#76
Options
Re:Firmware for TL-WPA8630(P) TL-PA8033(P) TL-PA8030(P) TL-PA8010(P) QCA75XX-2.10.0.0032
2021-02-16 16:24:54

@netadair 

You were spot on in relation to the necessary steps in order to update from 2.0.0 to 2.10.0. :)

In summary, as a middle (but necessary) step, I used the PA8010P_V2_UK_2.2.3.pib and the 2.2.3 nvm image in order to upgrade my v1.0 PA8010P UK adapters via the Linksys PLA5405 FW Upgrade Tool to 2.2.3.

Subsequently I saved down the pib file (probably this step is not necessary, but I did that just in case).

Finally, I used the extracted pib file along with the 2.10.0 nvm image via the Linksys utility again to get straight to 2.10.0.

I did not even have to pair or reset the adapters after the upgrade!

The other interesting observation was that the powerline rate as per TP link utility increased from circa 250Mbps to circa 350Mbps, with some fluctuation of course. Not sure if that is just a coincidence.

  0  
  0  
#77
Options
Re:Firmware for TL-WPA8630(P) TL-PA8033(P) TL-PA8030(P) TL-PA8010(P) QCA75XX-2.10.0.0032
2021-02-16 17:05:52

@pstlr78 

 

I don't think it is a coincidence. I also saw a significant increase in reported throughput when going from the original firmware on my 8010p and 8630 to the 2.8.x version. From 2.8.x to this last one I haven't seen any significant difference in performance.

 

We all own a very big thanks to @PowerlineFW for essentially doing the work that should be TP-Link's work and provide the community with the latest firmware updates for the Qualcomm devices and obviously to everyone that is participating with helpfull information on this and other threads.

 

@netadair are you the same as the netadair that made the firmware files for flashing openwrt on some WPA8630 devices? If so, a big thank you to you too, as I've used them to get rid of the OEM firmware and flash OpenWRT instead.

 

 

 

  2  
  2  
#78
Options
Re:Firmware for TL-WPA8630(P) TL-PA8033(P) TL-PA8030(P) TL-PA8010(P) QCA75XX-2.10.0.0032
2021-02-17 18:00:38 - last edited 2021-02-17 18:12:54

@turboleak Using as well on WPA8630 V1 OpenWRT. What I don`t linke at OpenWRT is that if you use some additional ipk files then after every OpenWRT software update you need to install these again. For V2 an V2.1 are currently only snapshots available. For V1 is a traget ath79 snapshot available which I did not test.
The installation of version 2.10 on the V1 was done via Zyxel tool with the 8030p pib file and the non stripped nvm file.

  1  
  1  
#79
Options
Re:Firmware for TL-WPA8630(P) TL-PA8033(P) TL-PA8030(P) TL-PA8010(P) QCA75XX-2.10.0.0032
2021-02-17 19:03:17

@PowerlineFW 

 

I own three WPA8630 v1 devices. I also purchased one 8630P v2 and V2.1 to help an OpenWRT developer add support for them into OpenWRT. I have since sold the v2 and v2.1 because they have less flash available for OpenWRT and also the 2.4GHZ radio only goes to 20dbm instead of 22dbm of the 8630 V1.

 

Anyway I build my own firmware, I don't use the ones provided by the automated build system of the OpenWRT project. As such, I compile in all the packages I want and every time I want to upgrade the version I just pull the latest master repository and compile it.

 

Building your own image is very easy, if you have time you have to try it :)

  1  
  1  
#80
Options
Re:Firmware for TL-WPA8630(P) TL-PA8033(P) TL-PA8030(P) TL-PA8010(P) QCA75XX-2.10.0.0032
2021-02-20 13:17:52

@PowerlineFW 

Just a quick heads-up for everyone.

I updated another pair of TL-PA8010P UK adapters, V3.0 this time.

Unlike v1.0 adapters, in order to update from stock 2.6 version to 2.10 I could only do it via the "old" TP Link utility (PowerLine.exe) which is located in the "/recovery/utility/" directory.

Any attempt that was made via the Zyxel utility (in v1.0 adapters this method only worked) or the latest tpPLC utility failed. The Zyxel utility popped-up a message saying that the pib and nvm files are not compatible and the Start button remained grayed out.

I also observed higher performance (~450Mbps) in V3.0 adapters compared to v1.0 adapters (~350Mbps) using the same 2.10 firmware.

  0  
  0  
#81
Options
Re:Firmware for TL-WPA8630(P) TL-PA8033(P) TL-PA8030(P) TL-PA8010(P) QCA75XX-2.10.0.0032
2021-02-20 13:24:29 - last edited 2021-02-20 13:29:22

Sigh. After it looked so good in the beginning, and after mass upgrade on four sites, with 30+ adapers... fw 2.10 is still broken.
Still adapters are locked out and do not (re?)join the network. Maybe there is a (unknown) setting in the pib which controls this lockout.

 

root@ap07:~# plcstat -t
 P/L NET TEI ------ MAC ------ ------ BDA ------  TX  RX CHIPSET FIRMWARE
 LOC STA 000 98:DE:D0:9D:78:7F 98:DE:D0:9D:78:7D n/a n/a QCA7500 MAC-QCA7500-2.10.0.32-01-20200626-CS
root@ap07:~# /root/bin/plckeepalive.sh
Mandatory neighbor not found
Resetting
br-lan 98:DE:D0:9D:78:7F Reset Device
br-lan 98:DE:D0:9D:78:7F Resetting ...
root@ap07:~# plcstat -t
 P/L NET TEI ------ MAC ------ ------ BDA ------  TX  RX CHIPSET FIRMWARE
 LOC STA 005 98:DE:D0:9D:78:7F 98:DE:D0:9D:78:7D n/a n/a QCA7500 MAC-QCA7500-2.10.0.32-01-20200626-CS
 REM CCO 001 F4:06:8D:50:2E:BC 30:B5:C2:86:42:9E 142 070 QCA7500 MAC-QCA7500-2.10.0.32-01-20200626-CS
 REM STA 002 98:DE:D0:9D:6D:7B A4:14:37:2C:6A:F5 064 068 QCA7500 MAC-QCA7500-2.10.0.32-01-20200626-CS
 REM STA 003 30:D3:2D:0A:40:8E A4:14:37:2C:6A:EF 031 039 QCA7500 MAC-QCA7500-2.10.0.32-01-20200626-CS
 REM STA 004 18:A6:F7:A2:03:F6 FF:FF:FF:FF:FF:FF 009 009



root@ap02:~# plcstat -t
 P/L NET TEI ------ MAC ------ ------ BDA ------  TX  RX CHIPSET FIRMWARE
 LOC STA 000 18:A6:F7:A2:03:F6 18:A6:F7:A2:03:F4 n/a n/a QCA7500 MAC-QCA7500-2.1                                                                   0.0.32-01-20200626-CS
root@ap02:~# /root/bin/plckeepalive.sh
Mandatory neighbor not found
Resetting
br-lan 18:A6:F7:A2:03:F6 Reset Device
br-lan 18:A6:F7:A2:03:F6 Resetting ...
root@ap02:~# plcstat -t
 P/L NET TEI ------ MAC ------ ------ BDA ------  TX  RX CHIPSET FIRMWARE
 LOC STA 004 18:A6:F7:A2:03:F6 18:A6:F7:A2:03:F4 n/a n/a QCA7500 MAC-QCA7500-2.10.0.32-01-20200626-CS
 REM CCO 001 F4:06:8D:50:2E:BC 30:B5:C2:86:42:9E 009 009 QCA7500 MAC-QCA7500-2.10.0.32-01-20200626-CS
 REM STA 002 98:DE:D0:9D:6D:7B A4:14:37:2C:6A:F5 041 062 QCA7500 MAC-QCA7500-2.10.0.32-01-20200626-CS
 REM STA 003 30:D3:2D:0A:40:8E A4:14:37:2C:6A:EF 026 037 QCA7500 MAC-QCA7500-2.10.0.32-01-20200626-CS
 REM STA 005 98:DE:D0:9D:78:7F 84:F3:EB:E8:FE:CC 081 079 QCA7500 MAC-QCA7500-2.10.0.32-01-20200626-CS

 

 

 

  0  
  0  
#82
Options