Firmware for TL-WPA4XXX, TP-PA4XXX AV500/AV600 adapters QCA7420-1.5.0.0026

Firmware for TL-WPA4XXX, TP-PA4XXX AV500/AV600 adapters QCA7420-1.5.0.0026
Firmware for TL-WPA4XXX, TP-PA4XXX AV500/AV600 adapters QCA7420-1.5.0.0026
2020-04-19 13:19:55 - last edited 2020-04-19 13:22:08
Model: TL-WPA4220
Hardware Version:
Firmware Version: QCA7420-1.5.0.0026

For TL-WPA4530 TL-WPA4230P TL-WPA4226T TL-WPA4226 TL-WPA4220T TL-WPA4220 TL-WPA4221 TL-WPA4220 TL-PA4020PT TL-PA4022P TL-PA4020P TL-PA4016P TL-PA4020 TL-PA4010P

 

This firmware is with 500Mbit and 600Mbit Adapters compatible of every manufacturer with QCA7420 chip regardless of hardware version.

Update via tpPLC_Utility for Windows or Mac with PIB file of previous firmware update.

 

FW-QCA7420-1.5.0.0026-02-CS-20200114.nvm

https://mega.nz/file/ocNDhYzK#xuSQXd-b6CzzfpSXaK7r5BV4i3pXmnstYMjZX5WEWHc

 

Changes to version 1.5.0.0021 are:

Stability increase

 

This is an official public available firmware.

1
1
#1
Options
10 Replies
Re:Firmware for TL-WPA4XXX, TP-PA4XXX AV500/AV600 adapters QCA7420-1.5.0.0026
2020-05-22 17:45:30
What is the password?
0
0
#2
Options
Re:Firmware for TL-WPA4XXX, TP-PA4XXX AV500/AV600 adapters QCA7420-1.5.0.0026
2020-05-25 22:06:34

@PowerlineFW FW-QCA7420-1.5.0.0026-02-CS-20200114.nvm working great. No drops on IPTV, stable connect.

1
1
#3
Options
Re:Firmware for TL-WPA4XXX, TP-PA4XXX AV500/AV600 adapters QCA7420-1.5.0.0026
2020-07-10 18:22:46

@PowerlineFW Hi, I'm a newcomer to TP-Link Powerline adapters. Where can I download the required PIB file to enable me to install FW-QCA7420-1.5.0.0026-02-CS-20200114.nvm? Thanks in advance.

Linux user for many years. My blog can be found at https://fitzcarraldoblog.wordpress.com/
0
0
#4
Options
Re:Firmware for TL-WPA4XXX, TP-PA4XXX AV500/AV600 adapters QCA7420-1.5.0.0026
3 weeks ago

@PowerlineFW Never mind, I read the PIB from my TP-Link Powerline adapters using open-plc-tools in (https://github.com/qca/open-plc-utils) Linux:

 

$ sudo plctool -i eno1 -p TL-PA4010P.pib <MAC address printed on the adapter>

$ sudo plctool -i eno1 -p TL-PA4010_TV.pib <MAC address printed on the adapter>

$ sudo plctool -i eno1 -p TL-PA4010_HOME-HUB.pib <MAC address printed on the adapter>

$ sudo plctool -i eno1 -p TL-PA4020P.pib <MAC address printed on the adapter>

 

I downloaded FW-QCA7420-1.5.0.0026-02-CS-20200114.nvm from the URL you gave, and installed it with the applicable PIB file using the tpPLC utility for Windows running in a Windows 10 VM (virtual machine) in my Linux installation. I could have used the plctool command in Linux instead to update the firmware, but it was easier for me just to use the TP-Link utility in a Windows VM.

 

Anyway, no more drop-outs. What a difference. Thanks.

 

Just to reiterate, the firmware you posted does work with the following TP-Link Powerline AV600 adapters I have, as they all use the QCA7420 chipset:

 

TL-PA4010

TL-PA4010P

TL-PA4020P

 

Linux user for many years. My blog can be found at https://fitzcarraldoblog.wordpress.com/
0
0
#5
Options
Re:Firmware for TL-WPA4XXX, TP-PA4XXX AV500/AV600 adapters QCA7420-1.5.0.0026
2 weeks ago - last edited 2 weeks ago

@PowerlineFW I've been trying to fix my TL-PA4010(UK) V3 but so far have had no luck flashing the new firmware. I tried through the TP-Link app after downloading my PIB files, but that bricked my adapters. I have tried flashing through plcboot/plctool but can't get the adapters to write the firmware (due to no softloader being present). The TP-Link app fails the firmware update immediately. Do I need a separate softloader file to get the firmware to flash onto my adapters? If so, where can I find that?

0
0
#6
Options
Re:Firmware for TL-WPA4XXX, TP-PA4XXX AV500/AV600 adapters QCA7420-1.5.0.0026
2 weeks ago

@typhoon_2099 I flashed my TL-PA4010 V1 by this firmware and I have no problem.

0
0
#7
Options
Re:Firmware for TL-WPA4XXX, TP-PA4XXX AV500/AV600 adapters QCA7420-1.5.0.0026
2 weeks ago

@2MEX2 What exact commands did you use? Whenever I try to flash I get an error (no NVM softloader present in flash memory, 0x71). I can run the new firmware without flashing but the device is bricked, so doesn't do anything without using plcboot.

0
0
#8
Options
Re:Firmware for TL-WPA4XXX, TP-PA4XXX AV500/AV600 adapters QCA7420-1.5.0.0026
2 weeks ago - last edited 2 weeks ago

@PowerlineFW I used TP-Link utility tpPLC

0
0
#9
Options
Re:Firmware for TL-WPA4XXX, TP-PA4XXX AV500/AV600 adapters QCA7420-1.5.0.0026
2 weeks ago

@2MEX2 Oh. When I used the TP-Link utility it updated for a while then failed, which also bricked my V3 adapters. My V1.2 adapters updated fine, and all 4 were upgraded using their PIBs downloaded from the devices.

0
0
#10
Options
Re:Firmware for TL-WPA4XXX, TP-PA4XXX AV500/AV600 adapters QCA7420-1.5.0.0026
2 weeks ago

@PowerlineFW Where can I find a softloader? I can't get my adapters to save the NVM/PIB to flash without it.

0
0
#11
Options