Signal got worse after firmware update

Signal got worse after firmware update
Signal got worse after firmware update
2020-04-26 12:04:13
Model: TL-WA850RE
Hardware Version: V5
Firmware Version: 1.0.0 Build 20181107 Rel. 73626

Recently I updated to the latest firmware version on my range extender, but my signal got worse.

 

My range extender is in my living room. Before the upgrade, I could use the extender without any issues on my bedroom. However, after the upgrade, I can barely catch the signal in my bedroom and the internet is painfully slow.

 

In the TP-Link router page, I can see that the "Wi-Fi Coverage" is set to Max strenght.

 

Is my only option to downgrade the firmware?

 

Also, I'm not sure if the previous version I was using is available for download. The download page for my router only shows 2 firmwares from 2018, and I think I was using a 2017 firmware.

 

Any help is gratefully appreciated.

0
0
#1
Options
7 Replies
Re:Signal got worse after firmware update
2020-04-27 21:54:00

@mrbeast87 

 

I would first factory default the extender then set it up again to see if that helps. If you are going to downgrade, I would check with local TP-Link support first.

0
0
#2
Options
Re:Signal got worse after firmware update
2020-04-28 22:50:28

@Tony Thanks for your suggestion! I'll try it out tomorrow and report back.

0
0
#3
Options
Re:Signal got worse after firmware update
2020-04-29 12:46:27

@Tony After a factory reset, the router signal hasn't changed... So I guess my only option is to downgrade the firmware unfortunately...

0
0
#4
Options
Re:Signal got worse after firmware update
2020-04-29 21:42:50 - last edited 2020-04-29 21:43:12

I was able to find the 2017 firmware version and downgraded my range extender firmware to the original version. Now I'm able to have internet on my bedroom again.

 

It's a shame that the newest firmware introduced this problem. I don't know what is happening with software development nowadays, but it seems that everytime someone updates something, there is always something that breaks.

0
0
#5
Options
Re:Signal got worse after firmware update
2020-04-30 21:36:32

@mrbeast87 

 

Thank you for the update.

 

You used the firmware from the Portugal website to upgrade your extender?

0
0
#6
Options
Re:Signal got worse after firmware update
2020-05-01 15:12:47 - last edited 2020-05-01 15:13:21

@Tony yes I did! By the way, how did you know I'm from Portugal? Just out of curiosity

0
0
#7
Options
Re:Signal got worse after firmware update
2020-05-01 18:25:37

@mrbeast87 
 

We are able to see the country a user is from when accessing our forums. Pretty much what any website has when visiting it.

0
0
#8
Options